summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm93
1 files changed, 83 insertions, 10 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 46b599a6a7..e808d8ebf6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -465,7 +465,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(package
(inherit go-1.14)
(name "go")
- (version "1.16.12")
+ (version "1.16.13")
(source
(origin
(method git-fetch)
@@ -475,7 +475,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(file-name (git-file-name name version))
(sha256
(base32
- "06c8dcmni38za638ma069izd9kbxr6ii6ccflbibgc6k54lpc3fb"))))
+ "03f37dspn4h5kqf0nqwmnl858wx6hngnlvbnrjl1ll6ihc5j66jz"))))
(arguments
(substitute-keyword-arguments (package-arguments go-1.14)
((#:tests? _) #t)
@@ -624,7 +624,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(package
(inherit go-1.16)
(name "go")
- (version "1.17.5")
+ (version "1.17.6")
(source
(origin
(method git-fetch)
@@ -634,7 +634,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(file-name (git-file-name name version))
(sha256
(base32
- "1yjhg4j89vgb26m35gc0799x2fd0xav03gcvcg2xwcfvvcar5gza"))))
+ "05k292i9qayfy5wh96z4kjmx1mfd5birnr25vb0blzaam72mcsgw"))))
(outputs '("out" "tests")) ; 'tests' contains distribution tests.
(arguments
`(#:modules ((ice-9 match)
@@ -5485,7 +5485,7 @@ golang's database/sql package.")
(define-public go-golang-org-colorful
(package
(name "go-golang-org-colorful")
- (version "1.0.2")
+ (version "1.2.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5494,7 +5494,7 @@ golang's database/sql package.")
(file-name (git-file-name name version))
(sha256
(base32
- "0fig06880bvk1l92j4127v4x9sar4ds7ga8959gxxghb2w70b7l2"))))
+ "08c3fkf27r16izjjd4w94xd1z7w1r4mdalbl53ms2ka2j465s3qs"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/lucasb-eyer/go-colorful"))
@@ -7146,7 +7146,7 @@ transforms one JSON document into another through a JMESPath expression.")
(define-public go-github-com-muesli-reflow-wordwrap
(package
(name "go-github-com-muesli-reflow-wordwrap")
- (version "0.1.0")
+ (version "0.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7155,7 +7155,7 @@ transforms one JSON document into another through a JMESPath expression.")
(file-name (git-file-name "go-github-com-muesli-reflow" version))
(sha256
(base32
- "1vhynm2n1az13fn03lp0gi28p9mznq1mblglh8f2rb9y1vkd2dqr"))))
+ "09zcz2cqdwgj1ilya5pqwndryk6lansn87x63fcm8j1xn74vd2ry"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/muesli/reflow/wordwrap"
@@ -7192,10 +7192,18 @@ io.Writers helping you to transform blocks of text.")
`(#:import-path "github.com/muesli/reflow/padding"
#:unpack-path "github.com/muesli/reflow"))))
+(define-public go-github-com-muesli-reflow-truncate
+ (package
+ (inherit go-github-com-muesli-reflow-wordwrap)
+ (name "go-github-com-muesli-reflow-truncate")
+ (arguments
+ `(#:import-path "github.com/muesli/reflow/truncate"
+ #:unpack-path "github.com/muesli/reflow"))))
+
(define-public go-github-com-muesli-termenv
(package
(name "go-github-com-muesli-termenv")
- (version "0.7.0")
+ (version "0.8.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7204,7 +7212,7 @@ io.Writers helping you to transform blocks of text.")
(file-name (git-file-name name version))
(sha256
(base32
- "09fwrdhy7c9qlf70h97f5inh6xvkfq1vi8fwx9q7bwmjjbiykk8m"))))
+ "0m24ljq1nq7z933fcvg99fw0fhxj9rb5ll4rlay7z2f2p59mrbdp"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/muesli/termenv"))
@@ -8816,6 +8824,71 @@ averages.")
string.")
(license license:expat)))
+
+(define-public go-github-com-charmbracelet-bubbletea
+ (package
+ (name "go-github-com-charmbracelet-bubbletea")
+ (version "0.13.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/charmbracelet/bubbletea")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1105cggi5fwqx69m0vrhgwx6kaw82w4ahn58sj0a81603c4yvrk0"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/charmbracelet/bubbletea"))
+ (propagated-inputs
+ `(("github.com/mattn/go-isatty" ,go-github-com-mattn-go-isatty)
+ ("github.com/muesli/termenv" ,go-github-com-muesli-termenv)
+ ("github.com/mattn/go-runewidth" ,go-github.com-mattn-go-runewidth)
+ ("go-github-com-muesli-reflow-indent" ,go-github-com-muesli-reflow-indent)
+ ("go-github-com-muesli-reflow-ansi" ,go-github-com-muesli-reflow-ansi)
+ ("go-golang-org-colorful" ,go-golang-org-colorful)
+ ("github.com/containerd/console" ,go-github-com-containerd-console)
+ ("go-github-com-muesli-reflow-truncate" ,go-github-com-muesli-reflow-truncate)
+ ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
+ ("go-golang-org-x-sys" ,go-golang-org-x-sys)
+ ("go-golang-org-x-term" ,go-golang-org-x-term)
+ ("github.com/mattn/go-isatty" ,go-github-com-mattn-go-isatty)))
+ (home-page "https://github.com/charmbracelet/bubbletea")
+ (synopsis "Powerful little TUI framework")
+ (description
+ "Bubble Tea is a Go framework based on The Elm Architecture. It is
+well-suited for simple and complex terminal applications, either inline,
+full-window, or a mix of both.")
+ (license license:asl2.0)))
+
+(define-public go-github-com-containerd-console
+ (package
+ (name "go-github-com-containerd-console")
+ (version "1.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/containerd/console")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pgx0y8x23jwc2f9jfk5hd5aslqk599nj6c7dj5846xvnkz2x7p2"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/containerd/console"))
+ (propagated-inputs
+ `(("golang.org/x/sys" ,go-golang-org-x-sys)))
+ (home-page "https://github.com/containerd/console")
+ (synopsis "Console package for Go")
+ (description
+ "This is Golang package for dealing with consoles. It has few
+dependencies and a simple API.")
+ (license license:asl2.0)))
+
(define-public go-github-com-arceliar-ironwood
(package
(name "go-github-com-arceliar-ironwood")