summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm37
1 files changed, 1 insertions, 36 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0277265375..9a7f60fc0a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -78,6 +78,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages golang-check)
#:use-module (gnu packages lua)
#:use-module (gnu packages mail)
#:use-module (gnu packages mp3)
@@ -4588,42 +4589,6 @@ Go.")
slices, JSON and other data.")
(license license:expat)))
-(define-public go-github-com-stretchr-testify
- (package
- (name "go-github-com-stretchr-testify")
- (version "1.7.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stretchr/testify")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ixgjsvafr3513pz3r6pmgk074s2dxkll0dadvl25gkf30rkmh10"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/stretchr/testify"))
- (propagated-inputs
- `(("github.com/davecgh/go-spew" ,go-github-com-davecgh-go-spew)
- ("github.com/pmezard/go-difflib" ,go-github-com-pmezard-go-difflib)
- ("github.com/stretchr/objx" ,go-github-com-stretchr-objx)
- ("gopkg.in/yaml.v3" ,go-gopkg-in-yaml-v3)))
- (home-page "https://github.com/stretchr/testify")
- (synopsis "Go helper library for tests and invariant checking")
- (description "This package provide many tools for testifying that your
-code will behave as you intend.
-
-Features include:
-@itemize
-@item Easy assertions
-@item Mocking
-@item HTTP response trapping
-@item Testing suite interfaces and functions.
-@end itemize")
- (license license:expat)))
-
(define go-github-com-stretchr-testify-bootstrap
(package
(inherit go-github-com-stretchr-testify)