summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0f80d4aba7..a093728805 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2107,7 +2107,7 @@ specified by @uref{https://tools.ietf.org/html/rfc2141, IETF RFC 2141}.")
(define-public go-github.com-jessevdk-go-flags
(package
(name "go-github.com-jessevdk-go-flags")
- (version "1.3.0")
+ (version "1.5.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2115,11 +2115,19 @@ specified by @uref{https://tools.ietf.org/html/rfc2141, IETF RFC 2141}.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "1jk2k2l10lwrn1r3nxdvbs0yz656830j4khzirw8p4ahs7c5zz36"))))
+ (base32 "13ixw1yx4bvcj66lkc8zgwf9j7gkvj686g991gycdsafvdvca0lj"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/jessevdk/go-flags"))
+ '(#:import-path "github.com/jessevdk/go-flags"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ ;; SOURCE_DATE_EPOCH messes with the date on the man page test.
+ (substitute* "src/github.com/jessevdk/go-flags/help_test.go"
+ (("TestMan") "DisabledTestMan")))))))
+ (propagated-inputs
+ (list go-golang-org-x-sys))
(synopsis "Go library for parsing command line arguments")
(description
"The @code{flags} package provides a command line option parser. The