summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm290
1 files changed, 218 insertions, 72 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a3b1c6c643..2c31632db6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright @ 2018, 2019 Katherine Cox-Buday <cox.katherine.e@gmail.com>
+;;; Copyright @ 2018, 2019, 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright @ 2019 Giovanni Biscuolo <g@xelera.eu>
;;; Copyright @ 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
@@ -218,21 +218,28 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(supported-systems '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux"))
(license license:bsd-3)))
-(define-public go-1.13
+(define-public go-1.14
(package
(inherit go-1.4)
(name "go")
- (version "1.13.9")
+ (version "1.14.4")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://storage.googleapis.com/golang/"
- name version ".src.tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/golang/go")
+ (commit (string-append "go" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "07gksk9194wa90xyd6yhagxfv7syvsx29bh8ypc4mg700vc1kfrl"))))
+ "08bazglmqp123c9dgrxflvxd011xsqfxsgah2kzbvca0mhm6qcm3"))))
(arguments
(substitute-keyword-arguments (package-arguments go-1.4)
+ ((#:system system)
+ (if (string-prefix? "aarch64-linux" (or (%current-system)
+ (%current-target-system)))
+ "aarch64-linux"
+ system))
((#:phases phases)
`(modify-phases ,phases
(replace 'prebuild
@@ -261,7 +268,13 @@ in the style of communicating sequential processes (@dfn{CSP}).")
'("cmd/go/testdata/script/mod_case_cgo.txt"
"cmd/go/testdata/script/list_find.txt"
"cmd/go/testdata/script/list_compiled_imports.txt"
- "cmd/go/testdata/script/cgo_syso_issue29253.txt"))
+ "cmd/go/testdata/script/cgo_syso_issue29253.txt"
+ "cmd/go/testdata/script/cover_cgo.txt"
+ "cmd/go/testdata/script/cover_cgo_xtest.txt"
+ "cmd/go/testdata/script/cover_cgo_extra_test.txt"
+ "cmd/go/testdata/script/cover_cgo_extra_file.txt"))
+
+ (for-each make-file-writable (find-files "."))
(substitute* "os/os_test.go"
(("/usr/bin") (getcwd))
@@ -329,6 +342,10 @@ in the style of communicating sequential processes (@dfn{CSP}).")
("syscall/exec_linux_test.go"
"(.+)(TestCloneNEWUSERAndRemapNoRootDisableSetgroups.+)")))
+ ;; These tests fail on aarch64-linux
+ (substitute* "cmd/dist/test.go"
+ (("t.registerHostTest\\(\"testsanitizers/msan.*") ""))
+
;; fix shebang for testar script
;; note the target script is generated at build time.
(substitute* "../misc/cgo/testcarchive/carchive_test.go"
@@ -360,7 +377,6 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(setenv "GOROOT_FINAL" output)
(setenv "CGO_ENABLED" "1")
(invoke "sh" "all.bash"))))
-
(replace 'install
;; TODO: Most of this could be factorized with Go 1.4.
(lambda* (#:key outputs #:allow-other-keys)
@@ -406,7 +422,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
,@(package-native-inputs go-1.4)))
(supported-systems %supported-systems)))
-(define-public go go-1.13)
+(define-public go go-1.14)
(define-public go-github-com-alsm-ioprogress
(let ((commit "063c3725f436e7fba0c8f588547bee21ffec7ac5")
@@ -417,7 +433,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/alsm/ioprogress.git")
+ (url "https://github.com/alsm/ioprogress")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -443,7 +459,7 @@ writers can be supplied for alternate environments.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/aki237/nscjar.git")
+ (url "https://github.com/aki237/nscjar")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -493,7 +509,7 @@ way of specifying command line options.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/go-tomb/tomb.git")
+ (url "https://github.com/go-tomb/tomb")
(commit commit)))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
@@ -846,7 +862,7 @@ time.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/BurntSushi/toml.git")
+ (url "https://github.com/BurntSushi/toml")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -871,7 +887,7 @@ is similar to Go's standard library @code{json} and @code{xml} package.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/getsentry/raven-go.git")
+ (url "https://github.com/getsentry/raven-go")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -900,7 +916,7 @@ logging system.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/hashicorp/go-version.git")
+ (url "https://github.com/hashicorp/go-version")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -930,7 +946,7 @@ increment versions.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/jpillora/backoff.git")
+ (url "https://github.com/jpillora/backoff")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -953,7 +969,7 @@ Go.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/stretchr/objx.git")
+ (url "https://github.com/stretchr/objx")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -976,7 +992,7 @@ slices, JSON and other data.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/stretchr/testify.git")
+ (url "https://github.com/stretchr/testify")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -1015,7 +1031,7 @@ Features include:
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/tevino/abool.git")
+ (url "https://github.com/tevino/abool")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -1040,7 +1056,7 @@ optimized for performance yet simple to use.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/blang/semver.git")
+ (url "https://github.com/blang/semver")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -1064,7 +1080,7 @@ optimized for performance yet simple to use.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/emicklei/go-restful.git")
+ (url "https://github.com/emicklei/go-restful")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -1090,7 +1106,7 @@ with the HTTP protocol definition.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/google/cadvisor.git")
+ (url "https://github.com/google/cadvisor")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -1116,7 +1132,7 @@ containers.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/google/gofuzz.git")
+ (url "https://github.com/google/gofuzz")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -1141,7 +1157,7 @@ values for the purpose of fuzz testing.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/gorilla/context.git")
+ (url "https://github.com/gorilla/context")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -1165,7 +1181,7 @@ values for the purpose of fuzz testing.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/gorilla/mux.git")
+ (url "https://github.com/gorilla/mux")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -1191,7 +1207,7 @@ incoming requests with their respective handler.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/jonboulle/clockwork.git")
+ (url "https://github.com/jonboulle/clockwork")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -1227,8 +1243,9 @@ incoming requests with their respective handler.")
(propagated-inputs
`(("golang.org/x/text" ,go-golang-org-x-text)))
(home-page "https://github.com/spf13/afero")
- (synopsis "Filesystem abstraction for Go")
- (description "Filesystem abstraction for Go")
+ (synopsis "File system abstraction for Go")
+ (description
+ "This package provides a file system abstraction for Go.")
(license license:asl2.0)))
(define-public go-github-com-spf13-cast
@@ -1312,7 +1329,7 @@ applications as well as a program to generate applications and command files.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/spf13/pflag.git")
+ (url "https://github.com/spf13/pflag")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -1339,7 +1356,7 @@ GNU extensions} to the POSIX recommendations for command-line options.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/spf13/viper.git")
+ (url "https://github.com/spf13/viper")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -1476,7 +1493,7 @@ all types of configuration needs and formats.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/sirupsen/logrus.git")
+ (url "https://github.com/sirupsen/logrus")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -1505,7 +1522,7 @@ compatible with the standard library logger.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/rifflock/lfshook.git")
+ (url "https://github.com/rifflock/lfshook")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -1519,7 +1536,7 @@ compatible with the standard library logger.")
(home-page "https://github.com/rifflock/lfshook")
(synopsis "Local File System hook for Logrus logger")
(description "This package provides a hook for Logrus to write directly to
-a file on the filesystem. The log levels are dynamic at instantiation of the
+a file on the file system. The log levels are dynamic at instantiation of the
hook, so it is capable of logging at some or all levels.")
(license license:expat)))
@@ -1638,7 +1655,7 @@ to interact with distribution components.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/docker/go-connections.git")
+ (url "https://github.com/docker/go-connections")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -1665,7 +1682,7 @@ translation (NAT), proxies, sockets, and transport layer security (TLS).")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/docker/machine.git")
+ (url "https://github.com/docker/machine")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -1692,7 +1709,7 @@ Docker on them, then configures the Docker client to talk to them.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/gorhill/cronexpr.git")
+ (url "https://github.com/gorhill/cronexpr")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2225,7 +2242,7 @@ generation features. This code generation is used to achieve:
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/libp2p/go-flow-metrics.git")
+ (url "https://github.com/libp2p/go-flow-metrics")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2251,7 +2268,7 @@ that's a lot faster (and only does simple bandwidth metrics).")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/davecgh/go-spew.git")
+ (url "https://github.com/davecgh/go-spew")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2291,7 +2308,7 @@ style).
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/btcsuite/btclog.git")
+ (url "https://github.com/btcsuite/btclog")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2317,7 +2334,7 @@ implementing the same interface.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/btcsuite/btcd.git")
+ (url "https://github.com/btcsuite/btcd")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2353,7 +2370,7 @@ needing to use secp256k1 elliptic curve cryptography.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/minio/sha256-simd.git")
+ (url "https://github.com/minio/sha256-simd")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2389,7 +2406,7 @@ Architecture Processors\" by J. Guilford et al.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/libp2p/go-libp2p-crypto.git")
+ (url "https://github.com/libp2p/go-libp2p-crypto")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2419,7 +2436,7 @@ Architecture Processors\" by J. Guilford et al.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/mr-tron/base58.git")
+ (url "https://github.com/mr-tron/base58")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2446,7 +2463,7 @@ encoding and 8 times faster decoding.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/gxed/hashland.git")
+ (url "https://github.com/gxed/hashland")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2472,7 +2489,7 @@ hash algorithm. See http://keccak.noekeon.org.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/minio/blake2b-simd.git")
+ (url "https://github.com/minio/blake2b-simd")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2502,7 +2519,7 @@ increase approaching hashing speeds of 1GB/sec on a single core.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/spaolacci/murmur3.git")
+ (url "https://github.com/spaolacci/murmur3")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2528,7 +2545,7 @@ required by Go's standard Hash interface.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/twmb/murmur3.git")
+ (url "https://github.com/twmb/murmur3")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2556,7 +2573,7 @@ required by Go's standard Hash interface.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/multiformats/go-multihash.git")
+ (url "https://github.com/multiformats/go-multihash")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2587,7 +2604,7 @@ required by Go's standard Hash interface.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/libp2p/go-libp2p-peer.git")
+ (url "https://github.com/libp2p/go-libp2p-peer")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2622,7 +2639,7 @@ required by Go's standard Hash interface.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/libp2p/go-libp2p-protocol.git")
+ (url "https://github.com/libp2p/go-libp2p-protocol")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2647,7 +2664,7 @@ required by Go's standard Hash interface.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/libp2p/go-libp2p-metrics.git")
+ (url "https://github.com/libp2p/go-libp2p-metrics")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2686,7 +2703,7 @@ statistics for wrapped connections.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/mitchellh/go-homedir.git")
+ (url "https://github.com/mitchellh/go-homedir")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2747,7 +2764,7 @@ cross-compilation.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/multiformats/go-multiaddr.git")
+ (url "https://github.com/multiformats/go-multiaddr")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2789,7 +2806,7 @@ does the following:
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/multiformats/go-multiaddr-net.git")
+ (url "https://github.com/multiformats/go-multiaddr-net")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2827,7 +2844,7 @@ as conversion to and from @command{net.Addr}.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/whyrusleeping/tar-utils.git")
+ (url "https://github.com/whyrusleeping/tar-utils")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2852,7 +2869,7 @@ as conversion to and from @command{net.Addr}.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/cheekybits/is.git")
+ (url "https://github.com/cheekybits/is")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2884,7 +2901,7 @@ as conversion to and from @command{net.Addr}.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/sabhiram/go-gitignore.git")
+ (url "https://github.com/sabhiram/go-gitignore")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2909,7 +2926,7 @@ as conversion to and from @command{net.Addr}.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/urfave/cli.git")
+ (url "https://github.com/urfave/cli")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -3038,7 +3055,7 @@ anchor names.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/whyrusleeping/json-filter.git")
+ (url "https://github.com/whyrusleeping/json-filter")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -3064,7 +3081,7 @@ anchor names.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/whyrusleeping/progmeter.git")
+ (url "https://github.com/whyrusleeping/progmeter")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -3089,7 +3106,7 @@ anchor names.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/whyrusleeping/stump.git")
+ (url "https://github.com/whyrusleeping/stump")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -3114,7 +3131,7 @@ have super fancy logs.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/kr/fs.git")
+ (url "https://github.com/kr/fs")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -3161,7 +3178,7 @@ format in Go.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/kr/pretty.git")
+ (url "https://github.com/kr/pretty")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -3184,7 +3201,7 @@ format in Go.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/kr/text.git")
+ (url "https://github.com/kr/text")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -3529,7 +3546,7 @@ decode/encode structures and slices.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/pkg/errors.git")
+ (url "https://github.com/pkg/errors")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -3615,6 +3632,135 @@ sensors).")
(home-page "https://github.com/shirou/gopsutil")
(license license:bsd-3))))
+(define-public go-github-com-danwakefield-fnmatch
+ (let ((commit "cbb64ac3d964b81592e64f957ad53df015803288")
+ (revision "0"))
+ (package
+ (name "go-github-com-danwakefield-fnmatch")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danwakefield/fnmatch")
+ (commit commit)))
+ (sha256
+ (base32
+ "0cbf511ppsa6hf59mdl7nbyn2b2n71y0bpkzbmfkdqjhanqh1lqz"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/danwakefield/fnmatch"))
+ (home-page "https://github.com/danwakefield/fnmatch")
+ (synopsis "Updated clone of kballards golang fnmatch gist")
+ (description "This package provides an updated clone of kballards golang
+fnmatch gist (https://gist.github.com/kballard/272720).")
+ (license license:bsd-2))))
+
+(define-public go-github-com-ddevault-go-libvterm
+ (let ((commit "b7d861da381071e5d3701e428528d1bfe276e78f")
+ (revision "0"))
+ (package
+ (name "go-github-com-ddevault-go-libvterm")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ddevault/go-libvterm")
+ (commit commit)))
+ (sha256
+ (base32
+ "06vv4pgx0i6hjdjcar4ch18hp9g6q6687mbgkvs8ymmbacyhp7s6"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/ddevault/go-libvterm"))
+ (propagated-inputs
+ `(("go-github-com-mattn-go-pointer" ,go-github-com-mattn-go-pointer)))
+ (home-page "https://github.com/ddevault/go-libvterm")
+ (synopsis "Go binding to libvterm")
+ (description
+ "This is a fork of another go-libvterm library for use with aerc.")
+ (license license:expat))))
+
+(define-public go-github-com-emersion-go-imap
+ (package
+ (name "go-github-com-emersion-go-imap")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-imap")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1id8j2d0rn9sj8y62xhyygqpk5ygrcl9jlfx92sm1jsvxsm3kywq"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/emersion/go-imap"))
+ (native-inputs
+ `(("go-golang-org-x-text" ,go-golang-org-x-text)))
+ (home-page "https://github.com/emersion/go-imap")
+ (synopsis "IMAP4rev1 library written in Go")
+ (description "This package provides an IMAP4rev1 library written in Go. It
+can be used to build a client and/or a server.")
+ (license license:expat)))
+
+(define-public go-github-com-emersion-go-sasl
+ (let ((commit "240c8404624e076f633766c16adbe96c7ac516b7")
+ (revision "0"))
+ (package
+ (name "go-github-com-emersion-go-sasl")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-sasl")
+ (commit commit)))
+ (sha256
+ (base32
+ "1py18p3clp474xhx6ypyp0bgv6n1dfm24m95cyyqb0k3vibar6ih"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/emersion/go-sasl"))
+ (home-page "https://github.com/emersion/go-sasl")
+ (synopsis "SASL library written in Go")
+ (description "This package provides a SASL library written in Go.")
+ (license license:expat))))
+
+(define-public go-github-com-emersion-go-imap-idle
+ (let ((commit "2704abd7050ed7f2143753554ee23affdf847bd9")
+ (revision "0"))
+ (package
+ (name "go-github-com-emersion-go-imap-idle")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-imap-idle")
+ (commit commit)))
+ (sha256
+ (base32
+ "0blwcadmxgqsdwgr9m4jqfbpfa2viw5ah19xbybpa1z1z4aj5cbc"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/emersion/go-imap-idle"))
+ (native-inputs
+ `(("go-github-com-emersion-go-imap" ,go-github-com-emersion-go-imap)
+ ("go-github-com-emersion-go-sasl" ,go-github-com-emersion-go-sasl)
+ ("go-golang-org-x-text" ,go-golang-org-x-text)))
+ (home-page "https://github.com/emersion/go-imap-idle")
+ (synopsis "IDLE extension for go-imap")
+ (description "This package provides an IDLE extension for go-imap.")
+ (license license:expat))))
+
(define-public go-github-com-fatih-color
(package
(name "go-github-com-fatih-color")
@@ -3622,7 +3768,7 @@ sensors).")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/fatih/color.git")
+ (url "https://github.com/fatih/color")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -3644,7 +3790,7 @@ colorized or SGR defined output to the standard output.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/google/go-cmp.git")
+ (url "https://github.com/google/go-cmp")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -3692,7 +3838,7 @@ common task.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/gotestyourself/gotest.tools.git")
+ (url "https://github.com/gotestyourself/gotest.tools")
(commit (string-append "v" version))))
(file-name (git-file-name "go-gotest-tools" version))
(sha256
@@ -3768,7 +3914,7 @@ test when a comparison fails.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/gotestyourself/gotestsum.git")
+ (url "https://github.com/gotestyourself/gotestsum")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -3815,7 +3961,7 @@ test results.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/golang/protobuf.git")
+ (url "https://github.com/golang/protobuf")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -3840,7 +3986,7 @@ data serialization format.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/mattn/go-zglob.git")
+ (url "https://github.com/mattn/go-zglob")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256