summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm43
1 files changed, 1 insertions, 42 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c863388475..71596a9a54 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8664,48 +8664,7 @@ non-cryptographic hash algorithm, working at speeds close to RAM limits.")
(license license:asl2.0)))
(define-public go-github-com-aswinkarthik-csvdiff
- (package
- (name "go-github-com-aswinkarthik-csvdiff")
- (version "1.4.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/aswinkarthik/csvdiff")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0cd1ikxsypjqisfnmr7zix3g7x8p892w77086465chyd39gpk97b"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/aswinkarthik/csvdiff"))
- (propagated-inputs
- (list go-golang-org-x-sys
- go-github-com-stretchr-testify
- go-github-com-spf13-cobra
- go-github-com-spf13-afero
- go-github-com-spaolacci-murmur3
- go-github-com-mattn-go-colorable
- go-github-com-fatih-color
- go-github-com-cespare-xxhash
- go-github-com-oneofone-xxhash))
- (home-page "https://github.com/aswinkarthik/csvdiff")
- (synopsis "Fast diff tool for comparing CSV files")
- (description "@code{csvdiff} is a diff tool to compute changes between two
-CSV files. It can compare CSV files with a million records in under 2
-seconds. It is specifically suited for comparing CSV files dumped from
-database tables. GNU Diff is orders of magnitude faster for comparing line by
-line. @code{csvdiff} supports
-
-@itemize
-@item Selective comparison of fields in a row
-@item Specifying group of columns as primary-key to uniquely identify a row
-@item Ignoring columns
-@item Several output formats including colored git style output or
-JSON for post-processing
-@end itemize")
- (license license:expat)))
+ (deprecated-package "go-github-com-aswinkarthik-csvdiff" csvdiff))
(define-public go-gopkg-in-djherbis-times-v1
(package