summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 79a69bc842..0ca70cec38 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2022 muradm <mail@muradm.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -161,6 +162,28 @@ the parse trees produced by the html package.")
incoming requests with their respective handler.")
(license license:bsd-3)))
+(define-public go-github-com-gorilla-websocket
+ (package
+ (name "go-github-com-gorilla-websocket")
+ (version "1.5.0")
+ (home-page "https://github.com/gorilla/websocket")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xrr6snvs9g1nzxxg05w4i4pq6k1xjljl5mvavd838qc468n118i"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/gorilla/websocket"))
+ (synopsis "Fast WebSocket implementation for Go")
+ (description "Gorilla WebSocket is a Go implementation of the WebSocket
+protocol.")
+ (license license:bsd-2)))
+
(define-public go-github-com-puerkitobio-goquery
(package
(name "go-github-com-puerkitobio-goquery")