summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 8d0e0ddb64..3b95965f6b 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -592,17 +592,11 @@ Stealing encryption and decryption methods.")
(build-system go-build-system)
(arguments
'(#:import-path "github.com/libp2p/go-libp2p-peer"))
- (native-inputs
+ (propagated-inputs
(list go-github-com-btcsuite-btcd-btcec
go-github-com-gogo-protobuf
- go-github-com-gxed-hashland-keccakpg
go-github-com-libp2p-go-libp2p-crypto
- go-github-com-minio-blake2b-simd
- go-github-com-minio-sha256-simd
- go-github-com-mr-tron-base58
- go-github-com-multiformats-go-multihash
- go-github-com-spaolacci-murmur3
- go-golang-org-x-crypto))
+ go-github-com-multiformats-go-multihash))
(home-page "https://github.com/libp2p/go-libp2p-peer")
(synopsis "PKI based identities for use in go-libp2p")
(description "PKI based identities for use in @command{go-libp2p}.")
@@ -812,7 +806,7 @@ Architecture Processors\" by J. Guilford et al.")
(build-system go-build-system)
(arguments
'(#:import-path "github.com/multiformats/go-multihash"))
- (native-inputs
+ (propagated-inputs
(list go-github-com-mr-tron-base58
go-github-com-gxed-hashland-keccakpg
go-github-com-minio-blake2b-simd