summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 4f90ab4242..24e114166c 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -555,6 +555,20 @@ libraries.")
hash algorithm. See http://keccak.noekeon.org.")
(license license:expat))))
+(define-public go-github-com-gxed-hashland-murmur3
+ (package
+ (inherit go-github-com-gxed-hashland)
+ (name "go-github-com-gxed-hashland-murmur3")
+ (arguments
+ (list
+ #:import-path "github.com/gxed/hashland/murmur3"
+ #:unpack-path "github.com/gxed/hashland"))
+ (synopsis "Golang implementation of MurmurHash3 algorithm")
+ (description
+ "This package provides a native Go implementation of
+@url{https://en.wikipedia.org/wiki/MurmurHash, Austin Appleby's third
+MurmurHash} revision (aka MurmurHash3).")))
+
(define-public go-github-com-jcmturner-aescts-v2
(package
(name "go-github-com-jcmturner-aescts-v2")