summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 2096f712bb..71e63543c2 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -716,8 +716,8 @@ in C/C++.")
;; XXXX: Workaround 'snippet' limitations.
(define computed-origin-method (@@ (guix packages) computed-origin-method))
-(define %icecat-version "91.7.0-guix0-preview1")
-(define %icecat-build-id "20220307000000") ;must be of the form YYYYMMDDhhmmss
+(define %icecat-version "91.8.0-guix0-preview1")
+(define %icecat-build-id "20220405000000") ;must be of the form YYYYMMDDhhmmss
;; 'icecat-source' is a "computed" origin that generates an IceCat tarball
;; from the corresponding upstream Firefox ESR tarball, using the 'makeicecat'
@@ -739,11 +739,11 @@ in C/C++.")
"firefox-" upstream-firefox-version ".source.tar.xz"))
(sha256
(base32
- "0npf1w6ic14zjn2h5zp8il4l0s61l9mykgnbcinxc47gw6myjflw"))))
+ "0fkz12grzl9892b8ncd5y93xhzhbvkik4d0944vgkizmrd9si0yl"))))
- (upstream-icecat-base-version "91.7.0") ; maybe older than base-version
+ (upstream-icecat-base-version "91.8.0") ; maybe older than base-version
;;(gnuzilla-commit (string-append "v" upstream-icecat-base-version))
- (gnuzilla-commit "76e23c5f1bcebc22f7936baa29f75c6c9415935e")
+ (gnuzilla-commit "3aec3e591e7b1de0bfe5025a54ef5771a9823917")
(gnuzilla-source
(origin
(method git-fetch)
@@ -755,7 +755,7 @@ in C/C++.")
(string-take gnuzilla-commit 8)))
(sha256
(base32
- "1qvhpyws73f5is7l5isiag6lbqj9gkbdkc9gj29lhhhgla8j6qyg"))))
+ "1mianwz71yixqdb3bji3hvn8ixsmhz4ygq06fnb1p3dpbaphspa1"))))
;; 'search-patch' returns either a valid file name or #f, so wrap it
;; in 'assume-valid-file-name' to avoid 'local-file' warnings.
@@ -1338,11 +1338,11 @@ standards of the IceCat project.")
(cpe-version . ,(first (string-split version #\-)))))))
;; Update this together with icecat!
-(define %icedove-build-id "20220308000000") ;must be of the form YYYYMMDDhhmmss
+(define %icedove-build-id "20220405000000") ;must be of the form YYYYMMDDhhmmss
(define-public icedove
(package
(name "icedove")
- (version "91.7")
+ (version "91.8")
(source icecat-source)
(properties
`((cpe-name . "thunderbird_esr")))
@@ -1628,7 +1628,7 @@ standards of the IceCat project.")
;; in the Thunderbird release tarball. We don't use the release
;; tarball because it duplicates the Icecat sources and only adds the
;; "comm" directory, which is provided by this repository.
- ,(let ((changeset "39ccd0b9ea033f3292af90667e470b98a79eb8c9"))
+ ,(let ((changeset "525d4941f4870a56f714af775b7d7bc18175021d"))
(origin
(method hg-fetch)
(uri (hg-reference
@@ -1637,7 +1637,7 @@ standards of the IceCat project.")
(file-name (string-append "thunderbird-" version "-checkout"))
(sha256
(base32
- "0zk6f3yxqq5dn4dh96jmip3xy66n4lnai5fan31kl2l63vfcm1ag")))))
+ "1kq6564bjzd80nsggyih4ypbkf35p32j5akaq589sm3xbjgd1zq6")))))
("cargo" ,rust "cargo")
("clang" ,clang-11)
("llvm" ,llvm-11)