summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm28
1 files changed, 23 insertions, 5 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index a1a0bf040d..335cfd1983 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
@@ -122,15 +122,15 @@ in the Mozilla clients.")
(define-public nss
(package
(name "nss")
- (version "3.17.3")
+ (version "3.17.4")
(source (origin
(method url-fetch)
(uri (string-append
"ftp://ftp.mozilla.org/pub/mozilla.org/security/nss/"
- "releases/NSS_3_17_3_RTM/src/nss-3.17.3.tar.gz"))
+ "releases/NSS_3_17_4_RTM/src/nss-3.17.4.tar.gz"))
(sha256
(base32
- "1m91z80x4zh1mxgf53bl33lp43gn1wxxx0y26mgz511gb81ykmgl"))
+ "0ycxzybgn4bq0i6j5zjdjl70n3s8a742yixyik4pw8x4h4cav60x"))
;; Create nss.pc and nss-config.
(patches (list (search-patch "nss-pkgconfig.patch")))))
(build-system gnu-build-system)
@@ -224,7 +224,25 @@ standards.")
version "/" name "-" version ".tar.bz2"))
(sha256
(base32
- "0q5ilgfybcrbwf9hq9zc1cpnlhq1pddnnjmdrxrcrrg8lgx5kkc2"))))
+ "0q5ilgfybcrbwf9hq9zc1cpnlhq1pddnnjmdrxrcrrg8lgx5kkc2"))
+ (patches (map search-patch
+ '("icecat-CVE-2015-0822.patch"
+ "icecat-CVE-2015-0827-pt-1.patch"
+ "icecat-CVE-2015-0827-pt-2.patch"
+ "icecat-CVE-2015-0827-pt-3.patch"
+ "icecat-CVE-2015-0831-pt-1.patch"
+ "icecat-CVE-2015-0831-pt-2.patch"
+ "icecat-CVE-2015-0836-pt-01.patch"
+ "icecat-CVE-2015-0836-pt-02.patch"
+ "icecat-CVE-2015-0836-pt-03.patch"
+ "icecat-CVE-2015-0836-pt-04.patch"
+ "icecat-CVE-2015-0836-pt-05.patch"
+ "icecat-CVE-2015-0836-pt-06.patch"
+ "icecat-CVE-2015-0836-pt-07.patch"
+ "icecat-CVE-2015-0836-pt-08.patch"
+ "icecat-CVE-2015-0836-pt-09.patch"
+ "icecat-CVE-2015-0836-pt-10.patch"
+ "icecat-CVE-2015-0836-pt-11.patch")))))
(build-system gnu-build-system)
(inputs
`(("alsa-lib" ,alsa-lib)