summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 1ee5248ced..d5d11b59d1 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -364,7 +364,8 @@ in C/C++.")
(file-name (git-file-name "mozjs" version))
(sha256
(base32
- "1xl6avsj9gkgma71p56jzs7nasc767k3n1frnmri5pad4rj94bij"))))
+ "1xl6avsj9gkgma71p56jzs7nasc767k3n1frnmri5pad4rj94bij"))
+ (patches (search-patches "mozjs60-riscv64-support.patch"))))
(arguments
`(#:tests? #f ; FIXME: all tests pass, but then the check phase fails anyway.
#:test-target "check-jstests"
@@ -419,6 +420,14 @@ in C/C++.")
(cons (string-append "--prefix=" out)
configure-flags))
#t)))
+ (add-after 'unpack 'update-config-scripts
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "build/autoconf"))
+ '("config.guess" "config.sub"))))
(add-after 'unpack 'disable-broken-tests
(lambda _
;; This test assumes that /bin exists and contains certain
@@ -428,6 +437,7 @@ in C/C++.")
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
+ ("config" ,config)
("which" ,which)
("perl" ,perl)
("pkg-config" ,pkg-config)