summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 233e3104d0..74403751a9 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -417,7 +417,7 @@ in C/C++.")
(define-public mozjs-78
(package
(inherit mozjs-60)
- (version "78.5.0")
+ (version "78.10.1")
(source (origin
(method url-fetch)
;; TODO: Switch to IceCat source once available on ftp.gnu.org.
@@ -426,7 +426,7 @@ in C/C++.")
version "esr.source.tar.xz"))
(sha256
(base32
- "1442yjmwz69hkfcvh8kkb60jf4c9ms0pac04nc3xw2da13v4zxai"))))
+ "0gyg2p6i1wmmfghwg13pp6fj8j8xz6c14f6bbnf4pf0f5c3la7y4"))))
(arguments
`(#:imported-modules ,%cargo-utils-modules ;for `generate-all-checksums'
#:modules ((guix build cargo-utils)
@@ -550,10 +550,10 @@ in C/C++.")
("perl" ,perl)
("pkg-config" ,pkg-config)
("python" ,python-3)
- ("rust" ,rust)
- ("cargo" ,rust "cargo")))
+ ("rust" ,rust-1.41)
+ ("cargo" ,rust-1.41 "cargo")))
(inputs
- `(("icu4c" ,icu4c-68)
+ `(("icu4c" ,icu4c)
("readline" ,readline)
("zlib" ,zlib)))))
@@ -929,8 +929,8 @@ from forcing GEXP-PROMISE."
("patch" ,(canonical-package patch))
- ("rust" ,rust-1.41)
- ("cargo" ,rust-1.41 "cargo")
+ ("rust" ,rust)
+ ("cargo" ,rust "cargo")
("rust-cbindgen" ,rust-cbindgen-0.14)
("llvm" ,llvm)
("clang" ,clang)
@@ -1607,7 +1607,7 @@ standards of the IceCat project.")
(base32
"10l042dd7b8rvla0cbiks5kjrz2b28yy7hr8sr169wlx202hxa01")))))
("autoconf" ,autoconf-2.13)
- ("cargo" ,rust-1.41 "cargo")
+ ("cargo" ,rust "cargo")
("clang" ,clang)
("llvm" ,llvm)
("nasm" ,nasm)
@@ -1616,7 +1616,7 @@ standards of the IceCat project.")
("pkg-config" ,pkg-config)
("python" ,python)
("python2" ,python-2.7)
- ("rust" ,rust-1.41)
+ ("rust" ,rust)
("rust-cbindgen" ,rust-cbindgen-0.14)
("which" ,which)
("yasm" ,yasm)))