summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 2d238febce..29bfc8199f 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -5,7 +5,8 @@
;;; Copyright © 2015, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
+;;; Copyright © 2016, 2017, 2018 ng0 <ng0@n0.is>
+;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -144,14 +145,14 @@ tool to extract metadata from a file and print the results.")
(define-public libmicrohttpd
(package
(name "libmicrohttpd")
- (version "0.9.58")
+ (version "0.9.59")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libmicrohttpd/libmicrohttpd-"
version ".tar.gz"))
(sha256
(base32
- "1wq17qvizis7bsyvyw1gnfycvivssncngziddnyrbzv2dhvy24bs"))))
+ "0g4jgnv43yddr9yxrqg11632rip0lg5c53gmy5wy3c0i1dywv74v"))))
(build-system gnu-build-system)
(inputs
`(("curl" ,curl)
@@ -185,13 +186,13 @@ authentication and support for SSL3 and TLS.")
(define-public gnurl
(package
(name "gnurl")
- (version "7.57.0")
+ (version "7.58.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gnunet/" name "-" version ".tar.xz"))
(sha256
(base32
- "0cl2x1jddnhn1z8gd75w6k7lb6pymn5rf2vqgl2vdkbxsz677z07"))))
+ "1yyswsz0csplqi8hlhqaxlafqn5kh5016j8k2gaxziv4cb343znx"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ; 1.5 MiB of man3 pages
@@ -226,8 +227,7 @@ authentication and support for SSL3 and TLS.")
(("/bin/sh") (which "sh")))
;; Make test output more verbose.
- (zero? (system* "make" "-C" "tests" "test"))
- #t)))))
+ (invoke "make" "-C" "tests" "test"))))))
(synopsis "Microfork of cURL with support for the HTTP/HTTPS/GnuTLS subset of cURL")
(description
"Gnurl is a microfork of cURL, a command line tool for transferring data
@@ -325,7 +325,7 @@ kinds of basic applications for the foundation of a GNU internet.")
'(#:phases (modify-phases %standard-phases
(add-after 'unpack 'bootstrap
(lambda _
- (zero? (system* "autoreconf" "-vfi")))))))
+ (invoke "autoreconf" "-vfi"))))))
(native-inputs `(("pkg-config" ,pkg-config)
("autoconf" ,(autoconf-wrapper))
("automake" ,automake)))