summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm33
1 files changed, 10 insertions, 23 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index d0a9955005..5c0dd348cc 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -113,7 +113,7 @@
("libvorbis" ,libvorbis)
("zlib" ,zlib)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(outputs '("out"
"static")) ; 420 KiB .a files
(arguments
@@ -164,14 +164,11 @@ tool to extract metadata from a file and print the results.")
version ".tar.gz"))
(sha256
(base32
- "0bh39irwzkv48fkw43skfgkk8ka3793bx1lm21sgw6zxi0djyyx3"))))
+ "0bh39irwzkv48fkw43skfgkk8ka3793bx1lm21sgw6zxi0djyyx3"))
+ (patches (search-patches "libmicrohttpd-0.9.73-test-ssl3.patch"))))
(build-system gnu-build-system)
(inputs
- `(("curl" ,curl)
- ("gnutls" ,gnutls/dane)
- ("libgcrypt" ,libgcrypt)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
+ (list curl gnutls/dane libgcrypt openssl zlib))
(synopsis "C library implementing an HTTP 1.1 server")
(description
"GNU libmicrohttpd is a small, embeddable HTTP server implemented as a
@@ -200,10 +197,7 @@ authentication and support for SSL3 and TLS.")
("libidn2" ,libidn2)
("zlib" ,zlib)))
(native-inputs
- `(("libtool" ,libtool)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("python" ,python)))
+ (list libtool perl pkg-config python))
(arguments
`(#:configure-flags
;; All of these produce errors during configure.
@@ -289,11 +283,8 @@ supports HTTP, HTTPS and GnuTLS.")
("zbar" ,zbar)
("zlib" ,zlib)))
(native-inputs
- `(("curl" ,curl)
- ("pkg-config" ,pkg-config)
- ("python" ,python)
- ("xxd" ,xxd)
- ("which" ,(@ (gnu packages base) which))))
+ (list curl pkg-config python xxd
+ (@ (gnu packages base) which)))
(arguments
'(#:parallel-tests? #f ; Parallel tests aren't supported.
#:phases
@@ -367,11 +358,8 @@ kinds of basic applications for the foundation of a GNU internet.")
(base32
"0nqc18jh9j30y4l6yh6j35byfg6qalq7yr3frv9rk10qa041c2sv"))))
(build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf)
- ("automake" ,automake)))
- (inputs `(("guile" ,guile-2.0)
- ("gnunet" ,gnunet)))
+ (native-inputs (list pkg-config autoconf automake))
+ (inputs (list guile-2.0 gnunet))
(synopsis "Guile bindings for GNUnet services")
(description
"This package provides Guile bindings to the client libraries of various
@@ -410,8 +398,7 @@ services.")
("libunique" ,libunique)
("qrencode" ,qrencode)))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("libglade" ,libglade)))
+ (list pkg-config libglade))
(synopsis "Graphical front-end tools for GNUnet")
(properties '((ftp-server . "ftp.gnu.org")
(ftp-directory . "/gnunet")))))