summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 36ffd3f4a7..f027e287cd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -48,7 +48,7 @@
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 raingloom <raingloom@riseup.net>
-;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
@@ -12003,7 +12003,7 @@ provided there is a DBus service present:
(define-public parlatype
(package
(name "parlatype")
- (version "2.1")
+ (version "3.0")
(source
(origin
(method git-fetch)
@@ -12012,13 +12012,17 @@ provided there is a DBus service present:
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1c15ja0rwz3jj8bnqdq0nmqka39iwrhy8krdv2a2x8nl4shfpmv0"))))
+ (base32 "0mvzagkg9kq2ji6mffi37mdjxmlj3wa65d4lcayij9hsmjlklnzs"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
#:tests? #f ;require internet access
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "data/meson_post_install.py"
+ (("gtk-update-icon-cache") "true"))))
(add-after 'install 'wrap-parlatype
;; Add gstreamer plugin provided in this package to system's
;; plugins.
@@ -12029,8 +12033,7 @@ provided there is a DBus service present:
":"
(getenv "GST_PLUGIN_SYSTEM_PATH"))))
(wrap-program (string-append out "/bin/parlatype")
- `("GST_PLUGIN_SYSTEM_PATH" ":" = (,gst-plugin-path))))
- #t)))))
+ `("GST_PLUGIN_SYSTEM_PATH" ":" = (,gst-plugin-path)))))))))
(native-inputs
`(("appstream-glib" ,appstream-glib)
("desktop-file-utils" ,desktop-file-utils) ;for desktop-file-validate
@@ -12043,10 +12046,11 @@ provided there is a DBus service present:
("gst-plugins-good" ,gst-plugins-good)
("gstreamer" ,gstreamer)
("gtk+" ,gtk+)
+ ("iso-codes" ,iso-codes)
("pocketsphinx" ,pocketsphinx)
("pulseaudio" ,pulseaudio)
("sphinxbase" ,sphinxbase)))
- (home-page "http://gkarsay.github.io/parlatype/")
+ (home-page "https://www.parlatype.org")
(synopsis "GNOME audio player for transcription")
(description "Parlatype is an audio player for the GNOME desktop
environment. Its main purpose is the manual transcription of spoken