summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm441
1 files changed, 201 insertions, 240 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 91ffa23548..e03ed77374 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -143,6 +143,7 @@
#:use-module (gnu packages lirc)
#:use-module (gnu packages lua)
#:use-module (gnu packages mail)
+ #:use-module (gnu packages man)
#:use-module (gnu packages mp3)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages music)
@@ -956,7 +957,7 @@ cloud integration is offered through GNOME Online Accounts.")
`("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))
`("GST_PLUGIN_SYSTEM_PATH" = (,(getenv "GST_PLUGIN_SYSTEM_PATH")))
`("GRL_PLUGIN_PATH" = (,(getenv "GRL_PLUGIN_PATH")))
- `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))))
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH") ,pylib))))
#t)))))
(native-inputs
`(("desktop-file-utils" ,desktop-file-utils)
@@ -1120,8 +1121,7 @@ freedesktop.org desktop notification specification.")
"1x8yvjy0yg17qyhmqws8xh2k8dvzrhpwqz7j1cfwzalrb1i9c5g8"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.55
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch
(lambda* (#:key inputs #:allow-other-keys)
@@ -1420,8 +1420,6 @@ and implementation of UPnP A/V profiles.")
(base32
"1mlw1qgj8nkd9ll6b6h54r1gfdy3zp8a8xqz7qfyfaj85jjgbph7"))))
(build-system meson-build-system)
- (arguments
- `(#:meson ,meson-next))
(native-inputs
`(("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)))
@@ -1808,7 +1806,6 @@ either on a local, or remote machine via a number of methods.")
(build-system glib-or-gtk-build-system)
(native-inputs
`(("desktop-file-utils" ,desktop-file-utils)
- ("gcc" ,gcc-8) ;required for -Wcast-function-type
("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
@@ -2749,7 +2746,7 @@ and how they are displayed (View).")
(package-version python))
"/site-packages")))
(wrap-program prog
- `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH") ,pylib))
`("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
#t))))))
(native-inputs
@@ -3267,104 +3264,70 @@ XML/CSS rendering engine.")
(sha256
(base32
"0kbpp9ksl7977xiga37sk1gdw1r039v6zviqznl7alvvg39yp26i"))))
- (build-system gnu-build-system)
- (arguments
- '(#:configure-flags '("--disable-static")))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("gettext" ,gettext-minimal)
-
- ;; For tests.
- ("perl" ,perl)
- ("perl-xml-parser" ,perl-xml-parser)))
- (inputs
- `(("zlib" ,zlib)
- ("bzip2" ,bzip2)))
- (propagated-inputs
- `(("gdk-pixbuf" ,gdk-pixbuf)
- ("glib" ,glib)
- ("libxml2" ,libxml2)))
- (home-page "https://www.gnome.org/projects/libgsf")
- (synopsis "GNOME's Structured File Library")
- (description
- "Libgsf aims to provide an efficient extensible I/O abstraction for
-dealing with different structured file formats.")
-
- ;; LGPLv2.1-only.
- (license license:lgpl2.1)))
-
-(define-public librsvg
- (package
- (name "librsvg")
- (version "2.40.21")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1fljkag2gr7c4k5mn798lgf9903xslz8h51bgvl89nnay42qjqpp"))))
- (build-system gnu-build-system)
+ (build-system glib-or-gtk-build-system)
+ (outputs '("out" "bin" "doc"))
(arguments
`(#:configure-flags
- (list "--disable-static"
- "--enable-vala") ; needed for e.g. gnome-mines
+ (list
+ "--disable-static"
+ "--enable-introspection"
+ (string-append "--with-gir-dir="
+ (assoc-ref %outputs "out")
+ "/share/gir-"
+ ,(version-major
+ (package-version gobject-introspection))
+ ".0")
+ (string-append "--with-typelib-dir="
+ (assoc-ref %outputs "out")
+ "/lib/girepository-"
+ ,(version-major
+ (package-version gobject-introspection))
+ ".0")
+ (string-append "--with-html-dir="
+ (assoc-ref %outputs "doc")
+ "/share/gtk-doc/html")
+ "--with-zlib"
+ "--with-bz2")
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'pre-configure
+ (add-after 'unpack 'patch-docbook-xml
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "gdk-pixbuf-loader/Makefile.in"
- ;; By default the gdk-pixbuf loader is installed under
- ;; gdk-pixbuf's prefix. Work around that.
- (("gdk_pixbuf_moduledir = .*$")
- (string-append "gdk_pixbuf_moduledir = "
- "$(prefix)/lib/gdk-pixbuf-2.0/2.10.0/"
- "loaders\n"))
- ;; Drop the 'loaders.cache' file, it's in gdk-pixbuf+svg.
- (("gdk_pixbuf_cache_file = .*$")
- "gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n"))
- #t))
- (add-before 'check 'remove-failing-tests
- (lambda _
- (with-directory-excursion "tests/fixtures/reftests"
- (for-each delete-file
- '(;; This test fails on i686:
- "svg1.1/masking-path-04-b.svg"
- ;; This test fails on armhf:
- "svg1.1/masking-mask-01-b.svg"
- ;; This test fails on aarch64:
- "bugs/777834-empty-text-children.svg")))
+ (with-directory-excursion "doc"
+ (substitute* "gsf-docs.xml"
+ (("http://www.oasis-open.org/docbook/xml/4.5/")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/"))))
#t)))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("vala" ,vala)
- ("glib" ,glib "bin") ; glib-mkenums, etc.
- ("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
+ `(("docbook-xml" ,docbook-xml)
+ ("gettext" ,gettext-minimal)
+ ("gobject-introspection" ,gobject-introspection)
+ ("perl" ,perl)
+ ("perl-xml-parser" ,perl-xml-parser)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)))
(inputs
- `(;; XXX: 1.44 causes some test failures, so we stick with 1.42 for
- ;; this ancient version of librsvg.
- ("pango" ,pango-1.42)
- ("libcroco" ,libcroco)
- ("bzip2" ,bzip2)
- ("libgsf" ,libgsf)
- ("libxml2" ,libxml2)))
- (propagated-inputs
- ;; librsvg-2.0.pc refers to all of that.
- `(("cairo" ,cairo)
+ `(("bzip2" ,bzip2)
("gdk-pixbuf" ,gdk-pixbuf)
- ("glib" ,glib)))
- (home-page "https://wiki.gnome.org/LibRsvg")
- (synopsis "Render SVG files using Cairo")
- (description
- "Librsvg is a C library to render SVG files using the Cairo 2D graphics
-library.")
- (license license:lgpl2.0+)))
+ ("zlib" ,zlib)))
+ (propagated-inputs
+ `(("glib" ,glib)
+ ("libxml2" ,libxml2)))
+ (synopsis "G Structured File Library")
+ (description "Libgsf aims to provide an efficient extensible I/O abstraction
+for dealing with different structured file formats.")
+ (home-page "https://gitlab.gnome.org/GNOME/libgsf")
+ (license
+ (list
+ ;; Library
+ license:lgpl2.1+
+ ;; Others
+ license:lgpl2.0+))))
-(define-public librsvg-next
+(define-public librsvg
(package
(name "librsvg")
- (version "2.50.3")
+ (version "2.50.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/librsvg/"
@@ -3372,15 +3335,16 @@ library.")
"librsvg-" version ".tar.xz"))
(sha256
(base32
- "0n79i4wj9hm0d3bbn4xvknq5ylhqs16pvhaqr1rxspx9wfc8lad4"))
+ "0wlj5g1jgp93sj3rr6qspj282whz13ahnv8ca99d7zilq9s1aw1j"))
(modules '((guix build utils)))
(snippet
- '(begin (delete-file-recursively "vendor")
- #t))))
+ '(begin (delete-file-recursively "vendor")))))
(build-system cargo-build-system)
(outputs '("out" "doc"))
(arguments
`(#:install-source? #f
+ ;; XXX: compiling librsvg_c_api hangs forever with 1.49.
+ #:rust ,rust-1.48
#:modules
((guix build cargo-build-system)
(guix build utils)
@@ -3440,8 +3404,7 @@ library.")
(substitute* "rsvg-docs.xml"
(("http://www.oasis-open.org/docbook/xml/4.3/")
(string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/"))))
- #t))
+ "/xml/dtd/docbook/"))))))
(add-after 'unpack 'prepare-for-build
(lambda _
;; In lieu of #:make-flags
@@ -3449,8 +3412,7 @@ library.")
;; Something about the build environment resists building
;; successfully with the '--locked' flag.
(substitute* '("Makefile.am" "Makefile.in")
- (("--locked") ""))
- #t))
+ (("--locked") ""))))
(add-before 'configure 'pre-configure
(lambda _
(substitute* "gdk-pixbuf-loader/Makefile.in"
@@ -3462,8 +3424,7 @@ library.")
"loaders\n"))
;; Drop the 'loaders.cache' file, it's in gdk-pixbuf+svg.
(("gdk_pixbuf_cache_file = .*$")
- "gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n"))
- #t))
+ "gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n"))))
(add-after 'configure 'gnu-configure
(lambda* (#:key inputs native-inputs outputs #:allow-other-keys)
((assoc-ref gnu:%standard-phases 'configure)
@@ -3474,14 +3435,13 @@ library.")
(list "--disable-static"
"--enable-vala"
(string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
+ (assoc-ref outputs "doc")
"/share/gtk-doc/html")))))
(add-after 'configure 'dont-vendor-self
(lambda* (#:key vendor-dir #:allow-other-keys)
;; Don't keep the whole tarball in the vendor directory
(delete-file-recursively
- (string-append vendor-dir "/" ,name "-" ,version ".tar.xz"))
- #t))
+ (string-append vendor-dir "/" ,name "-" ,version ".tar.xz"))))
(replace 'build
(assoc-ref gnu:%standard-phases 'build))
(add-before 'check 'ignore-failing-tests
@@ -3507,8 +3467,7 @@ library.")
(("fn multiple_input_files_not_allowed_for_png_output" all)
(string-append "#[ignore] " all))
(("fn stylesheet_option_error" all)
- (string-append "#[ignore] " all)))
- #t))
+ (string-append "#[ignore] " all)))))
(replace 'check
(lambda* args
((assoc-ref gnu:%standard-phases 'check)
@@ -4389,61 +4348,58 @@ passwords in the GNOME keyring.")
(define-public vala
(package
(name "vala")
- (version "0.46.5")
+ (version "0.52.0")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
+ (uri (string-append "mirror://gnome/sources/vala/"
(version-major+minor version) "/"
- name "-" version ".tar.xz"))
+ "vala-" version ".tar.xz"))
(sha256
(base32
- "07fv895sp9wq74b20qig7hic0r4ynrr5pfaqba02r44xb794fy0s"))))
- (build-system gnu-build-system)
+ "12y6p8wdjp01vmfhxg2cgh32xnyqq6ivblvrar9clnj6vc867qhx"))))
+ (build-system glib-or-gtk-build-system)
(arguments
- '(#:phases
+ '(#:configure-flags '("--enable-coverage")
+ #:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook-xml
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "doc/manual"
+ (substitute* '("manual.xml" "version.xml.in")
+ (("http://www.oasis-open.org/docbook/xml/4.4/")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/"))))
+ #t))
(add-before 'check 'pre-check
- (lambda _
- (setenv "CC" "gcc")
- (substitute* "valadoc/tests/testrunner.sh"
- (("export PKG_CONFIG_PATH=" m)
- (string-append m "$PKG_CONFIG_PATH:")))
- ;; For missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0")
- #t)))))
+ (lambda _
+ (setenv "CC" "gcc")
+ (substitute* "valadoc/tests/libvaladoc\
+/tests-extra-environment.sh"
+ (("export PKG_CONFIG_PATH=" m)
+ (string-append m "$PKG_CONFIG_PATH:"))))))))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("bison" ,bison)
+ ("dbus" ,dbus) ; for dbus tests
+ ("docbook-xml" ,docbook-xml-4.4)
+ ("docbook-xsl" ,docbook-xsl)
("flex" ,flex)
- ("bison" ,bison)
- ("xsltproc" ,libxslt)
- ("dbus" ,dbus) ; for dbus tests
- ("gobject-introspection" ,gobject-introspection))) ; for gir tests
- (inputs
- `(("graphviz" ,graphviz)))
+ ("gobject-introspection" ,gobject-introspection) ; for gir tests
+ ("help2man" ,help2man)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("xsltproc" ,libxslt)))
(propagated-inputs
- `(("glib" ,glib))) ; required by libvala-0.40.pc
+ `(("glib" ,glib) ; required by libvala-0.40.pc
+ ("libgvc" ,graphviz)))
(home-page "https://wiki.gnome.org/Projects/Vala/")
- (synopsis "Compiler for the GObject type system")
- (description
- "Vala is a programming language that aims to bring modern programming
-language features to GNOME developers without imposing any additional runtime
-requirements and without using a different ABI compared to applications and
-libraries written in C.")
+ (synopsis "Compiler using the GObject type system")
+ (description "Vala is a programming language using modern high level
+abstractions without imposing additional runtime requirements and without using
+a different ABI compared to applications and libraries written in C. Vala uses
+the GObject type system and has additional code generation routines that make
+targeting the GNOME stack simple.")
(license license:lgpl2.1+)))
-(define-public vala-0.50
- (package
- (inherit vala)
- (version "0.50.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/vala/"
- (version-major+minor version) "/"
- "vala-" version ".tar.xz"))
- (sha256
- (base32
- "1nnf0x6vk0a9p2y6z7jwjfvmlxh3qhj581v381r0y1sxsv35s39c"))))))
-
(define-public vte
(package
(name "vte")
@@ -4639,7 +4595,7 @@ configuration storage systems.")
(define-public json-glib
(package
(name "json-glib")
- (version "1.4.4")
+ (version "1.6.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4647,23 +4603,54 @@ configuration storage systems.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0ixwyis47v5bkx6h8a1iqlw3638cxcv57ivxv4gw2gaig51my33j"))))
+ "092g2dyy1hhl0ix9kp33wcab0pg1qicnsv0cj5ms9g9qs336cgd3"))))
(build-system meson-build-system)
+ (outputs '("out" "doc"))
+ (arguments
+ `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+ #:configure-flags
+ (list
+ "-Ddocs=true"
+ "-Dman=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "doc"
+ (substitute* (find-files "." "\\.xml$")
+ (("http://www.oasis-open.org/docbook/xml/4\\.3/")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/")))
+ (substitute* "meson.build"
+ (("http://docbook.sourceforge.net/release/xsl/current/")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-1.79.2/"))))
+ #t))
+ (add-after 'install 'move-docs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (rename-file
+ (string-append out "/share/gtk-doc")
+ (string-append doc "/share/gtk-doc"))
+ #t))))))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib" ,glib "bin") ;for glib-mkenums and glib-genmarshal
+ `(("docbook-xml" ,docbook-xml-4.3)
+ ("docbook-xsl" ,docbook-xsl)
+ ("gettext" ,gettext-minimal)
+ ("glib" ,glib "bin") ;for glib-mkenums and glib-genmarshal
("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)))
+ ("gtk-doc" ,gtk-doc)
+ ("pkg-config" ,pkg-config)
+ ("xsltproc" ,libxslt)))
(propagated-inputs
- `(("glib" ,glib))) ;according to json-glib-1.0.pc
+ `(("glib" ,glib))) ;according to json-glib-1.0.pc
(home-page "https://wiki.gnome.org/Projects/JsonGlib")
- (synopsis "Compiler for the GObject type system")
- (description
- "JSON-GLib is a C library based on GLib providing serialization and
-deserialization support for the JavaScript Object Notation (JSON) format
-described by RFC 4627. It provides parser and generator GObject classes and
-various wrappers for the complex data types employed by JSON, such as arrays
-and objects.")
+ (synopsis "Glib and GObject implementation of JSON")
+ (description "JSON-GLib is a library providing serialization and
+described by RFC 4627. It implements a full JSON parser and generator using
+GLib and GObject, and integrates JSON with GLib data types.")
(license license:lgpl2.1+)))
(define-public libxklavier
@@ -4750,7 +4737,7 @@ library.")
(define-public glib-networking
(package
(name "glib-networking")
- (version "2.62.2")
+ (version "2.68.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/glib-networking/"
@@ -4758,23 +4745,29 @@ library.")
"glib-networking-" version ".tar.xz"))
(sha256
(base32
- "0i2mw75297ql72h47vyvff3hqa0kcmqybblj52fqrarb0kfbhi06"))))
+ "0vlzn8jf4sg90cm8xxr28yf66nhf8qy9dl2m4b8w1cr6mn2mw8qb"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags '("-Dlibproxy_support=false")))
+ `(#:configure-flags '("-Dopenssl=auto")))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))
(inputs
`(("glib" ,glib)
("gnutls" ,gnutls)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
- (home-page "https://www.gnome.org")
- (synopsis "Network-related GIO modules")
- (description
- "This package contains various network related extensions for the GIO
-library.")
- (license license:lgpl2.0+)))
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("libproxy" ,libproxy)
+ ("openssl" ,openssl)))
+ (home-page "https://wiki.gnome.org/Projects/GLib")
+ (synopsis "Network extensions for GLib")
+ (description
+ "Glib-networking contains the implementations of certain GLib networking
+features that cannot be implemented directly in GLib itself because of their
+dependencies. Currently it contains GnuTLS and OpenSSL-based implementations of
+GTlsBackend, a libproxy-based implementation of GProxyResolver,
+GLibproxyResolver, and a GNOME GProxyResolver that uses the proxy information
+from the GSettings schemas in gsettings-desktop-schemas.")
+ (license license:lgpl2.1+)))
(define-public rest
(package
@@ -4857,49 +4850,10 @@ libxml to ease remote use of the RESTful API.")
(substitute* "tests/hsts-db-test.c"
((".*/hsts-db/subdomains.*") ""))
- ;; Generate a self-signed certificate that has "localhost" as its
- ;; 'dnsName'. Failing to do that, and starting with GnuTLS
- ;; 3.5.12, tests such as "ssl-tests" fail:
- ;;
- ;; ERROR:ssl-test.c:406:do_tls_interaction_test: Unexpected status 6 Unacceptable TLS certificate (expected 200 OK)
- ;;
- ;; 'certtool' is interactive so we have to pipe it the answers.
- ;; Reported at <https://bugzilla.gnome.org/show_bug.cgi?id=784696>.
- (let ((pipe (open-output-pipe "certtool --generate-self-signed \
- --load-privkey tests/test-key.pem --outfile tests/test-cert.pem")))
- (for-each (lambda (line)
- (display line pipe)
- (newline pipe))
- '("" ;Common name
- "" ;UID
- "Guix" ;Organizational unit name
- "GNU" ;Organization name
- "" ;Locality name
- "" ;State or province
- "" ;Country
- "" ;subject's domain component (DC)
- "" ;E-mail
- "" ;serial number
- "-1" ;expiration time
- "N" ;belong to authority?
- "N" ;web client certificate?
- "N" ;IPsec IKE?
- "Y" ;web server certificate?
- "localhost" ;dnsName of subject
- "" ;dnsName of subject (end)
- "" ;URI of subject
- "127.0.0.1" ;IP address of subject
- "" ;signing?
- "" ;encryption (RSA)?
- "" ;data encryption?
- "" ;sign OCSP requests?
- "" ;sign code?
- "" ;time stamping?
- "" ;email protection?
- "" ;URI of the CRL distribution point
- "y" ;above info OK?
- ))
- (close-pipe pipe))
+ ;; FIXME: ssl-test fails, starting with
+ ;; glib-networking 2.68.x.
+ (substitute* "tests/meson.build"
+ (("[ \t]*\\['ssl', true, \\[\\]\\],") ""))
#t))
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
@@ -4921,7 +4875,6 @@ libxml to ease remote use of the RESTful API.")
("vala" ,vala)
("php" ,php)
("curl" ,curl)
- ("gnutls" ,gnutls) ;for 'certtool'
("httpd" ,httpd)))
(propagated-inputs
;; libsoup-2.4.pc refers to all of these (except where otherwise noted)
@@ -6310,12 +6263,12 @@ which can read a large number of file formats.")
(gi-typelib-path (getenv "GI_TYPELIB_PATH"))
(gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH"))
(grl-plugin-path (getenv "GRL_PLUGIN_PATH"))
- (python-path (getenv "PYTHONPATH")))
+ (python-path (getenv "GUIX_PYTHONPATH")))
(wrap-program (string-append out "/bin/rhythmbox")
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
`("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
`("GRL_PLUGIN_PATH" ":" prefix (,grl-plugin-path))
- `("PYTHONPATH" ":" prefix (,python-path))))
+ `("GUIX_PYTHONPATH" ":" prefix (,python-path))))
#t)))))
(propagated-inputs
`(("dconf" ,dconf)))
@@ -6418,7 +6371,7 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
("libexif" ,libexif)
("libpeas" ,libpeas)
("libjpeg" ,libjpeg-turbo)
- ("librsvg" ,librsvg-next)
+ ("librsvg" ,librsvg)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)))
(home-page "https://wiki.gnome.org/Apps/EyeOfGnome")
@@ -6687,7 +6640,7 @@ almost all of them.")
":")))
(wrap-program (string-append out "/bin/eolie")
`("LD_LIBRARY_PATH" ":" prefix (,path))
- `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH")))
+ `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))
`("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))
#t)))))
(native-inputs
@@ -6833,7 +6786,7 @@ principles are simplicity and standards compliance.")
(let ((prog (string-append (assoc-ref outputs "out")
"/bin/d-feet")))
(wrap-program prog
- `("PYTHONPATH" = (,(getenv "PYTHONPATH")))
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
`("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
#t))))))
(native-inputs
@@ -6870,10 +6823,17 @@ of running programs and invoke methods on those interfaces.")
(sha256
(base32 "1bdpgkzawhqmw52l6zx8czzg1ndfgcf1p44m2bxjdpqkc4afcgqc"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ "--enable-doc")))
(native-inputs
- `(("gettext-minimal" ,gettext-minimal)
+ `(("ducktype" ,mallard-ducktype)
+ ("gettext" ,gettext-minimal)
+ ("intltool" ,intltool)
("itstool" ,itstool)
- ("xmllint" ,libxml2)))
+ ("xmllint" ,libxml2)
+ ("xsltproc" ,libxslt)))
(synopsis "XSL stylesheets for Yelp")
(description "Yelp-XSL is a collection of programs and data files to help
you build, maintain, and distribute documentation. It provides XSLT stylesheets
@@ -7292,11 +7252,11 @@ javascript engine and the GObject introspection framework.")
(let ((out (assoc-ref outputs "out"))
(gtksourceview (assoc-ref inputs "gtksourceview"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH"))
- (python-path (getenv "PYTHONPATH")))
+ (python-path (getenv "GUIX_PYTHONPATH")))
(wrap-program (string-append out "/bin/gedit")
;; For plugins.
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
- `("PYTHONPATH" ":" prefix (,python-path))
+ `("GUIX_PYTHONPATH" ":" prefix (,python-path))
;; For language-specs.
`("XDG_DATA_DIRS" ":" prefix (,(string-append gtksourceview
"/share")))))
@@ -7659,12 +7619,12 @@ Evolution (hence the name), but is now used by other packages as well.")
(add-after 'install 'wrap-programs
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (python-path (getenv "PYTHONPATH"))
+ (python-path (getenv "GUIX_PYTHONPATH"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH")))
(for-each
(lambda (prog)
(wrap-program prog
- `("PYTHONPATH" ":" prefix (,python-path))
+ `("GUIX_PYTHONPATH" ":" prefix (,python-path))
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
(list (string-append out "/bin/caribou-preferences")
(string-append out "/libexec/antler-keyboard"))))
@@ -8519,9 +8479,10 @@ properties, screen resolution, and other GNOME parameters.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:disallowed-references ((,glib "bin")
- ,inkscape ,libxslt
- ,ruby-sass)
+ #:disallowed-references ,(list (gexp-input glib "bin")
+ (gexp-input inkscape)
+ (gexp-input libxslt)
+ (gexp-input ruby-sass))
#:configure-flags
(list "-Dsystemd=false"
;; Otherwise, the RUNPATH will lack the final path component.
@@ -8570,7 +8531,7 @@ properties, screen resolution, and other GNOME parameters.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH"))
- (python-path (getenv "PYTHONPATH")))
+ (python-path (getenv "GUIX_PYTHONPATH")))
(wrap-program (string-append out "/bin/gnome-shell")
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
;; FIXME: gnome-shell loads these libraries with unqualified
@@ -8584,7 +8545,7 @@ properties, screen resolution, and other GNOME parameters.")
(for-each
(lambda (prog)
(wrap-program (string-append out "/bin/" prog)
- `("PYTHONPATH" ":" prefix (,python-path))
+ `("GUIX_PYTHONPATH" ":" prefix (,python-path))
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
'("gnome-shell-extension-tool" "gnome-shell-perf-tool"))
#t)))
@@ -9368,7 +9329,7 @@ specified duration and save it as a GIF encoded animated image file.")
(package-version python))
"/site-packages")))
(wrap-program prog
- `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH") ,pylib))
`("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
#t))))))
(native-inputs
@@ -9579,13 +9540,13 @@ desktop. It supports multiple calendars, month, week and year view.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH"))
- (python-path (getenv "PYTHONPATH")))
+ (python-path (getenv "GUIX_PYTHONPATH")))
(wrap-program (string-append out "/bin/gnome-todo")
;; XXX: gi plugins are broken.
;; See https://bugzilla.gnome.org/show_bug.cgi?id=787212
;; For plugins.
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
- `("PYTHONPATH" ":" prefix (,python-path))))
+ `("GUIX_PYTHONPATH" ":" prefix (,python-path))))
#t)))))
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -10187,8 +10148,8 @@ accessibility infrastructure.")
(,(getenv "GI_TYPELIB_PATH")))
`("GST_PLUGIN_SYSTEM_PATH" ":" prefix
(,(getenv "GST_PLUGIN_SYSTEM_PATH")))
- `("PYTHONPATH" ":" prefix
- (,(getenv "PYTHONPATH")))))
+ `("GUIX_PYTHONPATH" ":" prefix
+ (,(getenv "GUIX_PYTHONPATH")))))
#t)))))
(native-inputs
`(("intltool" ,intltool)
@@ -10521,7 +10482,7 @@ apply fancy special effects and lets you share the fun with others.")
(package-version python))
"/site-packages")))
(wrap-program prog
- `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH") ,pylib))
`("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
#t))))))
(native-inputs
@@ -11588,7 +11549,7 @@ and toolbars.")
(package-version python))
"/site-packages")))
(wrap-program prog
- `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH") ,pylib))
`("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
#t))))))
(native-inputs
@@ -11649,7 +11610,7 @@ GTK+. It integrates well with the GNOME desktop environment.")
(pygo (string-append
(assoc-ref inputs "python-pygobject") site))
(python-wrap
- `("PYTHONPATH" = (,evdev ,pygo))))
+ `("GUIX_PYTHONPATH" = (,evdev ,pygo))))
(wrap-program (string-append out "/bin/" "ratbagctl")
python-wrap)
#t))))))
@@ -12031,7 +11992,7 @@ integrated profiler via Sysprof, debugging support, and more.")
(let ((prog (string-append (assoc-ref outputs "out")
"/bin/komikku")))
(wrap-program prog
- `("PYTHONPATH" = (,(getenv "PYTHONPATH")))
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
`("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
#t))))))
(inputs