summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f9126d18e1..d8545eaa58 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -861,8 +861,21 @@ on the GNOME Desktop with a single simple application.")
(base32
"0bshwm49cd01ighsxqlbqn10q0ch71ff99gcrx8pr2gyky2ad3pq"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'set-adwaita-theme-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Provide the correct file name of the default GNOME
+ ;; background, 'adwaita-timed.xml'.
+ (let ((theme (assoc-ref inputs "gnome-backgrounds")))
+ (substitute* (find-files "schemas"
+ "\\.gschema\\.xml\\.in$")
+ (("@datadir@/backgrounds/gnome")
+ (string-append theme "/share/backgrounds/gnome")))
+ #t))))))
(inputs
- `(("glib" ,glib)))
+ `(("glib" ,glib)
+ ("gnome-backgrounds" ,gnome-backgrounds)))
(native-inputs
`(("intltool" ,intltool)
("glib" ,glib "bin") ; glib-compile-schemas, etc.