summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm42
1 files changed, 14 insertions, 28 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ed9f54be88..fda8c5c661 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2116,7 +2116,7 @@ editors, IDEs, etc.")
(arguments
`(#:configure-flags '("CXXFLAGS=-Wformat=0")
#:phases (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
+ (replace 'bootstrap
(lambda _
(setenv "NOCONFIGURE" "true")
(zero? (system* "sh" "autogen.sh")))))))
@@ -2544,12 +2544,11 @@ libxml to ease remote use of the RESTful API.")
#t))
(replace 'install
(lambda _
- (zero?
- (system* "make"
- ;; Install vala bindings into $out.
- (string-append "vapidir=" %output
- "/share/vala/vapi")
- "install")))))))
+ (invoke "make"
+ ;; Install vala bindings into $out.
+ (string-append "vapidir=" %output
+ "/share/vala/vapi")
+ "install"))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums
("gobject-introspection" ,gobject-introspection)
@@ -2870,7 +2869,8 @@ output devices.")
(add-before 'configure 'patch-/bin/true
(lambda _
(substitute* "configure"
- (("/bin/true") (which "true"))))))))
+ (("/bin/true") (which "true")))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("gobject-introspection" ,gobject-introspection)
@@ -3657,7 +3657,7 @@ for application developers.")
("clutter" ,clutter)
("clutter-gtk" ,clutter-gtk)
("clutter-gst" ,clutter-gst)
- ("xproto" ,xproto)
+ ("xorgproto" ,xorgproto)
("libxxf86vm" ,libxxf86vm)
("libxtst" ,libxtst)
("libxrandr" ,libxrandr)
@@ -5045,7 +5045,8 @@ users.")
(substitute* "src/nm-session-monitor.c"
(("systemd") "elogind"))
(substitute* "./src/nm-logging.c"
- (("systemd") "elogind"))))))
+ (("systemd") "elogind"))
+ #t))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ; 8 MiB of gtk-doc HTML
@@ -5969,7 +5970,7 @@ associations for GNOME.")
(version (package-version gnome-shell))
(source #f)
(build-system trivial-build-system)
- (arguments '(#:builder (mkdir %output)))
+ (arguments '(#:builder (begin (mkdir %output) #t)))
(propagated-inputs
;; TODO: Add more packages according to:
;; <https://packages.debian.org/jessie/gnome-core>.
@@ -6043,7 +6044,7 @@ documents and diagrams, playing media, scanning, and much more.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
+ (replace 'bootstrap
(lambda _
;; The build system cleverly detects that we're not building from
;; a release tarball and turns on -Werror for GCC.
@@ -6377,12 +6378,6 @@ functionality and behavior.")
(base32
"0igxpngnkf1wpsg872a9jg3c9f5z8afm312yfbillz16mk8w39cw"))))
(build-system gnu-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda _
- (zero? (system* "autoreconf" "-vif")))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -6419,10 +6414,7 @@ like GNOME, Unity, Budgie, Pantheon, XFCE, Mate, etc.")
(substitute* '("Makefile.am")
(("\\$\\(DESTDIR\\)/usr/share")
"$(datadir)"))
- #t))
- (add-after 'patch-makefile.am 'bootstrap
- (lambda _
- (zero? (system* "autoreconf" "-vif")))))))
+ #t)))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)))
@@ -6471,12 +6463,6 @@ simple and consistent.")
(base32
"1ya1cqvv8q847c0rpcg6apzky87q3h04y8jz5nmi52qk6kg8si0b"))))
(build-system gnu-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda _
- (zero? (system* "autoreconf" "-vif")))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)))