summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm166
1 files changed, 104 insertions, 62 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 36e3346499..c69fb21ba5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2015, 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015, 2016, 2017, 2018, 2021 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017, 2018 Rene Saavedra <pacoon@protonmail.com>
@@ -166,6 +166,7 @@
#:use-module (gnu packages protobuf)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-compression)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -1974,7 +1975,7 @@ access the common Google services, and has full asynchronous support.")
(define-public libgxps
(package
(name "libgxps")
- (version "0.3.1")
+ (version "0.3.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1982,7 +1983,7 @@ access the common Google services, and has full asynchronous support.")
name "-" version ".tar.xz"))
(sha256
(base32
- "157s4c9gjjss6yd7qp7n4q6s72gz1k4ilsx4xjvp357azk49z4qs"))))
+ "07156nj7yrp3h9zyzx6mjwxwmfijialb4gi5d6dwyp53arr8c9vd"))))
(build-system meson-build-system)
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
@@ -2433,8 +2434,7 @@ GNOME Desktop.")
;;; A minimal variant used to break a cycle with Inkscape.
(define-public gdl-minimal
- (package
- (inherit gdl)
+ (package/inherit gdl
(name "gdl-minimal")
(arguments
'(#:phases
@@ -3227,6 +3227,7 @@ the GNOME desktop environment.")
(sha256
(base32
"1m110rbj5d2raxcdp4iz0qp172284945awrsbdlq99ksmqsc4zkn"))))
+ (replacement libcroco/fixed)
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -3245,6 +3246,21 @@ XML/CSS rendering engine.")
;; LGPLv2.1-only.
(license license:lgpl2.1)))
+(define libcroco/fixed
+ (package
+ (inherit libcroco)
+ (name "libcroco")
+ (version "0.6.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1m110rbj5d2raxcdp4iz0qp172284945awrsbdlq99ksmqsc4zkn"))
+ (patches (search-patches "libcroco-CVE-2020-12825.patch"))))))
+
(define-public libgsf
(package
(name "libgsf")
@@ -3301,7 +3317,8 @@ dealing with different structured file formats.")
(build-system cargo-build-system)
(outputs '("out" "doc"))
(arguments
- `(#:modules
+ `(#:install-source? #f
+ #:modules
((guix build cargo-build-system)
(guix build utils)
((guix build gnu-build-system) #:prefix gnu:))
@@ -4043,14 +4060,14 @@ Hints specification (EWMH).")
(define-public goffice
(package
(name "goffice")
- (version "0.10.48")
+ (version "0.10.49")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/goffice/"
(version-major+minor version) "/"
"goffice-" version ".tar.xz"))
(sha256
- (base32 "1z6f3q8fxkd1ysqrwdxdi0844zqa00vjpf07gq8mh3kal8picfd4"))))
+ (base32 "1s87ngs3g3nfvcn96aq4lgzx5cscbfg4n9f6ns2zpvc5ngdiiz2z"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ; 4.0 MiB of gtk-doc
@@ -4107,7 +4124,7 @@ Hints specification (EWMH).")
(define-public gnumeric
(package
(name "gnumeric")
- (version "1.12.48")
+ (version "1.12.49")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gnumeric/"
@@ -4115,7 +4132,7 @@ Hints specification (EWMH).")
"gnumeric-" version ".tar.xz"))
(sha256
(base32
- "14556b0vyxdvdwjlin0rv7jk0vq4nplbmvp9j89bhkfk84xf7k2p"))))
+ "0mzdhhpa7kwkc51l344g6vgqwaxkjdf03s7zasqh0bn3jpn75h4i"))))
(build-system glib-or-gtk-build-system)
(arguments
`(;; The gnumeric developers don't worry much about failing tests.
@@ -4793,8 +4810,7 @@ and the GLib main loop, to integrate well with GNOME applications.")
;;; A minimal version of libsoup used to prevent a cycle with Inkscape.
(define-public libsoup-minimal
- (package
- (inherit libsoup)
+ (package/inherit libsoup
(name "libsoup-minimal")
(outputs (delete "doc" (package-outputs libsoup)))
(arguments
@@ -6354,7 +6370,7 @@ part of udev-extras, then udev, then systemd. It's now a project on its own.")
(define-public gvfs
(package
(name "gvfs")
- (version "1.40.1")
+ (version "1.40.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gvfs/"
@@ -6362,7 +6378,7 @@ part of udev-extras, then udev, then systemd. It's now a project on its own.")
"gvfs-" version ".tar.xz"))
(sha256
(base32
- "1cfnzamr4mvgpf6yhm28lh9cafy9z6842s8jpbqnfizfxybg8ylj"))
+ "07lpcfric3h0302n9b1pwa38mjb76r9s98kg2867y2d1qvzfivxx"))
;; This patch may be removed when upgrading to version 1.46.x.
(patches
(search-patches "gvfs-add-support-for-libplist-2.2.patch"))))
@@ -6409,6 +6425,10 @@ part of udev-extras, then udev, then systemd. It's now a project on its own.")
("openssh" ,openssh)
("polkit" ,polkit)
("udisks" ,udisks)))
+ ;; CVE-2019-{12447,12448,12449} are fixed in the 1.40.2 release.
+ (properties '((lint-hidden-cve . ("CVE-2019-12447"
+ "CVE-2019-12448"
+ "CVE-2019-12449"))))
(home-page "https://wiki.gnome.org/gvfs/")
(synopsis "Userspace virtual file system for GIO")
(description
@@ -6839,7 +6859,7 @@ classes for commonly used data structures.")
(define-public gexiv2
(package
(name "gexiv2")
- (version "0.12.1")
+ (version "0.12.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -6847,7 +6867,7 @@ classes for commonly used data structures.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0xxxq8xdkgkn146my307jgws4qgxx477h0ybg1mqza1ycmczvsla"))))
+ "0k4ljzzz5dwqndw8awvlw3ala8rh3b2rk9i4jzvywc53mi9ba8i3"))))
(build-system meson-build-system)
(native-inputs
`(("gcr" ,gcr)
@@ -7390,7 +7410,9 @@ Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(patches (search-patches "evolution-data-server-locales.patch"
- "evolution-data-server-libical-compat.patch"))
+ "evolution-data-server-libical-compat.patch"
+ "evolution-data-server-CVE-2020-14928.patch"
+ "evolution-data-server-CVE-2020-16117.patch"))
(sha256
(base32
"16z85y6hhazcrp5ngw47w4x9r0j8zrj7awv5im58hhp0xs19zf1y"))))
@@ -8333,7 +8355,7 @@ properties, screen resolution, and other GNOME parameters.")
(define-public gnome-shell
(package
(name "gnome-shell")
- (version "3.34.2")
+ (version "3.34.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -8341,8 +8363,9 @@ properties, screen resolution, and other GNOME parameters.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0k9vq2gh1nhdd6fpp7jnwx37qxaakawiqw1xnlfjvq5g5zdn8ckh"))
- (patches (search-patches "gnome-shell-theme.patch"
+ "0l3mdn7g2c22mdhrqkxvvc1pk2w0v32f2v4a6n1phvaalwcg75nj"))
+ (patches (search-patches "gnome-shell-CVE-2020-17489.patch"
+ "gnome-shell-theme.patch"
"gnome-shell-disable-test.patch"))
(modules '((guix build utils)))
(snippet
@@ -8484,6 +8507,9 @@ properties, screen resolution, and other GNOME parameters.")
;; Missing propagation? See also: <https://bugs.gnu.org/27264>
("librsvg" ,librsvg)
("geoclue" ,geoclue)))
+ ;; CVE-2019-3820 was fixed before GNOME 3.34 was released, in upstream
+ ;; commit f0a7395b3006360905ccdc642982f9fc67378927.
+ (properties '((lint-hidden-cve . ("CVE-2019-3820"))))
(synopsis "Desktop shell for GNOME")
(home-page "https://wiki.gnome.org/Projects/GnomeShell")
(description
@@ -8540,7 +8566,7 @@ core C library, and bindings for Python (PyGTK).")
(define-public gnome-autoar
(package
(name "gnome-autoar")
- (version "0.2.4")
+ (version "0.3.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -8548,7 +8574,7 @@ core C library, and bindings for Python (PyGTK).")
name "-" version ".tar.xz"))
(sha256
(base32
- "0yk56ch46n3wfy633mq31kif9n7v06rlij4vqbsbn6l4z1vw6d0a"))))
+ "1y6hh5dldhdq7mpbmd571zl0yadfackvifhnxvykkqqddwz72y0f"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
@@ -8940,7 +8966,7 @@ associations for GNOME.")
(define-public libgovirt
(package
(name "libgovirt")
- (version "0.3.6")
+ (version "0.3.8")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -8948,7 +8974,7 @@ associations for GNOME.")
name "-" version ".tar.xz"))
(sha256
(base32
- "19pb71pag3vsi83kbv8h08kimwym4hpw36kjl6a5ik5nk50mc8sg"))))
+ "1y0x1wyakj3ya33hgj0w1jkbcn50q21gmn2zyalxysqp55i1ij8x"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -9983,8 +10009,7 @@ accessibility infrastructure.")
(properties '((upstream-name . "pyatspi")))))
(define-public python2-pyatspi
- (package
- (inherit python-pyatspi)
+ (package/inherit python-pyatspi
(name "python2-pyatspi")
(inputs
`(("python" ,python-2)))
@@ -10620,7 +10645,8 @@ generic enough to work for everyone.")
"evolution-" version ".tar.xz"))
(sha256
(base32
- "164vy8h432pjglafn8y2ms4gsvk3kbgc63h5qp0mk5dv4smsp29c"))))
+ "164vy8h432pjglafn8y2ms4gsvk3kbgc63h5qp0mk5dv4smsp29c"))
+ (patches (search-patches "evolution-CVE-2020-11879.patch"))))
(build-system cmake-build-system)
(arguments
`(#:imported-modules (,@%cmake-build-system-modules
@@ -10683,7 +10709,7 @@ functionality.")
(define-public gthumb
(package
(name "gthumb")
- (version "3.8.2")
+ (version "3.10.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gthumb/"
@@ -10691,7 +10717,7 @@ functionality.")
"gthumb-" version ".tar.xz"))
(sha256
(base32
- "15wqks35ks5dm7zj046dfd45vvrilan2ayfy2sxiprv7q74cip2q"))))
+ "14sw8d37g1lkp44dwsgyxjjsgh5pnpp4wq00mcy9p3rp30lf9spx"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -10730,19 +10756,20 @@ advanced image management tool")
(define-public terminator
(package
(name "terminator")
- (version "1.92")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/gnome-" name "/" name "/"
- "releases/download/v" version "/"
- name "-" version ".tar.gz"))
- (sha256
- (base32
- "1wbkfp0nk6x9bcwi681zy30qmrp4h754sdz6b7hi9j22mmvdd50z"))))
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/gnome-terminator/terminator/"
+ "releases/download/v" version "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vap4li2i24l1iz2q4b8wvhj8flamarf18xcmzq5ik2vzcrisbjy"))))
(build-system python-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin") ; for glib-compile-resources
+ ("glib:bin" ,glib "bin") ; for glib-compile-resources
("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)
("pkg-config" ,pkg-config)
@@ -10754,33 +10781,45 @@ advanced image management tool")
("dbus-glib" ,dbus-glib)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)
+ ("python" ,python-wrapper)
+ ("python-dbus" ,python-dbus)
+ ("python-notify2" ,python-notify2)
("python-pycairo" ,python-pycairo)
("python-pygobject" ,python-pygobject)
("vte" ,vte)))
(propagated-inputs
`(("python-configobj" ,python-configobj)))
(arguments
- `(#:imported-modules ((guix build glib-or-gtk-build-system)
+ ;; One test out of 28 fails due to dbus-python and python-notify; skip
+ ;; tests.
+ `(#:tests? #f
+ #:imported-modules ((guix build glib-or-gtk-build-system)
,@%python-build-system-modules)
#:modules ((guix build python-build-system)
((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
(guix build utils))
#:phases
(modify-phases %standard-phases
- (add-after
- 'install 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((prog (string-append (assoc-ref outputs "out")
- "/bin/terminator"))
- (pylib (string-append (assoc-ref outputs "out")
- "/lib/python"
- ,(version-major+minor
- (package-version python))
- "/site-packages")))
- (wrap-program prog
- `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH") ,pylib))
- `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
- #t)))
+ (add-after 'unpack 'handle-dbus-python
+ (lambda _
+ ;; python-dbus cannot be found but it's really there. See
+ ;; https://github.com/SpotlightKid/jack-select/issues/2
+ (substitute* "setup.py"
+ (("'dbus-python',") ""))
+ #t))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/terminator"))
+ (pylib (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t)))
(add-after 'wrap-program 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(home-page "https://gnome-terminator.org/")
@@ -10793,7 +10832,7 @@ tabs, and it supports drag and drop re-ordering of terminals.")
(define-public libhandy
(package
(name "libhandy")
- (version "1.0.3")
+ (version "1.2.0")
(source
(origin
(method git-fetch)
@@ -10802,7 +10841,7 @@ tabs, and it supports drag and drop re-ordering of terminals.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0flgwlm921801i3ns0dwqpnxl89f3rzn4y9h723i13bmflch3in7"))))
+ (base32 "1a8wfgm2jd3gcbk1nzhq6f2xq7vkxdc9qky8p9k0za9gqi7xfg4v"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
@@ -11070,7 +11109,7 @@ index files needed for Adwaita to be used outside of GNOME.")
(define-public gnote
(package
(name "gnote")
- (version "3.38.0")
+ (version "3.38.1")
(source
(origin
(method url-fetch)
@@ -11078,7 +11117,7 @@ index files needed for Adwaita to be used outside of GNOME.")
(version-major+minor version) "/"
"gnote-" version ".tar.xz"))
(sha256
- (base32 "1ingbaw4d8vpjn083xvzqw7kz8z0k2bx7msk78pbzd68bwgkadpx"))))
+ (base32 "1adjfjhmsm2d33999khjyzvli6kiz1jlzavn77jhd49kfzhxa9y4"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("desktop-file-utils" ,desktop-file-utils)
@@ -11231,7 +11270,8 @@ these services on the Guix System.")
(file-name (git-file-name name version))
(sha256
(base32
- "01cc921kyh3zxz07biqbdzkjgmdcc36kwjyajm4y382a75cl5zg7"))))
+ "01cc921kyh3zxz07biqbdzkjgmdcc36kwjyajm4y382a75cl5zg7"))
+ (patches (search-patches "geary-CVE-2020-24661.patch"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -11821,7 +11861,7 @@ integrated profiler via Sysprof, debugging support, and more.")
(define-public komikku
(package
(name "komikku")
- (version "0.26.1")
+ (version "0.27.0")
(source
(origin
(method git-fetch)
@@ -11831,7 +11871,7 @@ integrated profiler via Sysprof, debugging support, and more.")
(file-name (git-file-name name version))
(sha256
(base32
- "1mas409c14p6g0v10w4cf5hsjbs0922h6h9k9pyj9s8y7yi2ikz2"))))
+ "0mj4bsy7jp9wjj1dqz9zdq5aj0ib813wkz5k1481k80jp9dnlqnv"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -11863,6 +11903,7 @@ integrated profiler via Sysprof, debugging support, and more.")
("libnotify" ,libnotify)
("libsecret" ,libsecret)
("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-brotli" ,python-brotli)
("python-dateparser" ,python-dateparser)
("python-keyring" ,python-keyring)
("python-lxml" ,python-lxml)
@@ -11872,7 +11913,8 @@ integrated profiler via Sysprof, debugging support, and more.")
("python-pycairo" ,python-pycairo)
("python-pygobject" ,python-pygobject)
("python-requests" ,python-requests)
- ("python-unidecode" ,python-unidecode)))
+ ("python-unidecode" ,python-unidecode)
+ ("webkitgtk" ,webkitgtk)))
(native-inputs
`(("desktop-file-utils" ,desktop-file-utils)
("gettext" ,gettext-minimal)