summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm34
1 files changed, 14 insertions, 20 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4c3e47bb8c..abcc485b79 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2121,7 +2121,9 @@ dealing with different structured file formats.")
("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
(inputs
- `(("pango" ,pango)
+ `(;; XXX: 1.44 causes some test failures, so we stick with 1.42 for
+ ;; this ancient version of librsvg.
+ ("pango" ,pango-1.42)
("libcroco" ,libcroco)
("bzip2" ,bzip2)
("libgsf" ,libgsf)
@@ -2466,7 +2468,9 @@ functionality was designed to be as reusable and portable as possible.")
"0l3mhpyym9m5iz09fz0rgiqxl2ym6kpkwpsp1xrr4aa80nlh1jam"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
+ `(;; The "timeout-server" test hangs when run in parallel.
+ #:parallel-tests? #f
+ #:configure-flags
'(;; We don't need static libraries, plus they don't build reproducibly
;; (non-deterministic ordering of .o files in the archive.)
"--disable-static"
@@ -2799,7 +2803,7 @@ creating interactive structured graphics.")
("libgnome" ,libgnome)
("libgnomecanvas" ,libgnomecanvas)
("libgnome-keyring" ,libgnome-keyring)))
- (inputs `(("libjpeg" ,libjpeg)
+ (inputs `(("libjpeg" ,libjpeg-turbo)
("popt" ,popt)
("libbonobo" ,libbonobo)
("libxml2" ,libxml2)
@@ -3111,7 +3115,7 @@ Hints specification (EWMH).")
`(("bison" ,bison)
("docbook-xml" ,docbook-xml)
("intltool" ,intltool)
- ("itstool" ,itstool/fixed) ;see <https://bugs.gnu.org/37468>
+ ("itstool" ,itstool)
("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)))
(home-page "http://www.gnumeric.org")
@@ -3428,6 +3432,7 @@ and RDP protocols.")
"mirror://gnome/sources/" name "/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
+ (patches (search-patches "dconf-meson-0.52.patch"))
(sha256
(base32
"1azz4hb9z76yxn34yrrsiib3iqz5z4vpwn5q7cncp55w365ygg38"))))
@@ -3981,7 +3986,7 @@ more fun.")
("vte" ,vte)
("gnutls" ,gnutls)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("util-linux" ,util-linux)
+ ("util-linux" ,util-linux "lib")
("vala" ,vala)))
(home-page "https://wiki.gnome.org/Apps/Terminal")
(synopsis "Terminal emulator")
@@ -5145,7 +5150,7 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
("lcms" ,lcms)
("libexif" ,libexif)
("libpeas" ,libpeas)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("librsvg" ,librsvg)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)))
@@ -5655,17 +5660,6 @@ lifting is done by packages like yelp-xsl and itstool. This package just
wraps things up in a developer-friendly way.")
(license license:gpl2+)))
-(define-public yelp-tools/fixed
- ;; This variant fixes a python-libxml2 crash when processing UTF-8
- ;; sequences: <https://bugs.gnu.org/37468>. TODO: Remove this in
- ;; the next rebuild cycle.
- (hidden-package
- (package/inherit
- yelp-tools
- (propagated-inputs
- `(("itstool" ,itstool/fixed)
- ,@(alist-delete "itstool" (package-propagated-inputs yelp-tools)))))))
-
(define-public libgee
(package
(name "libgee")
@@ -7465,7 +7459,7 @@ easy, safe, and automatic.")
("openjpeg" ,openjpeg-1)
("libseccomp" ,libseccomp)
("libsoup" ,libsoup)
- ("libuuid" ,util-linux)
+ ("libuuid" ,util-linux "lib")
("network-manager" ,network-manager)))
(synopsis "Metadata database, indexer and search tool")
(home-page "https://wiki.gnome.org/Projects/Tracker")
@@ -7525,7 +7519,7 @@ shared object databases, search tools and indexing.")
("libgsf" ,libgsf)
("libgxps" ,libgxps)
("libiptcdata" ,libiptcdata)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("libosinfo" ,libosinfo)
("libpng" ,libpng)
("libseccomp" ,libseccomp)
@@ -9460,7 +9454,7 @@ functionality.")
("clutter" ,clutter)
("clutter-gst" ,clutter-gst)
("clutter-gtk" ,clutter-gtk)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("libtiff" ,libtiff)
("libraw" ,libraw)))
(home-page "https://wiki.gnome.org/Apps/Gthumb")