summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm26
1 files changed, 15 insertions, 11 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ca573d55ee..e03ed77374 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2721,7 +2721,7 @@ and how they are displayed (View).")
(define-public gtg
(package
(name "gtg")
- (version "0.4")
+ (version "0.5")
(source
(origin
(method git-fetch)
@@ -2730,7 +2730,7 @@ and how they are displayed (View).")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0r28vyr88rj3kd3cg4gj7sd29wadjchi92wzmbx67d4hlg25h8kk"))))
+ (base32 "0b2slm7kjq6q8c7v4m7aqc8m1ynjxn3bl7445srpv1xc0dilq403"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -2757,10 +2757,13 @@ and how they are displayed (View).")
("gtk+:bin" ,gtk+ "bin")
("pkg-config" ,pkg-config)))
(inputs
- `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ `(("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)
+ ("pango" ,pango)
("python-dbus" ,python-dbus)
("python-liblarch" ,python-liblarch)
+ ("python-lxml" ,python-lxml)
("python-pycairo" ,python-pycairo)
("python-pygobject" ,python-pygobject)
("python-pyxdg" ,python-pyxdg)))
@@ -4084,14 +4087,14 @@ Hints specification (EWMH).")
(define-public goffice
(package
(name "goffice")
- (version "0.10.49")
+ (version "0.10.50")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/goffice/"
(version-major+minor version) "/"
"goffice-" version ".tar.xz"))
(sha256
- (base32 "1s87ngs3g3nfvcn96aq4lgzx5cscbfg4n9f6ns2zpvc5ngdiiz2z"))))
+ (base32 "1p5zbj7cbcfcxd6l8pnph54p6ah1bwf146y810j4bcq8ggf3sp1c"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ; 4.0 MiB of gtk-doc
@@ -4148,7 +4151,7 @@ Hints specification (EWMH).")
(define-public gnumeric
(package
(name "gnumeric")
- (version "1.12.49")
+ (version "1.12.50")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gnumeric/"
@@ -4156,7 +4159,7 @@ Hints specification (EWMH).")
"gnumeric-" version ".tar.xz"))
(sha256
(base32
- "0mzdhhpa7kwkc51l344g6vgqwaxkjdf03s7zasqh0bn3jpn75h4i"))))
+ "1f0lrj5msg80pgjp38jj6rddf352gwddgip7z4lki66n3fx1k23m"))))
(build-system glib-or-gtk-build-system)
(arguments
`(;; The gnumeric developers don't worry much about failing tests.
@@ -4209,7 +4212,7 @@ engineering.")
(define-public drawing
(package
(name "drawing")
- (version "0.6.5")
+ (version "0.8.0")
(source
(origin
(method git-fetch)
@@ -4218,7 +4221,7 @@ engineering.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1kfgmalakifcvzhzss9zhmqjbdk24zr22c5xwkkahlvfcafp13wn"))))
+ (base32 "03cx6acb0ph7b3difshjfddi8ld79wp8d12bdp7dp1q1820j5mz0"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -11956,7 +11959,7 @@ integrated profiler via Sysprof, debugging support, and more.")
(define-public komikku
(package
(name "komikku")
- (version "0.29.0")
+ (version "0.29.2")
(source
(origin
(method git-fetch)
@@ -11966,7 +11969,7 @@ integrated profiler via Sysprof, debugging support, and more.")
(file-name (git-file-name name version))
(sha256
(base32
- "1sirwgny1s6jv9rb0lildqv4p7nfa15rvw957pwxnvrjasxyf6bq"))))
+ "0g1whk0y3k1cy6ix20gz226ww1vzpb9hinn5d24z6j38mdgqqa5l"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -11999,6 +12002,7 @@ integrated profiler via Sysprof, debugging support, and more.")
("libsecret" ,libsecret)
("python-beautifulsoup4" ,python-beautifulsoup4)
("python-brotli" ,python-brotli)
+ ("python-cloudscraper" ,python-cloudscraper)
("python-dateparser" ,python-dateparser)
("python-keyring" ,python-keyring)
("python-lxml" ,python-lxml)