summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm321
1 files changed, 285 insertions, 36 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f50bcfc105..84c98b0ff8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -14,18 +14,19 @@
;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
-;;; Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
+;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016, 2017 ng0 <ng0@infotropique.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 nee <nee-git@hidamari.blue>
;;; Copyright © 2017 Chris Marusich <cmmarusich@gmail.com>
+;;; Copyright © 2017 Mohammed Sadiq <sadiq@sadiqpk.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -51,6 +52,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
@@ -138,6 +140,7 @@
#:use-module (gnu packages fonts)
#:use-module (gnu packages speech)
#:use-module (gnu packages virtualization)
+ #:use-module (gnu packages vpn)
#:use-module (srfi srfi-1))
(define-public brasero
@@ -312,7 +315,7 @@ either on a local, or remote machine via a number of methods.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'run-autogen
+ (add-after 'unpack 'run-autogen
(lambda _
(system* "sh" "autogen.sh"))))))
(home-page "https://wiki.gnome.org/Apps/Dia")
@@ -765,7 +768,7 @@ on the GNOME Desktop with a single simple application.")
(define-public gsettings-desktop-schemas
(package
(name "gsettings-desktop-schemas")
- (version "3.24.0")
+ (version "3.24.1")
(source
(origin
(method url-fetch)
@@ -774,7 +777,7 @@ on the GNOME Desktop with a single simple application.")
name "-" version ".tar.xz"))
(sha256
(base32
- "145vpcljy4660cnk8zk91qf7ywa7hqfl5hhw025gy8hxcqzklmzn"))))
+ "19zfqy58missq5cck13ip8j824hb9whqg2c4cr6hgrlxkwqgm8vn"))))
(build-system gnu-build-system)
(inputs
`(("glib" ,glib)))
@@ -932,7 +935,7 @@ database is translated at Transifex.")
(define-public hicolor-icon-theme
(package
(name "hicolor-icon-theme")
- (version "0.15")
+ (version "0.17")
(source
(origin
(method url-fetch)
@@ -940,7 +943,7 @@ database is translated at Transifex.")
"hicolor-icon-theme-" version ".tar.xz"))
(sha256
(base32
- "1k1kf2c5zbqh31nglc3nxs9j6wr083k9kjyql8p22ccc671mmi4w"))))
+ "1n59i3al3zx6p90ff0l43gzpzmlqnzm6hf5cryxqrlbi48sq8x1i"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f)) ; no check target
@@ -987,7 +990,7 @@ some form of information without getting in the user's way.")
(define-public libpeas
(package
(name "libpeas")
- (version "1.20.0")
+ (version "1.22.0")
(source
(origin
(method url-fetch)
@@ -996,12 +999,11 @@ some form of information without getting in the user's way.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0m6k6fcrx40n92nc1cy3z72vs1ja49sb58dj3fjp40605pzgz4pk"))))
+ "0qm908kisyjzjxvygdl18hjqxvvgkq9w0phs2g55pck277sw0bsv"))))
(build-system gnu-build-system)
(inputs
`(("gtk+" ,gtk+)
("glade" ,glade3)
- ("libxml2" ,libxml2) ; XXX: required by gladeui-2.0.pc
("python" ,python)
("python-pygobject" ,python-pygobject)))
(native-inputs
@@ -2647,7 +2649,7 @@ floating in an ocean using only your brain and a little bit of luck.")
(define-public gnome-sudoku
(package
(name "gnome-sudoku")
- (version "3.24.0")
+ (version "3.26.0")
(source
(origin
(method url-fetch)
@@ -2656,7 +2658,7 @@ floating in an ocean using only your brain and a little bit of luck.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1mw5ykk7wr0r9770jj5270f07rjws0pmpjs0b1fywj4li13r98h4"))))
+ "186k2axryn3ic8blc9ddnvyrqqf88khg2hlisfa1n4wp784wfx47"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -2963,11 +2965,20 @@ service via the system message bus.")
(substitute* "data/Locations.xml"
(("Asia/Rangoon")
"Asia/Yangon"))
- #t)))))
+ #t))
+ (replace 'install
+ (lambda _
+ (zero?
+ (system* "make"
+ ;; Install vala bindings into $out.
+ (string-append "vapidir=" %output
+ "/share/vala/vapi")
+ "install")))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums
("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
+ ("vala" ,vala)
("intltool" ,intltool)))
(propagated-inputs
;; gweather-3.0.pc refers to GTK+, GDK-Pixbuf, GLib/GObject, libxml, and
@@ -2989,7 +3000,7 @@ services for numerous locations.")
(define-public gnome-settings-daemon
(package
(name "gnome-settings-daemon")
- (version "3.24.2")
+ (version "3.24.3")
(source
(origin
(method url-fetch)
@@ -2998,7 +3009,7 @@ services for numerous locations.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1jnw920zn4cadhgmcv2q5ylzqhwm1rmrhf3a14q8mvp38hkdgaaa"))))
+ "14w5jhpq02mbcxvn41qcj3cjfqdr3sgzl96c6glwpdrjphw61i38"))))
(build-system glib-or-gtk-build-system)
(arguments
`(;; Color management test can't reach the colord system service.
@@ -3331,7 +3342,7 @@ GL based interactive canvas library.")
(define-public libchamplain
(package
(name "libchamplain")
- (version "0.12.15")
+ (version "0.12.16")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3339,7 +3350,7 @@ GL based interactive canvas library.")
version ".tar.xz"))
(sha256
(base32
- "0x5qa1aw1y59lzkmf4j4szspn49341a87vcja4ydgxny1chilwjl"))))
+ "13chvc2n074i0jw5jlb8i7cysda4yqx58ca6y3mrlrl9g37k2zja"))))
(build-system gnu-build-system)
(arguments '(#:configure-flags '("--enable-vala")))
(native-inputs
@@ -3399,7 +3410,7 @@ queries upon that data.")
(define-public libgnome-games-support
(package
(name "libgnome-games-support")
- (version "1.2.2")
+ (version "1.2.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -3407,7 +3418,7 @@ queries upon that data.")
name "-" version ".tar.xz"))
(sha256
(base32
- "04qbgcgmc01sinhbqdljiny8q868l01nkdawj8wrnqnd1i8czvsg"))))
+ "1vwad7kqy7yd6wqyr71nq0blh7m53r3lz6ya16dmh942kd0w48v1"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -3435,7 +3446,7 @@ GNOME Games, but it may be used by others.")
(define-public gnome-klotski
(package
(name "gnome-klotski")
- (version "3.22.1")
+ (version "3.22.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -3443,7 +3454,7 @@ GNOME Games, but it may be used by others.")
name "-" version ".tar.xz"))
(sha256
(base32
- "04ragvrz29sydi2kf1zk2aimi3b3hn34jrndfd2lx6h8l45anq3q"))))
+ "16hd6yk01rhb4pj8m01fyn72wykf41d72gsms81q0n4zm5bm1a4h"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("desktop-file-utils" ,desktop-file-utils)
@@ -4087,7 +4098,7 @@ a secret password store, an adblocker, and a modern UI.")
(define-public epiphany
(package
(name "epiphany")
- (version "3.24.3")
+ (version "3.24.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4095,7 +4106,7 @@ a secret password store, an adblocker, and a modern UI.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0m51cclpnb7lxk8w526rriyb2bi3aj17fbcvikhkg7qd65v1dxgy"))))
+ "1jg59s98aljf603w24r5a3cr4fw6z88gc0warqy1946iprjgdw0m"))))
(build-system glib-or-gtk-build-system)
(arguments
;; FIXME: tests run under Xvfb, but fail with:
@@ -4719,7 +4730,6 @@ to display dialog boxes from the commandline and shell scripts.")
("cairo" ,cairo)
("gdk-pixbuf" ,gdk-pixbuf)
("glib" ,glib)
- ("glib" ,glib)
("gtk+" ,gtk+)
("json-glib" ,json-glib)
("libinput" ,libinput)
@@ -4760,7 +4770,7 @@ window manager.")
(define-public gnome-online-accounts
(package
(name "gnome-online-accounts")
- (version "3.24.2")
+ (version "3.24.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -4768,7 +4778,7 @@ window manager.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1fmgywfcvlb5sa0slxxlg80gafiaal8vnq6h5lcybqa12lnxa2mp"))))
+ "0m1qf2ffxzmwxa157lrvh3507d5gr3lg4kvj653zhcihjpmmhbi5"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
@@ -4923,7 +4933,7 @@ users.")
(define-public network-manager
(package
(name "network-manager")
- (version "1.8.0")
+ (version "1.8.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/NetworkManager/"
@@ -4931,7 +4941,7 @@ users.")
"NetworkManager-" version ".tar.xz"))
(sha256
(base32
- "17pn7kzilyl0qk525gp9xnbz4x0ssrdmgk1lvw95pyfd6rm5qnps"))
+ "1x0vzxvrck0snga2n3pc7g74m20zz74cr4r8gfspl8sckv6yz9bi"))
(snippet
'(begin
(use-modules (guix build utils))
@@ -5044,6 +5054,39 @@ services.")
(license license:gpl2+)
(properties '((upstream-name . "NetworkManager")))))
+(define-public network-manager-openvpn
+ (package
+ (name "network-manager-openvpn")
+ (version "1.2.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnome/sources/NetworkManager-openvpn/"
+ (version-major+minor version)
+ "/NetworkManager-openvpn-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0q9x61fq509gybz3ljzyvf9zn8nlya1r2vk7jl0gk3fp76jsg1mc"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--enable-absolute-paths")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("openvpn" ,openvpn)
+ ("network-manager" ,network-manager)
+ ("network-manager-applet" ,network-manager-applet) ;for libnma
+ ("libsecret" ,libsecret)))
+ (home-page "https://wiki.gnome.org/Projects/NetworkManager/VPN")
+ (synopsis "OpenVPN plug-in for NetworkManager")
+ (description
+ "This extension of NetworkManager allows it to take care of connections
+to virtual private networks (VPNs) via OpenVPN.")
+ (license license:gpl2+)
+ (properties `((upstream-name . "NetworkManager-openvpn")))))
+
(define-public mobile-broadband-provider-info
(package
(name "mobile-broadband-provider-info")
@@ -5262,7 +5305,7 @@ providing graphical log-ins and managing local and remote displays.")
(define-public libgtop
(package
(name "libgtop")
- (version "2.36.0")
+ (version "2.38.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -5270,7 +5313,7 @@ providing graphical log-ins and managing local and remote displays.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0ax17c7nplghxgsf8zl92nmhkbnggj62wwzl7nq00aqb2m6f7gqk"))))
+ "04mnxgzyb26wqk6qij4iw8cxwl82r8pcsna5dg8vz2j3pdi0wv2g"))))
(build-system gnu-build-system)
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
@@ -5546,7 +5589,7 @@ easy, safe, and automatic.")
(define-public tracker
(package
(name "tracker")
- (version "1.12.2")
+ (version "1.12.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -5554,7 +5597,7 @@ easy, safe, and automatic.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1zdzh8l5ahi906i40i4pqw2cs1hwrl6l9a7fp344a3idk3pl5szb"))))
+ "1mpq418lzba7fad0w0m3bnxvz3khf461b5zya8zmq5n1g0w99ki3"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("gnome-common" ,gnome-common)
@@ -5925,6 +5968,34 @@ specified duration and save it as a GIF encoded animated image file.")
(home-page "https://git.gnome.org/browse/byzanz")
(license license:gpl2+))))
+(define-public gsound
+ (package
+ (name "gsound")
+ (version "1.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0lwfwx2c99qrp08pfaj59pks5dphsnxjgrxyadz065d8xqqgza5v"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("gobject-introspection" ,gobject-introspection)
+ ("vala" ,vala)))
+ (inputs
+ `(("glib" ,glib)
+ ("libcanberra" ,libcanberra)))
+ (home-page "https://wiki.gnome.org/Projects/GSound")
+ (synopsis "GObject wrapper for libcanberra")
+ (description
+ "GSound is a small library for playing system sounds. It's designed to be
+used via GObject Introspection, and is a thin wrapper around the libcanberra C
+library.")
+ (license license:lgpl2.1+)))
+
(define-public libzapojit
(package
(name "libzapojit")
@@ -5953,6 +6024,44 @@ specified duration and save it as a GIF encoded animated image file.")
Microsoft SkyDrive and Hotmail, using their REST protocols.")
(license license:lgpl2.1+)))
+(define-public gnome-clocks
+ (package
+ (name "gnome-clocks")
+ (version "3.26.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "00a5bqi1hbyb9kbl4p393l1g6rddl2y6ljxjby9c5j3k1qka0c0g"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:glib-or-gtk? #t))
+ (native-inputs
+ `(("vala" ,vala)
+ ("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin") ; for glib-compile-resources
+ ("gtk+-bin" ,gtk+ "bin") ; for gtk-update-icon-cache
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("gettext" ,gettext-minimal)
+ ("itstool" ,itstool)))
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("gsound" ,gsound)
+ ("geoclue" ,geoclue)
+ ("geocode-glib" ,geocode-glib)
+ ("libgweather" ,libgweather)
+ ("gnome-desktop" ,gnome-desktop)))
+ (home-page "https://wiki.gnome.org/Apps/Clocks")
+ (synopsis "GNOME's clock application")
+ (description
+ "GNOME Clocks is a simple clocks application designed to fit the GNOME
+desktop. It supports world clock, stop watch, alarms, and count down timer.")
+ (license license:gpl3+)))
+
(define-public gnome-calendar
(package
(name "gnome-calendar")
@@ -5982,6 +6091,57 @@ Microsoft SkyDrive and Hotmail, using their REST protocols.")
desktop. It supports multiple calendars, monthly view and yearly view.")
(license license:gpl3+)))
+(define-public gnome-todo
+ (package
+ (name "gnome-todo")
+ (version "3.26.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "13if2lg4r65v3z7h5y57qv4iqz9ihjaml8bzvvihha7dffyr1lz4"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:glib-or-gtk? #t
+ #:phases (modify-phases %standard-phases
+ (add-after
+ 'install 'wrap-gnome-todo
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
+ (python-path (getenv "PYTHONPATH")))
+ (wrap-program (string-append out "/bin/gnome-todo")
+ ;; XXX: gi plugins are broken.
+ ;; See https://bugzilla.gnome.org/show_bug.cgi?id=787212
+ ;; For plugins.
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
+ `("PYTHONPATH" ":" prefix (,python-path))))
+ #t)))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("gobject-introspection" ,gobject-introspection)
+ ("glib:bin" ,glib "bin") ; For glib-compile-resources
+ ("gtk+-bin" ,gtk+ "bin") ; For gtk-update-icon-cache
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("rest" ,rest) ; For Todoist plugin
+ ("json-glib" ,json-glib) ; For Todoist plugin
+ ("libical" ,libical)
+ ("libpeas" ,libpeas)
+ ("python-pygobject" ,python-pygobject)
+ ("evolution-data-server" ,evolution-data-server)
+ ("gnome-online-accounts" ,gnome-online-accounts)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
+ (home-page "https://wiki.gnome.org/Apps/Todo")
+ (synopsis "GNOME's ToDo Application")
+ (description
+ "GNOME To Do is a simplistic personal task manager designed to perfectly
+fit the GNOME desktop.")
+ (license license:gpl3+)))
+
(define-public gnome-dictionary
(package
(name "gnome-dictionary")
@@ -6066,7 +6226,7 @@ GNOME Shell appearance and extension, etc.")
(define-public gnome-shell-extensions
(package
(name "gnome-shell-extensions")
- (version "3.24.2")
+ (version "3.24.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -6074,7 +6234,7 @@ GNOME Shell appearance and extension, etc.")
name "-" version ".tar.xz"))
(sha256
(base32
- "10sg87wml5cmyk90pybnr6r942ba7173sl7yplhj2sfggp0wc74s"))))
+ "0y8anpp9ymp0lxn15w63ra6zxxf8nvbl48xqkvqdjzida73fyz9w"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--enable-extensions=all")))
@@ -6422,7 +6582,7 @@ only know by its Unicode name or code point.")
(define-public bluefish
(package
(name "bluefish")
- (version "2.2.9")
+ (version "2.2.10")
(source
(origin
(method url-fetch)
@@ -6430,7 +6590,7 @@ only know by its Unicode name or code point.")
name "-" version ".tar.gz"))
(sha256
(base32
- "1vnl6raxbvc4hacg3pr6sqyjh707d304dhk5nyhlp7m0m1y3j756"))))
+ "1jw4has7lbp77lqmzvnnjmqcf0lacjfnka873lkkwdyrpzc4c1q4"))))
(build-system gnu-build-system)
(native-inputs
`(("desktop-file-utils" ,desktop-file-utils)
@@ -6754,3 +6914,92 @@ Lollypop plays audio formats such as mp3, mp4, ogg and flac and gets information
from artists and tracks from the web. It also fetches cover artworks
automatically and it can stream songs from online music services and charts.")
(license license:gpl3+)))
+
+(define-public gnome-video-effects
+ (package
+ (name "gnome-video-effects")
+ (version "0.4.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/" name "-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "06c2f1kihyhawap1s3zg5w7q7fypsybkp7xry4hxkdz4mpsy0zjs"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:out-of-source? #f))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("intltool" ,intltool)
+ ("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://wiki.gnome.org/Projects/GnomeVideoEffects")
+ (synopsis "Video effects for Cheese and other GNOME applications")
+ (description
+ "A collection of GStreamer video filters and effects to be used in
+photo-booth-like software, such as Cheese.")
+ (license license:gpl2+)))
+
+(define-public cheese
+ (package
+ (name "cheese")
+ (version "3.24.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/" name "-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0wpks2lnr8va9wxgmj26dwmhlcb3vamhpxkqi8xaan6q25635l16"))))
+ (arguments
+ ;; Tests require GDK.
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'skip-gtk-update-icon-cache
+ (lambda _
+ ;; Don't create 'icon-theme.cache'
+ (substitute* "Makefile"
+ (("gtk-update-icon-cache") (which "true")))
+ #t))
+ (add-after 'install 'wrap-cheese
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/cheese")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))))
+ #t)))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("libxml2" ,libxml2)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (propagated-inputs
+ `(("gnome-video-effects" ,gnome-video-effects)))
+ (inputs
+ `(("clutter" ,clutter)
+ ("clutter-gst" ,clutter-gst)
+ ("clutter-gtk" ,clutter-gtk)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("glib" ,glib)
+ ("gnome-desktop" ,gnome-desktop)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("gst-plugins-bad" ,gst-plugins-bad)
+ ("gtk+" ,gtk+)
+ ("libcanberra" ,libcanberra)
+ ("libx11" ,libx11)
+ ("libxtst" ,libxtst)))
+ (home-page "https://wiki.gnome.org/Apps/Cheese")
+ (synopsis "Webcam photo booth software for GNOME")
+ (description
+ "Cheese uses your webcam to take photos and videos. Cheese can also
+apply fancy special effects and lets you share the fun with others.")
+ (license license:gpl2+)))