summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm53
1 files changed, 27 insertions, 26 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7d052921b1..7ee520b7ae 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7760,7 +7760,7 @@ users.")
(define-public network-manager
(package
(name "network-manager")
- (version "1.24.0")
+ (version "1.32.12")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/NetworkManager/"
@@ -7769,18 +7769,15 @@ users.")
(patches (search-patches "network-manager-plugin-path.patch"))
(sha256
(base32
- "06044fl60bjlj7c6rqqfbm5795h61h6yzp7ch392hzcnm46wwhn3"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (substitute* "src/devices/wwan/nm-modem-manager.c"
- (("systemd") "elogind"))
- #t))))
+ "0jzmz0zw64dgvdn2g7pppr7bkywpbxcbdb1viv6p7zh2lnh3dax8"))))
(build-system meson-build-system)
(outputs '("out"
- "doc")) ; 8 MiB of gtk-doc HTML
+ "doc")) ; 8 MiB of gtk-doc HTML
(arguments
- `(#:configure-flags
+ ;; Use meson-0.59, otherwise the custom rpaths are not registered
+ ;; correctly (see: https://github.com/mesonbuild/meson/issues/9492).
+ `(#:meson ,meson-0.59
+ #:configure-flags
(let ((out (assoc-ref %outputs "out"))
(dhclient (search-input-file %build-inputs "/sbin/dhclient")))
(list
@@ -7818,33 +7815,38 @@ users.")
;; cope with being already in the Guix build jail as that jail
;; lacks some features that they would like to proxy over (like
;; a /sys mount).
- (substitute* "src/platform/tests/meson.build"
+ (substitute* "src/core/tests/meson.build"
+ ((".*test-l3cfg.*") ""))
+ (substitute* "src/core/devices/tests/meson.build"
+ ((".*test-acd.*") "")
+ ((".*test-lldp.*") ""))
+ (substitute* "src/core/platform/tests/meson.build"
((".*test-address-linux.*") "")
((".*test-cleanup-linux.*") "")
((".*test-link-linux.*") "")
- ((".*test-route-linux.*") ""))
- (substitute* "src/devices/tests/meson.build"
- ((".*test-acd.*") "")
- ((".*test-lldp.*") ""))
- #t))
+ ((".*test-lldp.*") "")
+ ((".*test-route-linux.*") "")
+ ((".*test-tc-linux.*") ""))
+ ;; FIXME: The jansson check fails (see:
+ ;; https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/issues/837
+ (substitute* "src/libnm-core-impl/tests/test-setting.c"
+ (("g_assert\\(nm_json_vt\\(\\)\\);")
+ "return TRUE;"))))
(add-after 'unpack 'patch-docbook-xml
(lambda* (#:key inputs #:allow-other-keys)
(let ((xmldoc (string-append (assoc-ref inputs "docbook-xml")
"/xml/dtd/docbook")))
(substitute* (find-files "." ".*\\.(xsl|xml)")
(("http://.*/docbookx\\.dtd")
- (string-append xmldoc "/docbookx.dtd")))
- #t)))
+ (string-append xmldoc "/docbookx.dtd"))))))
(add-before 'check 'pre-check
(lambda _
;; For the missing /etc/machine-id.
- (setenv "DBUS_FATAL_WARNINGS" "0")
- #t))
+ (setenv "DBUS_FATAL_WARNINGS" "0")))
(add-before 'install 'no-polkit-magic
;; Meson ‘magically’ invokes pkexec, which fails (not setuid).
(lambda _
- (setenv "PKEXEC_UID" "something")
- #t))
+ (setenv "PKEXEC_UID" "something")))
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -7855,8 +7857,7 @@ users.")
(string-append doc directory))
(delete-file-recursively
(string-append out directory)))
- '("/share/doc" "/share/gtk-doc"))
- #t))))))
+ '("/share/doc" "/share/gtk-doc"))))))))
(propagated-inputs
`(("glib" ,glib)))
(native-inputs
@@ -7894,8 +7895,8 @@ users.")
("libsoup" ,libsoup)
("mobile-broadband-provider-info" ,mobile-broadband-provider-info)
("modem-manager" ,modem-manager)
- ("newt" ,newt) ;for the 'nmtui' console interface
- ("openresolv" ,openresolv) ; alternative resolv.conf manager
+ ("newt" ,newt) ;for the 'nmtui' console interface
+ ("openresolv" ,openresolv) ; alternative resolv.conf manager
("polkit" ,polkit)
("ppp" ,ppp)
("readline" ,readline)