summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm50
1 files changed, 46 insertions, 4 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index b8cd32db08..24a1dc256c 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -123,7 +124,7 @@ the Obsidian icon theme.")
(define-public gnome-shell-extension-appindicator
(package
(name "gnome-shell-extension-appindicator")
- (version "30")
+ (version "33")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -132,7 +133,7 @@ the Obsidian icon theme.")
(commit (string-append "v" version))))
(sha256
(base32
- "1fjhx23jqwv3d0smwhnjvc35gqhwk9p5f96ic22pfax653cn5vh8"))
+ "0qm77s080nbf4gqnfzpwp8a7jf7lliz6fxbsd3lasvrr11pgsk87"))
(file-name (git-file-name name version))))
(build-system copy-build-system)
(arguments
@@ -146,6 +147,47 @@ GNOME Shell.")
(home-page "https://github.com/ubuntu/gnome-shell-extension-appindicator/")
(license license:gpl2+)))
+(define-public gnome-shell-extension-topicons-redux
+ (package
+ (name "gnome-shell-extension-topicons-redux")
+ (version "6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/pop-planet/TopIcons-Redux.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dli9xb545n3xlj6q4wl0y5gzkm903zs47p8fiq71pdvbr6v38rj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("glib" ,glib "bin")))
+ (arguments
+ `(#:tests? #f ;no test defined in the project
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "make"
+ "install"
+ (string-append
+ "INSTALL_PATH="
+ out
+ "/share/gnome-shell/extensions"))))))))
+ (home-page "https://gitlab.com/pop-planet/TopIcons-Redux")
+ (synopsis "Display legacy tray icons in the GNOME Shell top panel")
+ (description "Many applications, such as chat clients, downloaders, and
+some media players, are meant to run long-term in the background even after you
+close their window. These applications remain accessible by adding an icon to
+the GNOME Shell Legacy Tray. However, the Legacy Tray was removed in GNOME
+3.26. TopIcons Redux brings those icons back into the top panel so that it's
+easier to keep track of apps running in the backround.")
+ (license license:gpl2+)))
+
(define-public gnome-shell-extension-dash-to-dock
(package
(name "gnome-shell-extension-dash-to-dock")
@@ -391,7 +433,7 @@ It uses ES6 syntax and claims to be more actively maintained than others.")
(define-public gnome-shell-extension-paperwm
(package
(name "gnome-shell-extension-paperwm")
- (version "34.3")
+ (version "36.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -400,7 +442,7 @@ It uses ES6 syntax and claims to be more actively maintained than others.")
(file-name (git-file-name name version))
(sha256
(base32
- "1qry75f696pgmd9yzqvwhq5h6cipin2fvk7h881g29cjcpxim37a"))
+ "1ssnabwxrns36c61ppspjkr9i3qifv08pf2jpwl7cjv3pvyn4kly"))
(snippet
'(begin (delete-file "schemas/gschemas.compiled")))))
(build-system copy-build-system)