summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm22
1 files changed, 9 insertions, 13 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 6d8d02fb9c..6ba9656cdd 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 Ellis Kenyo <me@elken.dev>
;;; Copyright © 2020 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -603,7 +604,7 @@ notebooks and tiling window managers.")
(define-public arc-theme
(package
(name "arc-theme")
- (version "20201013")
+ (version "20210412")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -612,24 +613,19 @@ notebooks and tiling window managers.")
(file-name (git-file-name name version))
(sha256
(base32
- "1x2l1mwjx68dwf3jb1i90c1q8nqsl1wf2zggcn8im6590k5yv39s"))))
- (build-system gnu-build-system)
+ "0zs44dagp6baiyszlr1kj5ncap43fg32dv07rl46nxbds2p65lh4"))))
+ (build-system meson-build-system)
(arguments
'(#:configure-flags
- (list "--disable-cinnamon")
+ '("-Dthemes=gnome-shell,gtk2,gtk3,metacity,plank,unity,xfwm")
#:phases
(modify-phases %standard-phases
- ;; autogen.sh calls configure at the end of the script.
- (replace 'bootstrap
- (lambda _ (invoke "autoreconf" "-vfi")))
(add-before 'build 'set-home ;placate Inkscape
(lambda _
(setenv "HOME" (getcwd))
#t)))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("glib" ,glib "bin") ; for glib-compile-resources
+ `(("glib" ,glib "bin") ; for glib-compile-resources
("gnome-shell" ,gnome-shell)
("gtk+" ,gtk+)
("inkscape" ,inkscape)
@@ -897,7 +893,7 @@ track stocks, currencies and cryptocurrencies.")
;; Note to maintainer: VLS must be built with a Vala toolchain the same
;; version or newer. Therefore when you update this package you may need
;; to update Vala too.
- (version "0.48.1")
+ (version "0.48.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -905,7 +901,7 @@ track stocks, currencies and cryptocurrencies.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "12k095052jkvbiyz8gzkj6w7r7p16d5m18fyikl48yvh5nln8fw0"))))
+ (base32 "1gnvc91gdp3wj9r3r3xxfr09f9lw39cfypn2q5f0443dhhmp059j"))))
(build-system meson-build-system)
(arguments '(#:glib-or-gtk? #t))
(inputs
@@ -913,7 +909,7 @@ track stocks, currencies and cryptocurrencies.")
("json-glib" ,json-glib)
("jsonrpc-glib" ,jsonrpc-glib)
("libgee" ,libgee)
- ("vala" ,vala-0.50)))
+ ("vala" ,vala)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "https://github.com/benwaffle/vala-language-server")