summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 087dd97f7d..a6386247f2 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Songlin Jiang <hollowman@hollowman.ml>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -282,6 +283,39 @@ GNOME Shell.")
that caches clipboard history.")
(license license:expat)))
+(define-public gnome-shell-extension-customize-ibus
+ (package
+ (name "gnome-shell-extension-customize-ibus")
+ (version "78")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openSUSE/Customize-IBus.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hnnsjriq7xaakk8biwz55mn077lnm9nsmi4wz5zk7clgxmasvq9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "VERSION=" ,version)
+ (string-append "INSTALLBASE=" (assoc-ref %outputs "out")
+ "/share/gnome-shell/extensions"))
+ #:tests? #f ; No test target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")))
+ (home-page "https://github.com/openSUSE/Customize-IBus")
+ (synopsis "GNOME Shell Extension for IBus Customization")
+ (description "Customize IBus provides full customization of appearance,
+behavior, system tray and input source indicator for IBus.")
+ (license license:gpl3+)))
+
(define-public gnome-shell-extension-topicons-redux
(package
(name "gnome-shell-extension-topicons-redux")