summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index bc69af5a9e..16a1a6162d 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -61,14 +61,15 @@
(name "dbus")
(version "1.10.0")
(source (origin
- ;; TODO: Apply patch from DBUS/ACTIVATION below.
(method url-fetch)
(uri (string-append
"https://dbus.freedesktop.org/releases/dbus/dbus-"
version ".tar.gz"))
(sha256
(base32
- "0jwj7wlrhq5y0fwfh8k2d9rgdpfax06lj8698g6iqbwrzd2rgyqx"))))
+ "0jwj7wlrhq5y0fwfh8k2d9rgdpfax06lj8698g6iqbwrzd2rgyqx"))
+ (patches
+ (list (search-patch "dbus-helper-search-path.patch")))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -126,17 +127,6 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
shared NFS home directories.")
(license license:gpl2+))) ; or Academic Free License 2.1
-(define-public dbus/activation
- ;; D-Bus with a patch to fix service activation.
- ;; TODO: Merge with DBUS above.
- (package
- (inherit dbus)
- (version (string-append (package-version dbus) ".a"))
- (source (origin
- (inherit (package-source dbus))
- (patches
- (list (search-patch "dbus-helper-search-path.patch")))))))
-
(define glib
(package
(name "glib")