summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 829ef32221..f2606a70af 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -438,11 +438,19 @@ functions for strings and common data structures.")
#t)))))
(native-inputs
`(("glib" ,glib "bin")
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ;; TODO(core-updates): Unconditionally place "flex" and "bison"
+ ;; in 'native-inputs'.
+ ,@(if (%current-target-system)
+ `(("bison" ,bison)
+ ("flex" ,flex))
+ '())))
(inputs
- `(("bison" ,bison)
- ("flex" ,flex)
- ("python" ,python-wrapper)
+ `(,@(if (%current-target-system)
+ `(("python" ,python))
+ `(("bison" ,bison)
+ ("flex" ,flex)
+ ("python" ,python-wrapper)))
("zlib" ,zlib)))
(propagated-inputs
`(("glib" ,glib)