summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 6ef64e4b73..e4bf6ad0fc 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -59,6 +59,7 @@
(name "dbus")
(version "1.10.0")
(source (origin
+ ;; TODO: Apply patch from DBUS/ACTIVATION below.
(method url-fetch)
(uri (string-append
"http://dbus.freedesktop.org/releases/dbus/dbus-"
@@ -123,6 +124,17 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
shared NFS home directories.")
(license license:gpl2+))) ; or Academic Free License 2.1
+(define-public dbus/activation
+ ;; D-Bus with a patch to fix service activation.
+ ;; TODO: Merge with DBUS above.
+ (package
+ (inherit dbus)
+ (version (string-append (package-version dbus) ".a"))
+ (source (origin
+ (inherit (package-source dbus))
+ (patches
+ (list (search-patch "dbus-helper-search-path.patch")))))))
+
(define glib
(package
(name "glib")