summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm48
1 files changed, 44 insertions, 4 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 1286700911..7ff9ede22b 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -18,7 +18,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages glib)
- #:use-module ((guix licenses) #:select (lgpl2.0+ gpl2+))
+ #:use-module ((guix licenses) #:select (lgpl2.0+ gpl2+ gpl2))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -76,7 +76,7 @@ shared NFS home directories.")
(version "2.34.3")
(source (origin
(method url-fetch)
- (uri (string-append "http://ftp.gnome.org/pub/gnome/sources/"
+ (uri (string-append "mirror://gnome/sources/"
name "/2.34/"
name "-" version ".tar.xz"))
(sha256
@@ -99,11 +99,14 @@ shared NFS home directories.")
("patch/tests-homedir"
,(search-patch "glib-tests-homedir.patch"))
("patch/tests-desktop"
- ,(search-patch "glib-tests-desktop.patch"))))
+ ,(search-patch "glib-tests-desktop.patch"))
+ ("patch/tests-prlimit"
+ ,(search-patch "glib-tests-prlimit.patch"))))
(arguments
'(#:patches (list (assoc-ref %build-inputs "patch/tests-tzdata")
(assoc-ref %build-inputs "patch/tests-homedir")
- (assoc-ref %build-inputs "patch/tests-desktop"))
+ (assoc-ref %build-inputs "patch/tests-desktop")
+ (assoc-ref %build-inputs "patch/tests-prlimit"))
#:phases (alist-cons-before
'build 'pre-build
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -124,3 +127,40 @@ and interfaces for such runtime functionality as an event loop, threads,
dynamic loading, and an object system.")
(home-page "http://developer.gnome.org/glib/")
(license lgpl2.0+))) ; some files are under lgpl2.1+
+
+(define-public intltool
+ (package
+ (name "intltool")
+ (version "0.40.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnome/sources/intltool/0.40/intltool-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "0r1vkvy5xzqk01yl6a0xlrry39bra24alkrx6279b77hc62my7jd"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("gettext" ,guix:gettext)
+ ("perl-xml-parser" ,xml:perl-xml-parser)
+ ("perl" ,perl)))
+ (home-page "http://freedesktop.org/wiki/Software/intltool")
+ (synopsis "Tools to centralize translation of many different file formats")
+ (description
+ "intltool is a set of tools to centralize translation of many different
+file formats using GNU gettext-compatible PO files.
+
+The intltool collection can be used to do these things:
+
+ Extract translatable strings from various source files (.xml.in,
+ glade, .desktop.in, .server.in, .oaf.in).
+
+ Collect the extracted strings together with messages from traditional
+ source files (.c, .h) in po/$(PACKAGE).pot.
+
+ Merge back the translations from .po files into .xml, .desktop and
+ oaf files. This merge step will happen at build resp. installation time.")
+ (license gpl2)))