summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 6bb5fab86b..cb65c9a286 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -6,9 +6,10 @@
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -701,7 +702,7 @@ and visualizations.")
(define-public gl2ps
(package
(name "gl2ps")
- (version "1.3.9")
+ (version "1.4.0")
(source
(origin
(method url-fetch)
@@ -710,7 +711,7 @@ and visualizations.")
version ".tgz"))
(sha256
(base32
- "0h1nrhmkc4qjw2ninwpj2zbgwhc0qg6pdhpsibbvry0d2bzhns4a"))))
+ "1qpidkz8x3bxqf69hlhyz1m0jmfi9kq24fxsp7rq6wfqzinmxjq3"))))
(build-system cmake-build-system)
(inputs
`(("libpng" ,libpng)
@@ -726,6 +727,7 @@ capable of handling intersecting and stretched polygons, as well as
non-manifold objects. GL2PS provides many features including advanced
smooth shading and text rendering, culling of invisible primitives and
mixed vector/bitmap output.")
+ ;; GL2PS is dual-licenced and can be used under the terms of either.
(license (list license:lgpl2.0+
(license:fsf-free "http://www.geuz.org/gl2ps/COPYING.GL2PS"
"GPL-incompatible copyleft license")))))
@@ -745,7 +747,10 @@ mixed vector/bitmap output.")
"0rnid3hwrry9d5d4m7sygq00xxx976rgk00a3557m9r5kxbmy476"))))
(arguments
`(#:tests? #f ;; no tests are available
- #:configure-flags (list "-DVGL_USESSL=1"))) ;; use OpenSSL
+ #:configure-flags (list
+ (string-append "-DCMAKE_INSTALL_LIBDIR="
+ (assoc-ref %outputs "out") "/lib")
+ "-DVGL_USESSL=1"))) ;; use OpenSSL
(build-system cmake-build-system)
(inputs `(("glu" ,glu)
("libjpeg-turbo" ,libjpeg-turbo)