summaryrefslogtreecommitdiff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 2da57ee8ee..a0490e5421 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -185,8 +185,7 @@ of a larger interface.")
"1w68h81kqkqnziixrx21qs0gfv2z79651h19sxn226xdb58mjgqb"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.55
- #:configure-flags
+ `(#:configure-flags
(list "-Denable-gir=false")))
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -225,8 +224,7 @@ provided, as well as a framework to add new color models and data types.")
"1pd8xkx70k0fsi1hrzrmaify7112wjmxzk0p6bi6js89yhn7h4n1"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.55
- #:configure-flags
+ `(#:configure-flags
(list "-Dintrospection=false")
#:phases
(modify-phases %standard-phases
@@ -304,7 +302,7 @@ buffers.")
;; Install 'sitecustomize.py' into gimp's python directory to
;; add pygobject and pygtk to pygimp's search path.
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((pythonpath (getenv "PYTHONPATH"))
+ (let* ((pythonpath (getenv "GUIX_PYTHONPATH"))
(out (assoc-ref outputs "out"))
(sitecustomize.py
(string-append
@@ -608,7 +606,7 @@ transferring the style of an image.")
;; Install 'sitecustomize.py' into glimpse's python directory to
;; add pygobject and pygtk to pygimp's search path.
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((pythonpath (getenv "PYTHONPATH"))
+ (let* ((pythonpath (getenv "GUIX_PYTHONPATH"))
(out (assoc-ref outputs "out"))
(sitecustomize.py
(string-append