summaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index f5ca71313d..472ada47b1 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -150,7 +150,19 @@ printing, and psresize, for adjusting page sizes.")
(("/bin/sh") (which "bash")))
(substitute* "base/unixhead.mak"
(("/bin/sh") (which "bash")))))
- %standard-phases)))
+ (alist-replace
+ 'build
+ (lambda* (#:key #:allow-other-keys #:rest args)
+ (let ((build (assoc-ref %standard-phases 'build)))
+ (apply build args)
+ (system* "make" "so")))
+ (alist-replace
+ 'install
+ (lambda* (#:key #:allow-other-keys #:rest args)
+ (let ((install (assoc-ref %standard-phases 'install)))
+ (apply install args)
+ (system* "make" "install-so")))
+ %standard-phases)))))
(synopsis "GNU Ghostscript, an interpreter for the PostScript language and for PDF")
(description
"GNU Ghostscript is an interpreter for PostScript and Portable Document