summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm61
1 files changed, 18 insertions, 43 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 791fd5f1b6..0be0703b82 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -237,15 +237,6 @@ topology functions.")
(("@pkgdatadir@/org.gnome.Maps")
(string-append (assoc-ref outputs "out") "/bin/gnome-maps")))
#t))
- (add-after 'unpack 'fix-broken-tests
- (lambda _
- ;; For some reason setting LC_ALL=C and LANG=C as done in the
- ;; build system does not prevent these gratuitous commas from
- ;; being inserted.
- (substitute* "tests/utilsTest.js"
- (("1001 m") "1,001 m")
- (("1000 ft") "1,000 ft")
- (("5282 ft") "5,282 ft"))))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -488,14 +479,12 @@ coverages using a SpatiaLite DBMS.")
'("--enable-rttopo=yes")
#:phases
(modify-phases %standard-phases
- ;; 3 tests are failing, ignore them:
+ ;; 1 test is failing, ignore it:
(add-after 'unpack 'ignore-broken-tests
(lambda _
(substitute* '("test/Makefile.in")
- (("\tcheck_sql_stmt.* (check_sql_.*)" all tiny) (string-append "\t" tiny))
- (("(\tch.*) check_v.*ble2.*$" all vt1) (string-append vt1 " \\\n"))
- (("\tch.* (check_v.*ble4.*)$" all vt4) (string-append "\t" vt4)))
- #t)))))
+ (("check_wms\\$\\(EXEEXT\\) check_drop_rename\\$\\(EXEEXT\\) ")
+ "check_wms$(EXEEXT) ")))))))
(synopsis "Extend SQLite to support Spatial SQL capabilities")
(description
"SpatiaLite is a library intended to extend the SQLite core to support
@@ -1228,6 +1217,7 @@ map display. Downloads map data from a number of websites, including
(url "https://github.com/opengribs/XyGrib")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
+ (patches (search-patches "xygrib-fix-finding-data.patch"))
(sha256
(base32
"0xzsm8pr0zjk3f8j880fg5n82jyxn8xf1330qmmq1fqv7rsrg9ia"))
@@ -1242,18 +1232,15 @@ map display. Downloads map data from a number of websites, including
#t))))
(build-system cmake-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags (list "-DGNU_PACKAGE=ON")
+
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-directories
(lambda* (#:key inputs #:allow-other-keys)
(let ((jpeg (assoc-ref inputs "openjpeg"))
(font (assoc-ref inputs "font-liberation")))
(substitute* "CMakeLists.txt"
- ;; Find libjpeg.
- (("/usr") jpeg)
- ;; Fix install locations.
- (("set\\(PREFIX_BIN.*") "set(PREFIX_BIN \"bin\")\n")
- (("set\\(PREFIX_PKGDATA.*") "set(PREFIX_PKGDATA \"share/${PROJECT_NAME}\")\n")
;; Skip looking for the static library.
(("\"libnova.a\"") ""))
;; Don't use the bundled font-liberation.
@@ -1262,8 +1249,7 @@ map display. Downloads map data from a number of websites, including
(string-append "\"" font "/share/fonts/truetype/\"")))
(substitute* "src/util/Util.h"
(("pathData\\(\\)\\+\"data/fonts/\"")
- (string-append "\"" font "/share/fonts/\""))))
- #t)))
+ (string-append "\"" font "/share/fonts/\"")))))))
#:tests? #f)) ; no tests
(native-inputs
`(("qttools" ,qttools)))
@@ -1276,6 +1262,10 @@ map display. Downloads map data from a number of websites, including
("proj.4" ,proj.4)
("qtbase" ,qtbase-5)
("zlib" ,zlib)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "XDG_DATA_DIRS")
+ (files '("share")))))
(synopsis "Weather Forecast Visualization")
(description
"XyGrib is a Grib file reader and visualizes meteorological data providing
@@ -1717,22 +1707,7 @@ using the dataset of topographical information collected by
;; of QMapShack, but they are not applied by default, for
;; some reason...
(invoke "patch" "-p1" "-i" "FindPROJ4.patch")
- (invoke "patch" "-p1" "-i" "FindQuaZip5.patch")
- #t))
- (add-after 'install 'wrap
- ;; The program fails to find the QtWebEngineProcess program,
- ;; so we set QTWEBENGINEPROCESS_PATH to help it.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin"))
- (qtwebengineprocess (string-append
- (assoc-ref inputs "qtwebengine")
- "/lib/qt5/libexec/QtWebEngineProcess")))
- (for-each (lambda (program)
- (wrap-program program
- `("QTWEBENGINEPROCESS_PATH" =
- (,qtwebengineprocess))))
- (find-files bin ".*")))
- #t)))))
+ (invoke "patch" "-p1" "-i" "FindQuaZip5.patch"))))))
(synopsis "GPS mapping application")
(description
"QMapShack can be used to plan your next outdoor trip or to visualize and
@@ -1890,7 +1865,8 @@ exchanged form one Spatial DBMS and the other.")
`(#:configure-flags '("-DENABLE_PORTAUDIO=ON"
"-DENABLE_SNDFILE=ON"
"-DBUNDLE_TCDATA=ON"
- "-DBUNDLE_GSHHS=CRUDE")
+ "-DBUNDLE_GSHHS=CRUDE"
+ "-DCMAKE_C_FLAGS=-fcommon")
#:tests? #f ; No tests defined
#:phases
(modify-phases %standard-phases
@@ -1976,8 +1952,7 @@ track your position right from your laptop.")
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((shell (string-append (assoc-ref inputs "bash")
- "/bin/bash")))
+ (let ((shell (search-input-file inputs "/bin/bash")))
(setenv "SHELL" shell)
(setenv "CONFIG_SHELL" shell)
(setenv "LDFLAGS" (string-append "-Wl,-rpath -Wl,"
@@ -2150,8 +2125,7 @@ growing set of geoscientific methods.")
(replace 'check
(lambda* (#:key inputs #:allow-other-keys)
(setenv "HOME" "/tmp")
- (system (string-append (assoc-ref inputs "xorg-server")
- "/bin/Xvfb :1 &"))
+ (system "Xvfb :1 &")
(setenv "DISPLAY" ":1")
(setenv "TRAVIS" "true")
(setenv "CTEST_OUTPUT_ON_FAILURE" "1")
@@ -2173,6 +2147,7 @@ growing set of geoscientific methods.")
"PyCoreAdittions"
"PyQgsAnnotation"
"PyQgsAppStartup"
+ "PyQgsAuthBasicMethod"
"PyQgsAuthenticationSystem"
"PyQgsAuxiliaryStorage"
"PyQgsDBManagerGpkg"