summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm807
1 files changed, 351 insertions, 456 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 927ddb167d..5fb0f633a3 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -59,6 +59,7 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
@@ -165,10 +166,9 @@
("seed" ,seed)
("vala" ,vala)))
(inputs
- `(("expat" ,expat)
- ("glib" ,glib)))
+ (list expat glib))
(propagated-inputs
- `(("cairo" ,cairo)))
+ (list cairo))
(synopsis "Map-rendering for OpenSteetMap")
(description "Memphis is a map-rendering application and a library for
OpenStreetMap written in C using eXpat, Cairo and GLib.")
@@ -198,7 +198,7 @@ OpenStreetMap written in C using eXpat, Cairo and GLib.")
(("/bin/sh") (which "sh")))
#t)))))
(inputs
- `(("glib" ,glib)))
+ (list glib))
(home-page "https://geos.osgeo.org/")
(synopsis "Geometry Engine for Geographic Information Systems")
(description
@@ -215,41 +215,32 @@ topology functions.")
(define-public gnome-maps
(package
(name "gnome-maps")
- (version "3.38.5")
+ (version "41.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
+ (version-major version) "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "1llgzm2ni3iy31dznqkc81vadv0fpqgpz2l9zzrj5jshvyq0akgh"))))
+ "037xmkmcmcw87vb1c1s3y225m8757k331cvk1m8cshf6mx61p0l1"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
+ `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
+ #:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
(substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") "true"))
- #t))
+ (("gtk-update-icon-cache") "true"))))
(add-after 'unpack 'patch-dbus-service
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "data/org.gnome.Maps.service.in"
(("@pkgdatadir@/org.gnome.Maps")
- (string-append (assoc-ref outputs "out") "/bin/gnome-maps")))
- #t))
- (add-after 'unpack 'fix-broken-tests
- (lambda _
- ;; For some reason setting LC_ALL=C and LANG=C as done in the
- ;; build system does not prevent these gratuitous commas from
- ;; being inserted.
- (substitute* "tests/utilsTest.js"
- (("1001 m") "1,001 m")
- (("1000 ft") "1,000 ft")
- (("5282 ft") "5,282 ft"))))
+ (string-append (assoc-ref outputs "out")
+ "/bin/gnome-maps")))))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -287,11 +278,12 @@ topology functions.")
("folks" ,folks)
("libchamplain" ,libchamplain)
("libgee" ,libgee)
+ ("libhandy" ,libhandy)
("libsecret" ,libsecret)
- ("libsoup" ,libsoup)
+ ("libsoup" ,libsoup-minimal-2)
("libgweather" ,libgweather)
("libxml2" ,libxml2)
- ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("librsvg" ,librsvg)
("glib-networking" ,glib-networking)
("geoclue" ,geoclue)
("geocode-glib" ,geocode-glib)
@@ -302,7 +294,7 @@ topology functions.")
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)
("rest" ,rest)
- ("webkitgtk" ,webkitgtk)))
+ ("webkitgtk" ,webkitgtk-with-libsoup2)))
(synopsis "Graphical map viewer and wayfinding program")
(description "GNOME Maps is a graphical map viewer. It uses map data from
the OpenStreetMap project. It can provide directions for walking, bicycling,
@@ -334,12 +326,10 @@ and driving.")
#t))))
(build-system gnu-build-system)
(inputs
- `(("libjpeg-turbo" ,libjpeg-turbo)
- ("libtiff" ,libtiff)
- ("zlib" ,zlib)))
+ (list libjpeg-turbo libtiff zlib))
(propagated-inputs
- `(;; libgeotiff headers include proj headers, so ensure those are available.
- ("proj" ,proj)))
+ (list ;; libgeotiff headers include proj headers, so ensure those are available.
+ proj))
(arguments
`(#:configure-flags
(list "--disable-static"
@@ -374,27 +364,27 @@ writing GeoTIFF information tags.")
"1x24gqp4hsq97c31ncwxblab0x0863q8v1z42jil7lvsq3glqa7p"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("cairo" ,cairo)
- ("curl" ,curl)
- ("freetype" ,freetype)
- ("freexl" ,freexl)
- ("giflib" ,giflib)
- ("libgeotiff" ,libgeotiff)
- ("libjpeg-turbo" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("librttopo" ,librttopo)
- ("libspatialite" ,libspatialite)
- ("libtiff" ,libtiff)
- ("libwebp" ,libwebp)
- ("libxml2" ,libxml2)
- ("lz4" ,lz4)
- ("minizip" ,minizip)
- ("openjpeg" ,openjpeg)
- ("proj" ,proj)
- ("sqlite" ,sqlite)
- ("zstd" ,zstd "lib")))
+ (list cairo
+ curl
+ freetype
+ freexl
+ giflib
+ libgeotiff
+ libjpeg-turbo
+ libpng
+ librttopo
+ libspatialite
+ libtiff
+ libwebp
+ libxml2
+ lz4
+ minizip
+ openjpeg
+ proj
+ sqlite
+ `(,zstd "lib")))
(synopsis "Library to work with huge raster coverages using a SpatiaLite")
(description
"librasterlite2 is a library that stores and retrieves huge raster
@@ -451,12 +441,9 @@ coverages using a SpatiaLite DBMS.")
(string-append "LIBTOOLIZE=" libtoolize "\n"))))
#t)))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ (list autoconf automake libtool pkg-config))
(inputs
- `(("geos" ,geos)))
+ (list geos))
(synopsis "Library to handle SQL/MM topologies")
(description
"The RT Topology Library exposes an API to create and manage standard
@@ -478,28 +465,26 @@ coverages using a SpatiaLite DBMS.")
"164y82rw2lrp5glfc0rkn7n6xvx5dvlgmh7bb7815067251wkjzf"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("freexl" ,freexl)
- ("geos" ,geos)
- ("librttopo" ,librttopo)
- ("libxml2" ,libxml2)
- ("minizip" ,minizip)
- ("proj" ,proj)
- ("sqlite" ,sqlite)))
+ (list freexl
+ geos
+ librttopo
+ libxml2
+ minizip
+ proj
+ sqlite))
(arguments
`(#:configure-flags
'("--enable-rttopo=yes")
#:phases
(modify-phases %standard-phases
- ;; 3 tests are failing, ignore them:
+ ;; 1 test is failing, ignore it:
(add-after 'unpack 'ignore-broken-tests
(lambda _
(substitute* '("test/Makefile.in")
- (("\tcheck_sql_stmt.* (check_sql_.*)" all tiny) (string-append "\t" tiny))
- (("(\tch.*) check_v.*ble2.*$" all vt1) (string-append vt1 " \\\n"))
- (("\tch.* (check_v.*ble4.*)$" all vt4) (string-append "\t" vt4)))
- #t)))))
+ (("check_wms\\$\\(EXEEXT\\) check_drop_rename\\$\\(EXEEXT\\) ")
+ "check_wms$(EXEEXT) ")))))))
(synopsis "Extend SQLite to support Spatial SQL capabilities")
(description
"SpatiaLite is a library intended to extend the SQLite core to support
@@ -531,13 +516,9 @@ fully fledged Spatial SQL capabilities.")
(arguments
`(#:configure-flags '("-DUSE_EXTERNAL_GTEST=ON")))
(inputs
- `(("curl" ,curl)
- ("libjpeg-turbo" ,libjpeg-turbo)
- ("libtiff" ,libtiff)
- ("sqlite" ,sqlite)))
+ (list curl libjpeg-turbo libtiff sqlite))
(native-inputs
- `(("googletest" ,googletest)
- ("pkg-config" ,pkg-config)))
+ (list googletest pkg-config))
(home-page "https://proj.org/")
(synopsis "Coordinate transformation software")
(description
@@ -588,7 +569,7 @@ lets developers use the functionality of Proj in their own software.")
(("\tPROJ_LIB.*" all) (string-append "#" all)))
#t)))))
(inputs
- `(("glib" ,glib)))
+ (list glib))
(home-page "https://proj.org/")
(synopsis "Cartographic Projections Library")
(description
@@ -627,15 +608,12 @@ projections.")
(("(internal_datadir = ).*$" all var)
(string-append var "Path(\"" proj "/share/proj\")\n")))))))))
(inputs
- `(("proj" ,proj)))
+ (list proj))
(propagated-inputs
- `(("python-certifi" ,python-certifi)))
+ (list python-certifi))
(native-inputs
- `(("python-cython" ,python-cython)
- ("python-numpy" ,python-numpy)
- ("python-pandas" ,python-pandas)
- ("python-pytest" ,python-pytest)
- ("python-xarray" ,python-xarray)))
+ (list python-cython python-numpy python-pandas python-pytest
+ python-xarray))
(home-page "https://github.com/pyproj4/pyproj")
(synopsis
"Python interface to PROJ")
@@ -670,23 +648,23 @@ projections and coordinate transformations library.")
(when tests?
(invoke "pytest" "-m" "not network and not wheel")))))))
(inputs
- `(("gdal" ,gdal)))
+ (list gdal))
(propagated-inputs
- `(("python-attrs" ,python-attrs)
- ("python-certifi" ,python-certifi)
- ("python-click" ,python-click)
- ("python-click-plugins" ,python-click-plugins)
- ("python-cligj" ,python-cligj)
- ("python-munch" ,python-munch)
- ("python-setuptools" ,python-setuptools)
- ("python-six" ,python-six)
- ("python-pytz" ,python-pytz)))
+ (list python-attrs
+ python-certifi
+ python-click
+ python-click-plugins
+ python-cligj
+ python-munch
+ python-setuptools
+ python-six
+ python-pytz))
(native-inputs
- `(("gdal" ,gdal) ; for gdal-config
- ("python-boto3" ,python-boto3)
- ("python-cython" ,python-cython)
- ("python-pytest" ,python-pytest)
- ("python-pytest-cov" ,python-pytest-cov)))
+ (list gdal ; for gdal-config
+ python-boto3
+ python-cython
+ python-pytest
+ python-pytest-cov))
(home-page "https://github.com/Toblerity/Fiona")
(synopsis
"Fiona reads and writes spatial data files")
@@ -726,12 +704,9 @@ pyproj, Rtree, and Shapely.")
; Disable tests that require internet access.
"-m" "not web")))))))
(propagated-inputs
- `(("python-fiona" ,python-fiona)
- ("python-pandas" ,python-pandas)
- ("python-pyproj" ,python-pyproj)
- ("python-shapely" ,python-shapely)))
+ (list python-fiona python-pandas python-pyproj python-shapely))
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ (list python-pytest))
(home-page "http://geopandas.org")
(synopsis "Geographic pandas extensions")
(description "The goal of GeoPandas is to make working with
@@ -756,21 +731,21 @@ require a spatial database such as PostGIS.")
"06frcikaj2mgz3abfk5h0z4j3hbksi0zikwjngbjv4p5f3pwxf8q"))))
(build-system scons-build-system)
(inputs
- `(("boost" ,boost)
- ("cairo" ,cairo)
- ("freetype" ,freetype)
- ("harfbuzz" ,harfbuzz)
- ("icu4c" ,icu4c)
- ("libjpeg-turbo" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("libwebp" ,libwebp)
- ("libxml2" ,libxml2)
- ("proj.4" ,proj.4)
- ("sqlite" ,sqlite)
- ("zlib" ,zlib)))
+ (list boost
+ cairo
+ freetype
+ harfbuzz
+ icu4c
+ libjpeg-turbo
+ libpng
+ libtiff
+ libwebp
+ libxml2
+ proj.4
+ sqlite
+ zlib))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(arguments
`(#:scons ,scons-python2
#:scons-flags
@@ -811,28 +786,28 @@ development.")
(base32 "0cyv4cycl073p9lnnnglcb72qn71g8h9g5zn4gzw7swcy5nxjj5s"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("curl" ,curl)
- ("freexl" ,freexl)
- ("geos" ,geos)
- ("giflib" ,giflib)
- ("libjpeg-turbo" ,libjpeg-turbo)
- ("librasterlite2" ,librasterlite2)
- ("librttopo" ,librttopo)
- ("libspatialite" ,libspatialite)
- ("libwebp" ,libwebp)
- ("libxlsxwriter" ,libxlsxwriter)
- ("libxml2" ,libxml2)
- ("lz4" ,lz4)
- ("minizip" ,minizip)
- ("openjpeg" ,openjpeg)
- ("postgresql" ,postgresql)
- ("proj" ,proj)
- ("sqlite" ,sqlite)
- ("virtualpg" ,virtualpg)
- ("wxwidgets" ,wxwidgets)
- ("zstd" ,zstd "lib")))
+ (list curl
+ freexl
+ geos
+ giflib
+ libjpeg-turbo
+ librasterlite2
+ librttopo
+ libspatialite
+ libwebp
+ libxlsxwriter
+ libxml2
+ lz4
+ minizip
+ openjpeg
+ postgresql
+ proj
+ sqlite
+ virtualpg
+ wxwidgets
+ `(,zstd "lib")))
(arguments
`(#:phases (modify-phases %standard-phases
(add-after 'unpack 'fix-gui
@@ -904,24 +879,24 @@ development.")
(substitute* "frmts/mrf/mrf_band.cpp"
(("\"../zlib/zlib.h\"") "<zlib.h>")))))))
(inputs
- `(("expat" ,expat)
- ("freexl" ,freexl)
- ("geos" ,geos)
- ("giflib" ,giflib)
- ("json-c" ,json-c)
- ("libgeotiff" ,libgeotiff)
- ("libjpeg-turbo" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("libwebp" ,libwebp)
- ("netcdf" ,netcdf)
- ("pcre" ,pcre)
- ("postgresql" ,postgresql) ; libpq
- ("proj" ,proj)
- ("sqlite" ,sqlite)
- ("zlib" ,zlib)))
+ (list expat
+ freexl
+ geos
+ giflib
+ json-c
+ libgeotiff
+ libjpeg-turbo
+ libpng
+ libtiff
+ libwebp
+ netcdf
+ pcre
+ postgresql ; libpq
+ proj
+ sqlite
+ zlib))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(home-page "https://gdal.org/")
(synopsis "Raster and vector geospatial data format library")
(description "GDAL is a translator library for raster and vector geospatial
@@ -964,9 +939,9 @@ utilities for data translation and processing.")
#t)))))
(native-inputs '())
(propagated-inputs
- `(("python-numpy" ,python-numpy)))
+ (list python-numpy))
(inputs
- `(("gdal" ,gdal)))
+ (list gdal))
(synopsis "GDAL (Geospatial Data Abstraction Library) python bindings")))
(define-public python-pyshp
@@ -992,8 +967,7 @@ utilities for data translation and processing.")
;; This is the only test file.
(invoke "python" "-m" "pytest" "test_shapefile.py")))))))
(native-inputs
- `(("python-pytest" ,python-pytest)
- ("python-pytest-runner" ,python-pytest-runner)))
+ (list python-pytest python-pytest-runner))
(home-page "https://github.com/GeospatialPython/pyshp")
(synopsis "Read/write support for ESRI Shapefile format")
(description
@@ -1025,19 +999,16 @@ utilities for data translation and processing.")
;; This one too but it's not marked as such.
"-k" "not test_gridliner_labels_bbox_style")))))))
(propagated-inputs
- `(("python-matplotlib" ,python-matplotlib)
- ("python-numpy" ,python-numpy)
- ("python-pykdtree" ,python-pykdtree)
- ("python-pyshp" ,python-pyshp)
- ("python-scipy" ,python-scipy)
- ("python-shapely" ,python-shapely)))
+ (list python-matplotlib
+ python-numpy
+ python-pykdtree
+ python-pyshp
+ python-scipy
+ python-shapely))
(inputs
- `(("geos" ,geos)
- ("proj" ,proj)))
+ (list geos proj))
(native-inputs
- `(("python-cython" ,python-cython)
- ("python-flufl-lock" ,python-flufl-lock)
- ("python-pytest" ,python-pytest)))
+ (list python-cython python-flufl-lock python-pytest))
(home-page "https://scitools.org.uk/cartopy/docs/latest/")
(synopsis "Cartographic library for visualisation")
(description
@@ -1094,8 +1065,7 @@ Shapely capabilities
("protobuf-c" ,protobuf-c)
("proj" ,proj)))
(native-inputs
- `(("perl" ,perl)
- ("pkg-config" ,pkg-config)))
+ (list perl pkg-config))
(home-page "https://postgis.net")
(synopsis "Spatial database extender for PostgreSQL")
(description "PostGIS is a spatial database extender for PostgreSQL
@@ -1178,8 +1148,7 @@ delivered to any client.")
(("0.0.0-dev") ,version))
#t)))))
(inputs
- `(("geos" ,geos)
- ("leveldb" ,leveldb)))
+ (list geos leveldb))
(home-page "https://imposm.org/")
(synopsis "OpenStreetMap importer for PostGIS")
(description "Imposm is an importer for OpenStreetMap data. It reads PBF
@@ -1207,18 +1176,18 @@ to create databases that are optimized for rendering/tile/map-services.")
(base32 "0xw71lrw4q4sdm51rl0zg87ywxfkxbw9h52zqim0z0xl5qh5q8xf"))))
(build-system cmake-build-system)
(propagated-inputs
- `(("boost" ,boost)
- ("bzip2" ,bzip2)
- ("expat" ,expat)
- ("gdal" ,gdal)
- ("geos" ,geos)
- ("proj" ,proj)
- ("protozero" ,protozero)
- ("sparsehash" ,sparsehash)
- ("utfcpp" ,utfcpp)
- ("zlib" ,zlib)))
+ (list boost
+ bzip2
+ expat
+ gdal
+ geos
+ proj
+ protozero
+ sparsehash
+ utfcpp
+ zlib))
(native-inputs
- `(("doxygen" ,doxygen)))
+ (list doxygen))
(home-page "https://osmcode.org/libosmium/")
(synopsis "C++ library for working with OpenStreetMap data")
(description "Libosmium is a fast and flexible C++ library for working with
@@ -1255,18 +1224,17 @@ OpenStreetMap data.")
(assoc-ref %build-inputs "protozero")
"/include"))))
(inputs
- `(("boost" ,boost)
- ("bzip2" ,bzip2)
- ("expat" ,expat)
- ("libosmium" ,libosmium)
- ("lua" ,lua)
- ("postgresql" ,postgresql)
- ("proj" ,proj)
- ("protozero" ,protozero)
- ("zlib" ,zlib)))
+ (list boost
+ bzip2
+ expat
+ libosmium
+ lua
+ postgresql
+ proj
+ protozero
+ zlib))
(native-inputs
- `(("python" ,python)
- ("python-psycopg2" ,python-psycopg2)))
+ (list python python-psycopg2))
(home-page "https://github.com/openstreetmap/osm2pgsql")
(synopsis "OSM data importer to postgresql")
(description "Osm2pgsql is a tool for loading OpenStreetMap data into a
@@ -1296,9 +1264,7 @@ map, geocoding with Nominatim, or general analysis.")
(list (string-append "CC=" ,(cc-for-target))
(string-append "PREFIX=" (assoc-ref %outputs "out")))))
(inputs
- `(("perl" ,perl)
- ("sqlite" ,sqlite)
- ("zlib" ,zlib)))
+ (list perl sqlite zlib))
(home-page "https://github.com/mapbox/tippecanoe")
(synopsis "Vector tile server for maps")
(description "Tippecanoe creates scale-independent view of data, so that
@@ -1322,10 +1288,9 @@ dropping features at lower levels.")
"1m8d3r1q1v05pkr8k9czrmb4xjszw6hvgsf3kn9pf0v14gpn4r8f"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)))
+ (list autoconf automake))
(inputs
- `(("zlib" ,zlib)))
+ (list zlib))
(home-page "https://gitlab.com/osm-c-tools/osmctools")
(synopsis "Tools to convert, filter and update OpenStreetMap data files")
(description "This project contains a few tools which are used in the
@@ -1348,15 +1313,9 @@ OpenStreetMap data files.")
"11imsf4cz1dpxdjh178k2s29axmq86rkfg1pqmn7incyxmjzhbwg"))))
(build-system gnu-build-system)
(native-inputs
- `(("gnome-common" ,gnome-common)
- ("gtk-doc" ,gtk-doc/stable)
- ("pkg-config" ,pkg-config)))
+ (list gnome-common gtk-doc/stable pkg-config))
(inputs
- `(("cairo" ,cairo)
- ("glib" ,glib)
- ("gobject-introspection" ,gobject-introspection)
- ("gtk+" ,gtk+)
- ("libsoup" ,libsoup)))
+ (list cairo glib gobject-introspection gtk+ libsoup-minimal-2))
(home-page "https://nzjrs.github.io/osm-gps-map/")
(synopsis "GTK+ widget for displaying OpenStreetMap tiles")
(description
@@ -1376,6 +1335,7 @@ map display. Downloads map data from a number of websites, including
(url "https://github.com/opengribs/XyGrib")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
+ (patches (search-patches "xygrib-fix-finding-data.patch"))
(sha256
(base32
"0xzsm8pr0zjk3f8j880fg5n82jyxn8xf1330qmmq1fqv7rsrg9ia"))
@@ -1390,18 +1350,15 @@ map display. Downloads map data from a number of websites, including
#t))))
(build-system cmake-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags (list "-DGNU_PACKAGE=ON")
+
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-directories
(lambda* (#:key inputs #:allow-other-keys)
(let ((jpeg (assoc-ref inputs "openjpeg"))
(font (assoc-ref inputs "font-liberation")))
(substitute* "CMakeLists.txt"
- ;; Find libjpeg.
- (("/usr") jpeg)
- ;; Fix install locations.
- (("set\\(PREFIX_BIN.*") "set(PREFIX_BIN \"bin\")\n")
- (("set\\(PREFIX_PKGDATA.*") "set(PREFIX_PKGDATA \"share/${PROJECT_NAME}\")\n")
;; Skip looking for the static library.
(("\"libnova.a\"") ""))
;; Don't use the bundled font-liberation.
@@ -1410,20 +1367,23 @@ map display. Downloads map data from a number of websites, including
(string-append "\"" font "/share/fonts/truetype/\"")))
(substitute* "src/util/Util.h"
(("pathData\\(\\)\\+\"data/fonts/\"")
- (string-append "\"" font "/share/fonts/\""))))
- #t)))
+ (string-append "\"" font "/share/fonts/\"")))))))
#:tests? #f)) ; no tests
(native-inputs
- `(("qttools" ,qttools)))
+ (list qttools))
(inputs
- `(("bzip2" ,bzip2)
- ("font-liberation" ,font-liberation)
- ("libnova" ,libnova)
- ("libpng" ,libpng)
- ("openjpeg" ,openjpeg)
- ("proj" ,proj)
- ("qtbase" ,qtbase-5)
- ("zlib" ,zlib)))
+ (list bzip2
+ font-liberation
+ libnova
+ libpng
+ openjpeg
+ proj
+ qtbase-5
+ zlib))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "XDG_DATA_DIRS")
+ (files '("share")))))
(synopsis "Weather Forecast Visualization")
(description
"XyGrib is a Grib file reader and visualizes meteorological data providing
@@ -1496,11 +1456,9 @@ persisted.
(add-installed-pythonpath inputs outputs)
(invoke "python" "-m" "pytest")))))))
(native-inputs
- `(("python-numpy" ,python-numpy)
- ("python-pytest" ,python-pytest)
- ("python-wheel" ,python-wheel)))
+ (list python-numpy python-pytest python-wheel))
(inputs
- `(("libspatialindex" ,libspatialindex)))
+ (list libspatialindex))
(home-page "https://github.com/Toblerity/rtree")
(synopsis "R-Tree spatial index for Python GIS")
(description
@@ -1521,7 +1479,7 @@ persisted.
"0sy6r5fkbb9bclw0is6gwnbzz627m7pjfnsqydxz58pbndakkhrv"))))
(build-system ant-build-system)
(native-inputs
- `(("unzip" ,unzip)))
+ (list unzip))
(arguments
`(#:build-target "pack"
#:tests? #f; No tests
@@ -1577,11 +1535,9 @@ an independent project by the JOSM team.")
file))
#t)))))
(inputs
- `(("java-jetbrains-annotations" ,java-jetbrains-annotations)))
+ (list java-jetbrains-annotations))
(native-inputs
- `(("javacc" ,javacc)
- ("java-junit" ,java-junit)
- ("java-hamcrest-core" ,java-hamcrest-core)))
+ (list javacc java-junit java-hamcrest-core))
(home-page "https://github.com/simonpoole/OpeningHoursParser")
(synopsis "Java parser for the OpenStreetMap opening hour format")
(description "This is a very simplistic parser for string values according
@@ -1609,19 +1565,19 @@ to the OSM opening hours specification.")
#t))))
(build-system ant-build-system)
(native-inputs
- `(("javacc" ,javacc)))
+ (list javacc))
(inputs
- `(("java-commons-jcs" ,java-commons-jcs)
- ("java-commons-compress" ,java-commons-compress)
- ("java-jmapviewer" ,java-jmapviewer)
- ("java-jsonp-api" ,java-jsonp-api)
- ("java-jsonp-impl" ,java-jsonp-impl); runtime dependency
- ("java-jsr305" ,java-jsr305)
- ("java-metadata-extractor" ,java-metadata-extractor)
- ("java-opening-hours-parser" ,java-opening-hours-parser)
- ("java-openjfx-media" ,java-openjfx-media)
- ("java-signpost-core" ,java-signpost-core)
- ("java-svg-salamander" ,java-svg-salamander)))
+ (list java-commons-jcs
+ java-commons-compress
+ java-jmapviewer
+ java-jsonp-api
+ java-jsonp-impl ; runtime dependency
+ java-jsr305
+ java-metadata-extractor
+ java-opening-hours-parser
+ java-openjfx-media
+ java-signpost-core
+ java-svg-salamander))
(arguments
`(#:tests? #f
#:jar-name "josm.jar"
@@ -1760,7 +1716,7 @@ ways, and relations) and their metadata tags.")
`(#:make-flags
(list ,(string-append "CC=" (cc-for-target)))))
(native-inputs
- `(("perl" ,perl)))
+ (list perl))
(home-page "https://maxmind.github.io/libmaxminddb/")
(synopsis "C library for the MaxMind DB file format")
(description "The libmaxminddb library provides a C library for reading
@@ -1785,7 +1741,7 @@ associated with an address.")
(arguments
`(#:tests? #f)) ;; Tests require a copy of the maxmind database
(inputs
- `(("libmaxminddb" ,libmaxminddb)))
+ (list libmaxminddb))
(home-page "https://www.maxmind.com/")
(synopsis "Reader for the MaxMind DB format")
(description "MaxMind DB is a binary file format that stores data indexed
@@ -1808,8 +1764,7 @@ MaxMind DB files.")
(arguments
`(#:tests? #f)) ;; Tests require a copy of the maxmind database
(inputs
- `(("python-maxminddb" ,python-maxminddb)
- ("python-requests" ,python-requests)))
+ (list python-maxminddb python-requests))
(home-page "https://www.maxmind.com/")
(synopsis "MaxMind GeoIP2 API")
(description "Provides an API for the GeoIP2 web services and databases.
@@ -1829,11 +1784,9 @@ The API also works with MaxMind’s free GeoLite2 databases.")
(base32 "1xa7l2bjn832nk6bc7b481nv8hd2gj41jwhg0d2qy10lqdvjpn5b"))))
(build-system gnu-build-system)
(native-inputs
- `(("perl" ,perl)))
+ (list perl))
(inputs
- `(("bzip2" ,bzip2)
- ("xz" ,xz)
- ("zlib" ,zlib)))
+ (list bzip2 xz zlib))
(arguments
`(#:test-target "test"
#:phases
@@ -1873,21 +1826,20 @@ using the dataset of topographical information collected by
(base32 "1l1j2axf94pdqwirwwhwy3y6k8v1aix78ifqbv6j8sv131h2j7y7"))))
(build-system qt-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("qttools" ,qttools)))
+ (list pkg-config qttools))
(inputs
- `(("gdal" ,gdal)
- ("libjpeg-turbo" ,libjpeg-turbo)
- ("proj" ,proj)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)
- ("qtlocation" ,qtlocation)
- ("qtwebchannel" ,qtwebchannel)
- ("qtwebengine" ,qtwebengine)
- ("quazip" ,quazip-0)
- ("routino" ,routino)
- ("sqlite" ,sqlite) ; See wrap phase
- ("zlib" ,zlib)))
+ (list gdal
+ libjpeg-turbo
+ proj
+ qtbase-5
+ qtdeclarative
+ qtlocation
+ qtwebchannel
+ qtwebengine
+ quazip-0
+ routino
+ sqlite ; See wrap phase
+ zlib))
(arguments
`(#:tests? #f
#:phases
@@ -1904,22 +1856,7 @@ using the dataset of topographical information collected by
;; of QMapShack, but they are not applied by default, for
;; some reason...
(invoke "patch" "-p1" "-i" "FindPROJ4.patch")
- (invoke "patch" "-p1" "-i" "FindQuaZip5.patch")
- #t))
- (add-after 'install 'wrap
- ;; The program fails to find the QtWebEngineProcess program,
- ;; so we set QTWEBENGINEPROCESS_PATH to help it.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin"))
- (qtwebengineprocess (string-append
- (assoc-ref inputs "qtwebengine")
- "/lib/qt5/libexec/QtWebEngineProcess")))
- (for-each (lambda (program)
- (wrap-program program
- `("QTWEBENGINEPROCESS_PATH" =
- (,qtwebengineprocess))))
- (find-files bin ".*")))
- #t)))))
+ (invoke "patch" "-p1" "-i" "FindQuaZip5.patch"))))))
(synopsis "GPS mapping application")
(description
"QMapShack can be used to plan your next outdoor trip or to visualize and
@@ -1941,8 +1878,7 @@ QLandkarte GT application.")
(base32 "0igif2bxf4dr82glxz9gyx5mmni0r2dsnx9p9k6pxv3c4lfhaz6v"))))
(build-system gnu-build-system)
(inputs
- `(("expat" ,expat)
- ("zlib" ,zlib)))
+ (list expat zlib))
(synopsis "Data extractor for OpenStreetMap files")
(description
"ReadOSM is a library to extract valid data from within an OpenStreetMap
@@ -1967,9 +1903,7 @@ input file (in @code{.osm} or @code{.osm.pbf} format).")
(base32 "1lzch0jf6yqhw391phhafzw4ghmiz98zkf698h4fmq109fa2vhqd"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
+ (list autoconf automake libtool))
(home-page "http://shapelib.maptools.org/")
(synopsis "Provides C library to write and update ESRI Shapefiles")
(description
@@ -1991,18 +1925,18 @@ associated attribute file (@file{.dbf}).")
(base32 "070p6pg541wvwb28wkn7k0z1qdyirik2qc2jpj4pf0vzx02w414n"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("expat" ,expat)
- ("freexl" ,freexl)
- ("geos" ,geos)
- ("librttopo" ,librttopo)
- ("libspatialite" ,libspatialite)
- ("libxml2" ,libxml2)
- ("minizip" ,minizip)
- ("proj" ,proj)
- ("readosm" ,readosm)
- ("sqlite" ,sqlite)))
+ (list expat
+ freexl
+ geos
+ librttopo
+ libspatialite
+ libxml2
+ minizip
+ proj
+ readosm
+ sqlite))
(synopsis "Collection of command line tools for SpatiaLite")
(description
"@code{spatialite-tools} is a collection of Command Line Interface (CLI)
@@ -2023,8 +1957,7 @@ tools supporting SpatiaLite.")
(base32 "12z0l7368r4116ljzg7nljy5hf425r11vxc540w79wlzikmynamy"))))
(build-system gnu-build-system)
(inputs
- `(("postgresql" ,postgresql)
- ("sqlite" ,sqlite)))
+ (list postgresql sqlite))
(synopsis "Allow SQLite/SpatiaLite to access PostgreSQL/PostGIS tables")
(description
"VirtualPG is a dynamic extension for the SQLite DBMS. It implements
@@ -2039,7 +1972,7 @@ exchanged form one Spatial DBMS and the other.")
(define-public opencpn
(package
(name "opencpn")
- (version "5.0.0")
+ (version "5.2.4")
(source
(origin
(method git-fetch)
@@ -2048,45 +1981,49 @@ exchanged form one Spatial DBMS and the other.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1xv3h6svw9aay5ixpql231md3pf00qxvhg62z88daraf18hlkfja"))))
+ (base32 "0ffx0lmz1mp5433zqyxigy4qqav32xprpagd66krvihkyvqp2y6y"))))
(build-system cmake-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))
(inputs
- `(("bzip2" ,bzip2)
- ("cairo" ,cairo)
- ("curl" ,curl)
- ("glu" ,glu)
- ("gtk+" ,gtk+)
- ("libarchive" ,libarchive)
- ("libelf" ,libelf)
- ("libexif" ,libexif)
- ("libsndfile" ,libsndfile)
- ("lz4" ,lz4)
- ("mesa" ,mesa)
- ("pango" ,pango)
- ("portaudio" ,portaudio)
- ("sqlite" ,sqlite)
- ("tinyxml" ,tinyxml)
- ("wxsvg" ,wxsvg)
- ("wxwidgets" ,wxwidgets)
- ("xz" ,xz)
- ("zlib" ,zlib)))
+ (list bzip2
+ cairo
+ curl
+ glu
+ gtk+
+ libarchive
+ libelf
+ libexif
+ libsndfile
+ lz4
+ mesa
+ pango
+ portaudio
+ sqlite
+ tinyxml
+ wxsvg
+ wxwidgets
+ xz
+ zlib))
(arguments
- `(#:configure-flags '("-DENABLE_PORTAUDIO=ON"
- "-DENABLE_SNDFILE=ON"
- "-DBUNDLE_TCDATA=ON"
- "-DBUNDLE_GSHHS=CRUDE")
+ `(#:configure-flags '("-DOCPN_USE_BUNDLED_LIBS=OFF"
+ "-DOCPN_ENABLE_PORTAUDIO=ON"
+ "-DOCPN_ENABLE_SNDFILE=ON"
+ "-DOCPN_BUNDLE_TCDATA=ON"
+ "-DOCPN_BUNDLE_GSHHS=ON")
#:tests? #f ; No tests defined
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-build
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "CMakeLists.txt"
- (("set\\(wxWidgets_CONFIG_OPTIONS.*--toolkit=gtk3" all)
- (string-append all " --libs all")))
- #t)))))
+ (("wx-32.c; cc")
+ "wx-32.c; gcc")
+ (("\"/bin/sh\" \"-c\"")
+ (string-append "\"" (which "bash") "\" \"-c\""))
+ (("include\\(TargetSetup\\)")
+ "set(PKG_TARGET \"guix\")\nset(PKG_TARGET_VERSION 1)")))))))
(synopsis "Chart plotter and marine GPS navigation software")
(description
"OpenCPN is a chart plotter and marine navigation software designed to be
@@ -2163,8 +2100,7 @@ track your position right from your laptop.")
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((shell (string-append (assoc-ref inputs "bash")
- "/bin/bash")))
+ (let ((shell (search-input-file inputs "/bin/bash")))
(setenv "SHELL" shell)
(setenv "CONFIG_SHELL" shell)
(setenv "LDFLAGS" (string-append "-Wl,-rpath -Wl,"
@@ -2240,24 +2176,23 @@ visualization.")
(base32 "1n051yxxkylly0k9rlkx2ih3j2lf9d4csg00sm7161r7nhjvggd1"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("swig" ,swig)))
+ (list pkg-config swig))
(inputs
- `(("curl" ,curl)
- ("fftw" ,fftw)
- ("gdal" ,gdal)
- ("hdf5" ,hdf5)
- ("jasper" ,jasper)
- ("libharu" ,libharu)
- ("libtiff" ,libtiff)
- ("opencv" ,opencv)
- ("postgresql" ,postgresql)
- ("proj" ,proj)
- ("python" ,python)
- ("qhull" ,qhull)
- ("unixodbc" ,unixodbc)
- ("vigra" ,vigra)
- ("wxwidgets" ,wxwidgets)))
+ (list curl
+ fftw
+ gdal
+ hdf5
+ jasper
+ libharu
+ libtiff
+ opencv
+ postgresql
+ proj
+ python
+ qhull
+ unixodbc
+ vigra
+ wxwidgets))
(arguments
'(#:configure-flags '("--enable-python")))
(synopsis "System for Automated Geoscientific Analyses")
@@ -2337,8 +2272,7 @@ growing set of geoscientific methods.")
(replace 'check
(lambda* (#:key inputs #:allow-other-keys)
(setenv "HOME" "/tmp")
- (system (string-append (assoc-ref inputs "xorg-server")
- "/bin/Xvfb :1 &"))
+ (system "Xvfb :1 &")
(setenv "DISPLAY" ":1")
(setenv "TRAVIS" "true")
(setenv "CTEST_OUTPUT_ON_FAILURE" "1")
@@ -2360,6 +2294,7 @@ growing set of geoscientific methods.")
"PyCoreAdittions"
"PyQgsAnnotation"
"PyQgsAppStartup"
+ "PyQgsAuthBasicMethod"
"PyQgsAuthenticationSystem"
"PyQgsAuxiliaryStorage"
"PyQgsDBManagerGpkg"
@@ -2464,62 +2399,62 @@ growing set of geoscientific methods.")
`("GISBASE" = (,grass))))
#t)))))
(inputs
- `(("exiv2" ,exiv2)
- ("expat" ,expat)
- ("gdal" ,gdal)
- ("geos" ,geos)
- ("gpsbabel" ,gpsbabel)
- ("grass" ,grass)
- ("gsl" ,gsl)
- ("hdf5" ,hdf5)
- ("libspatialindex" ,libspatialindex)
- ("libspatialite" ,libspatialite)
- ("libxml2" ,libxml2)
- ("libzip" ,libzip)
- ("netcdf" ,netcdf)
- ("postgresql" ,postgresql)
- ("proj" ,proj)
- ("protobuf" ,protobuf)
- ("python" ,python)
- ("python-chardet" ,python-chardet)
- ("python-dateutil" ,python-dateutil)
- ("python-future" ,python-future)
- ("python-gdal" ,python-gdal)
- ("python-jinja2" ,python-jinja2)
- ("python-numpy" ,python-numpy)
- ("python-owslib" ,python-owslib)
- ("python-psycopg2" ,python-psycopg2)
- ("python-pygments" ,python-pygments)
- ("python-pyqt+qscintilla" ,python-pyqt+qscintilla)
- ("python-pytz" ,python-pytz)
- ("python-pyyaml" ,python-pyyaml)
- ("python-requests" ,python-requests)
- ("python-sip" ,python-sip)
- ("python-six" ,python-six)
- ("python-urllib3" ,python-urllib3)
- ("qca" ,qca)
- ("qscintilla" ,qscintilla)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)
- ("qtkeychain" ,qtkeychain)
- ("qtlocation" ,qtlocation)
- ("qtserialport" ,qtserialport)
- ("qtsvg" ,qtsvg)
- ("qtwebkit" ,qtwebkit)
- ("qwt" ,qwt)
- ;;("saga" ,saga)
- ("sqlite" ,sqlite)))
+ (list exiv2
+ expat
+ gdal
+ geos
+ gpsbabel
+ grass
+ gsl
+ hdf5
+ libspatialindex
+ libspatialite
+ libxml2
+ libzip
+ netcdf
+ postgresql
+ proj
+ protobuf
+ python
+ python-chardet
+ python-dateutil
+ python-future
+ python-gdal
+ python-jinja2
+ python-numpy
+ python-owslib
+ python-psycopg2
+ python-pygments
+ python-pyqt+qscintilla
+ python-pytz
+ python-pyyaml
+ python-requests
+ python-sip
+ python-six
+ python-urllib3
+ qca
+ qscintilla
+ qtbase-5
+ qtdeclarative
+ qtkeychain
+ qtlocation
+ qtserialport
+ qtsvg
+ qtwebkit
+ qwt
+ ;;("saga" ,saga)
+ sqlite))
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)
- ("perl" ,perl)
- ("perl-yaml-tiny" ,perl-yaml-tiny)
- ("pkg-config" ,pkg-config)
- ("python-mock" ,python-mock)
- ("python-nose2" ,python-nose2)
- ("qttools" ,qttools)
- ("shellcheck" ,shellcheck)
- ("xorg-server" ,xorg-server-for-tests)))
+ (list bison
+ flex
+ perl
+ perl-yaml-tiny
+ pkg-config
+ python-mock
+ python-nose2
+ qttools
+ shellcheck
+ xorg-server-for-tests))
(home-page "https://qgis.org")
(synopsis "Geographical information system")
(description "QGIS is an easy to use Geographical Information
@@ -2596,16 +2531,16 @@ architecture.")
"0fx0cv0kgbvynpmjgsvq2fpsyngd5idiscdn8pd5201f1ngii3mq"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-geographiclib" ,python-geographiclib)))
+ (list python-geographiclib))
(native-inputs
- `(("python-async-generator" ,python-async-generator)
- ("python-coverage" ,python-coverage)
- ("python-flake8" ,python-flake8)
- ("python-isort" ,python-isort)
- ("python-pytest" ,python-pytest)
- ("python-pytest-aiohttp" ,python-pytest-aiohttp)
- ("python-readme-renderer" ,python-readme-renderer)
- ("python-pytz" ,python-pytz)))
+ (list python-async-generator
+ python-coverage
+ python-flake8
+ python-isort
+ python-pytest
+ python-pytest-aiohttp
+ python-readme-renderer
+ python-pytz))
(home-page "https://github.com/geopy/geopy")
(synopsis "Geocoding library for Python")
(description "@code{geopy} is a Python client for several popular geocoding
@@ -2614,46 +2549,6 @@ coordinates of addresses, cities, countries, and landmarks across the globe
using third-party geocoders and other data sources.")
(license license:expat)))
-(define-public marble-qt
- (let ((release "17.08")
- (commit "fc7166eeef784732033c999ba605364f9c82d21c")
- (revision "1"))
- (package
- (name "marble-qt")
- (version (git-version release revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://invent.kde.org/education/marble.git/")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0m0sf3sddaib7vc5lhbmh7ziw07p1hahg02f65sgfylyl5f5kj92"))
- (patches (search-patches
- "marble-qt-add-qt-headers.patch"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ; libmarblewidget-qt5.so.28 not found
- #:configure-flags
- '("-DCMAKE_BUILD_TYPE=Release"
- "-DWITH_KF5=FALSE")))
- (native-inputs
- `(("qttools" ,qttools)))
- (inputs
- `(("qtbase" ,qtbase-5)
- ("qtsvg" ,qtsvg)
- ("qtdeclarative" ,qtdeclarative)
- ("qtwebkit" ,qtwebkit)
- ("qtlocation" ,qtlocation)))
- (home-page "https://marble.kde.org/")
- (synopsis "Virtual globe and world atlas")
- (description "Marble is similar to a desktop globe. At closer scale it
-becomes a world atlas, while OpenStreetMap takes the user to street level. It
-supports searching for places of interest, viewing Wikipedia articles,
-creating routes by drag and drop and more.")
- (license license:gpl3))))
-
(define-public gplates
(package
(name "gplates")