summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm104
1 files changed, 42 insertions, 62 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 927ddb167d..6362300d6c 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -59,6 +59,7 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
@@ -215,41 +216,32 @@ topology functions.")
(define-public gnome-maps
(package
(name "gnome-maps")
- (version "3.38.5")
+ (version "40.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
+ (version-major version) "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "1llgzm2ni3iy31dznqkc81vadv0fpqgpz2l9zzrj5jshvyq0akgh"))))
+ "02bdkmb3wyzfrbq726634v4g1hyh9za70cc2ivlbp7zc2n1jgp5c"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
+ `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
+ #:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
(substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") "true"))
- #t))
+ (("gtk-update-icon-cache") "true"))))
(add-after 'unpack 'patch-dbus-service
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "data/org.gnome.Maps.service.in"
(("@pkgdatadir@/org.gnome.Maps")
- (string-append (assoc-ref outputs "out") "/bin/gnome-maps")))
- #t))
- (add-after 'unpack 'fix-broken-tests
- (lambda _
- ;; For some reason setting LC_ALL=C and LANG=C as done in the
- ;; build system does not prevent these gratuitous commas from
- ;; being inserted.
- (substitute* "tests/utilsTest.js"
- (("1001 m") "1,001 m")
- (("1000 ft") "1,000 ft")
- (("5282 ft") "5,282 ft"))))
+ (string-append (assoc-ref outputs "out")
+ "/bin/gnome-maps")))))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -287,11 +279,12 @@ topology functions.")
("folks" ,folks)
("libchamplain" ,libchamplain)
("libgee" ,libgee)
+ ("libhandy" ,libhandy)
("libsecret" ,libsecret)
("libsoup" ,libsoup)
("libgweather" ,libgweather)
("libxml2" ,libxml2)
- ("gdk-pixbuf" ,gdk-pixbuf+svg)
+ ("librsvg" ,librsvg)
("glib-networking" ,glib-networking)
("geoclue" ,geoclue)
("geocode-glib" ,geocode-glib)
@@ -492,14 +485,12 @@ coverages using a SpatiaLite DBMS.")
'("--enable-rttopo=yes")
#:phases
(modify-phases %standard-phases
- ;; 3 tests are failing, ignore them:
+ ;; 1 test is failing, ignore it:
(add-after 'unpack 'ignore-broken-tests
(lambda _
(substitute* '("test/Makefile.in")
- (("\tcheck_sql_stmt.* (check_sql_.*)" all tiny) (string-append "\t" tiny))
- (("(\tch.*) check_v.*ble2.*$" all vt1) (string-append vt1 " \\\n"))
- (("\tch.* (check_v.*ble4.*)$" all vt4) (string-append "\t" vt4)))
- #t)))))
+ (("check_wms\\$\\(EXEEXT\\) check_drop_rename\\$\\(EXEEXT\\) ")
+ "check_wms$(EXEEXT) ")))))))
(synopsis "Extend SQLite to support Spatial SQL capabilities")
(description
"SpatiaLite is a library intended to extend the SQLite core to support
@@ -1356,7 +1347,7 @@ OpenStreetMap data files.")
("glib" ,glib)
("gobject-introspection" ,gobject-introspection)
("gtk+" ,gtk+)
- ("libsoup" ,libsoup)))
+ ("libsoup" ,libsoup-minimal-2)))
(home-page "https://nzjrs.github.io/osm-gps-map/")
(synopsis "GTK+ widget for displaying OpenStreetMap tiles")
(description
@@ -1376,6 +1367,7 @@ map display. Downloads map data from a number of websites, including
(url "https://github.com/opengribs/XyGrib")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
+ (patches (search-patches "xygrib-fix-finding-data.patch"))
(sha256
(base32
"0xzsm8pr0zjk3f8j880fg5n82jyxn8xf1330qmmq1fqv7rsrg9ia"))
@@ -1390,18 +1382,15 @@ map display. Downloads map data from a number of websites, including
#t))))
(build-system cmake-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags (list "-DGNU_PACKAGE=ON")
+
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-directories
(lambda* (#:key inputs #:allow-other-keys)
(let ((jpeg (assoc-ref inputs "openjpeg"))
(font (assoc-ref inputs "font-liberation")))
(substitute* "CMakeLists.txt"
- ;; Find libjpeg.
- (("/usr") jpeg)
- ;; Fix install locations.
- (("set\\(PREFIX_BIN.*") "set(PREFIX_BIN \"bin\")\n")
- (("set\\(PREFIX_PKGDATA.*") "set(PREFIX_PKGDATA \"share/${PROJECT_NAME}\")\n")
;; Skip looking for the static library.
(("\"libnova.a\"") ""))
;; Don't use the bundled font-liberation.
@@ -1410,8 +1399,7 @@ map display. Downloads map data from a number of websites, including
(string-append "\"" font "/share/fonts/truetype/\"")))
(substitute* "src/util/Util.h"
(("pathData\\(\\)\\+\"data/fonts/\"")
- (string-append "\"" font "/share/fonts/\""))))
- #t)))
+ (string-append "\"" font "/share/fonts/\"")))))))
#:tests? #f)) ; no tests
(native-inputs
`(("qttools" ,qttools)))
@@ -1424,6 +1412,10 @@ map display. Downloads map data from a number of websites, including
("proj" ,proj)
("qtbase" ,qtbase-5)
("zlib" ,zlib)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "XDG_DATA_DIRS")
+ (files '("share")))))
(synopsis "Weather Forecast Visualization")
(description
"XyGrib is a Grib file reader and visualizes meteorological data providing
@@ -1904,22 +1896,7 @@ using the dataset of topographical information collected by
;; of QMapShack, but they are not applied by default, for
;; some reason...
(invoke "patch" "-p1" "-i" "FindPROJ4.patch")
- (invoke "patch" "-p1" "-i" "FindQuaZip5.patch")
- #t))
- (add-after 'install 'wrap
- ;; The program fails to find the QtWebEngineProcess program,
- ;; so we set QTWEBENGINEPROCESS_PATH to help it.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin"))
- (qtwebengineprocess (string-append
- (assoc-ref inputs "qtwebengine")
- "/lib/qt5/libexec/QtWebEngineProcess")))
- (for-each (lambda (program)
- (wrap-program program
- `("QTWEBENGINEPROCESS_PATH" =
- (,qtwebengineprocess))))
- (find-files bin ".*")))
- #t)))))
+ (invoke "patch" "-p1" "-i" "FindQuaZip5.patch"))))))
(synopsis "GPS mapping application")
(description
"QMapShack can be used to plan your next outdoor trip or to visualize and
@@ -2039,7 +2016,7 @@ exchanged form one Spatial DBMS and the other.")
(define-public opencpn
(package
(name "opencpn")
- (version "5.0.0")
+ (version "5.2.4")
(source
(origin
(method git-fetch)
@@ -2048,7 +2025,7 @@ exchanged form one Spatial DBMS and the other.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1xv3h6svw9aay5ixpql231md3pf00qxvhg62z88daraf18hlkfja"))))
+ (base32 "0ffx0lmz1mp5433zqyxigy4qqav32xprpagd66krvihkyvqp2y6y"))))
(build-system cmake-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -2074,19 +2051,23 @@ exchanged form one Spatial DBMS and the other.")
("xz" ,xz)
("zlib" ,zlib)))
(arguments
- `(#:configure-flags '("-DENABLE_PORTAUDIO=ON"
- "-DENABLE_SNDFILE=ON"
- "-DBUNDLE_TCDATA=ON"
- "-DBUNDLE_GSHHS=CRUDE")
+ `(#:configure-flags '("-DOCPN_USE_BUNDLED_LIBS=OFF"
+ "-DOCPN_ENABLE_PORTAUDIO=ON"
+ "-DOCPN_ENABLE_SNDFILE=ON"
+ "-DOCPN_BUNDLE_TCDATA=ON"
+ "-DOCPN_BUNDLE_GSHHS=ON")
#:tests? #f ; No tests defined
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-build
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "CMakeLists.txt"
- (("set\\(wxWidgets_CONFIG_OPTIONS.*--toolkit=gtk3" all)
- (string-append all " --libs all")))
- #t)))))
+ (("wx-32.c; cc")
+ "wx-32.c; gcc")
+ (("\"/bin/sh\" \"-c\"")
+ (string-append "\"" (which "bash") "\" \"-c\""))
+ (("include\\(TargetSetup\\)")
+ "set(PKG_TARGET \"guix\")\nset(PKG_TARGET_VERSION 1)")))))))
(synopsis "Chart plotter and marine GPS navigation software")
(description
"OpenCPN is a chart plotter and marine navigation software designed to be
@@ -2163,8 +2144,7 @@ track your position right from your laptop.")
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((shell (string-append (assoc-ref inputs "bash")
- "/bin/bash")))
+ (let ((shell (search-input-file inputs "/bin/bash")))
(setenv "SHELL" shell)
(setenv "CONFIG_SHELL" shell)
(setenv "LDFLAGS" (string-append "-Wl,-rpath -Wl,"
@@ -2337,8 +2317,7 @@ growing set of geoscientific methods.")
(replace 'check
(lambda* (#:key inputs #:allow-other-keys)
(setenv "HOME" "/tmp")
- (system (string-append (assoc-ref inputs "xorg-server")
- "/bin/Xvfb :1 &"))
+ (system "Xvfb :1 &")
(setenv "DISPLAY" ":1")
(setenv "TRAVIS" "true")
(setenv "CTEST_OUTPUT_ON_FAILURE" "1")
@@ -2360,6 +2339,7 @@ growing set of geoscientific methods.")
"PyCoreAdittions"
"PyQgsAnnotation"
"PyQgsAppStartup"
+ "PyQgsAuthBasicMethod"
"PyQgsAuthenticationSystem"
"PyQgsAuxiliaryStorage"
"PyQgsDBManagerGpkg"