summaryrefslogtreecommitdiff
path: root/gnu/packages/geeqie.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geeqie.scm')
-rw-r--r--gnu/packages/geeqie.scm108
1 files changed, 0 insertions, 108 deletions
diff --git a/gnu/packages/geeqie.scm b/gnu/packages/geeqie.scm
deleted file mode 100644
index 509819e780..0000000000
--- a/gnu/packages/geeqie.scm
+++ /dev/null
@@ -1,108 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages geeqie)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module ((guix licenses) #:prefix l:)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages autotools)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages ghostscript)
- #:use-module (gnu packages glib)
- #:use-module (gnu packages gtk)
- #:use-module (gnu packages image)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages xml))
-
-(define-public exiv2 ; XXX: move elsewhere?
- (package
- (name "exiv2")
- (version "0.25")
- (source (origin
- (method url-fetch)
- (uri (list (string-append "http://www.exiv2.org/exiv2-"
- version ".tar.gz")
- (string-append "https://fossies.org/linux/misc/exiv2-"
- version ".tar.gz")))
- (sha256
- (base32
- "197g6vgcpyf9p2cwn5p5hb1r714xsk1v4p96f5pv1z8mi9vzq2y8"))))
- (build-system gnu-build-system)
- (arguments '(#:tests? #f)) ; no `check' target
- (propagated-inputs
- `(("expat" ,expat)
- ("zlib" ,zlib)))
- (native-inputs
- `(("intltool" ,intltool)))
- (home-page "http://www.exiv2.org/")
- (synopsis "Library and command-line utility to manage image metadata")
- (description
- "Exiv2 is a C++ library and a command line utility to manage image
-metadata. It provides fast and easy read and write access to the Exif, IPTC
-and XMP metadata of images in various formats.")
-
- ;; Files under `xmpsdk' are a copy of Adobe's XMP SDK, licensed under the
- ;; 3-clause BSD license: <http://www.adobe.com/devnet/xmp/sdk/eula.html>.
- ;; The core is GPLv2+:
- ;; <https://launchpad.net/ubuntu/precise/+source/exiv2/+copyright>.
- (license l:gpl2+)))
-
-(define-public geeqie
- (package
- (name "geeqie")
- (version "1.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/BestImageViewer/geeqie/"
- "releases/download/v" version "/geeqie-"
- version ".tar.xz"))
- (sha256
- (base32
- "0gzc82sy66pbsmq7lnmq4y37zqad1zfwfls3ik3dmfm8s5nmcvsb"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'autogen
- (lambda _
- (setenv "NOCONFIGURE" "true")
- (zero? (system* "sh" "autogen.sh")))))))
- (inputs
- `(;; ("libchamplain" ,libchamplain)
- ("lcms" ,lcms)
- ("exiv2" ,exiv2)
- ("libpng" ,libpng)
- ("gtk+" ,gtk+-2)))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("glib" ,glib "bin") ; glib-gettextize
- ("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
- (home-page "http://www.geeqie.org/")
- (synopsis "Lightweight GTK+ based image viewer")
- (description
- "Geeqie is a lightweight GTK+ based image viewer for Unix like operating
-systems. It features: EXIF, IPTC and XMP metadata browsing and editing
-interoperability; easy integration with other software; geeqie works on files
-and directories, there is no need to import images; fast preview for many raw
-image formats; tools for image comparison, sorting and managing photo
-collection. Geeqie was initially based on GQview.")
- (license l:gpl2+)))