summaryrefslogtreecommitdiff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index aea1a9730d..8826eb44ee 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -51,7 +51,17 @@
(lambda _
(for-each patch-makefile-SHELL
(find-files "." "Makefile\\.in")))
- %standard-phases)))
+ (alist-cons-after
+ 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Like Binutils, GDB installs libbfd and libopcodes.
+ ;; However, this leads to collisions when both are
+ ;; installed, and really is none of its business,
+ ;; conceptually. So remove them.
+ (for-each delete-file
+ (find-files (assoc-ref outputs "out")
+ "^lib(opcodes|bfd)\\.")))
+ %standard-phases))))
(inputs
`(("expat" ,expat)
("mpfr" ,mpfr)