summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm28
1 files changed, 1 insertions, 27 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index bcaab30886..279cc8d950 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -24,6 +24,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages texinfo)
+ #:use-module (gnu packages elf)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -324,30 +325,3 @@ CLooG is designed to avoid control overhead and to produce a very
effective code.")
(license gpl2+)))
-(define-public libelf
- (package
- (name "libelf")
- (version "0.8.13")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.mr511.de/software/libelf-"
- version ".tar.gz"))
- (sha256
- (base32
- "0vf7s9dwk2xkmhb79aigqm0x0yfbw1j0b9ksm51207qwr179n6jr"))))
- (build-system gnu-build-system)
- (arguments '(#:phases (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; This old `configure' script doesn't support
- ;; variables passed as arguments.
- (let ((out (assoc-ref outputs "out")))
- (setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)))))
- %standard-phases)))
- (home-page "http://www.mr511.de/software/english.html")
- (synopsis "An ELF object file access library")
- (description "libelf is a C library to access ELF object files.")
- (license lgpl2.0+)))