summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm43
1 files changed, 17 insertions, 26 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3909a6c5a9..c913d99334 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4390,8 +4390,8 @@ OpenGFX provides you with...
(arguments
`(#:make-flags
(list (string-append "DIR_NAME=opensfx")
- (string-append "TAR=" (assoc-ref %build-inputs "tar")
- "/bin/tar"))
+ (string-append "TAR="
+ (search-input-file %build-inputs "/bin/tar")))
;; The check phase only verifies md5sums, see openttd-opengfx.
#:tests? #f
#:phases
@@ -4440,8 +4440,8 @@ the original Transport Tycoon Deluxe.")
(arguments
`(#:make-flags
(list (string-append "DIR_NAME=openmsx")
- (string-append "TAR=" (assoc-ref %build-inputs "tar")
- "/bin/tar"))
+ (string-append "TAR="
+ (search-input-file %build-inputs "/bin/tar")))
;; The check phase only verifies md5sums, see openttd-opengfx.
#:tests? #f
#:phases
@@ -4513,7 +4513,7 @@ Transport Tycoon Deluxe.")
(openrct2-title-sequences (string-append out
"/share/openrct2/title-sequences"))
(source (assoc-ref %build-inputs "source"))
- (unzip (string-append (assoc-ref %build-inputs "unzip") "/bin/unzip")))
+ (unzip (search-input-file %build-inputs "/bin/unzip")))
(copy-file source (string-append ,name "-" ,version ".zip"))
(invoke unzip (string-append ,name "-" ,version ".zip"))
(delete-file (string-append ,name "-" ,version ".zip"))
@@ -4553,7 +4553,7 @@ Transport Tycoon Deluxe.")
(openrct2-objects (string-append out
"/share/openrct2/objects"))
(source (assoc-ref %build-inputs "source"))
- (unzip (string-append (assoc-ref %build-inputs "unzip") "/bin/unzip")))
+ (unzip (search-input-file %build-inputs "/bin/unzip")))
(copy-file source (string-append ,name "-" ,version ".zip"))
(invoke unzip (string-append ,name "-" ,version ".zip"))
(delete-file (string-append ,name "-" ,version ".zip"))
@@ -5714,14 +5714,10 @@ colors, pictures, and sounds.")
(script (string-append out "/bin/" ,name))
(data (string-append out "/share/" ,name))
(source (assoc-ref %build-inputs "source"))
- (unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip"))
- (patch (string-append (assoc-ref %build-inputs "patch")
- "/bin/patch"))
- (bash (string-append (assoc-ref %build-inputs "bash")
- "/bin/bash"))
- (love (string-append (assoc-ref %build-inputs "love")
- "/bin/love")))
+ (unzip (search-input-file %build-inputs "/bin/unzip"))
+ (patch (search-input-file %build-inputs "/bin/patch"))
+ (bash (search-input-file %build-inputs "/bin/bash"))
+ (love (search-input-file %build-inputs "/bin/love")))
(mkdir-p (dirname script))
(with-output-to-file script
@@ -6683,7 +6679,7 @@ fight against their plot and save his fellow rabbits from slavery.")
(use-modules (guix build utils))
(let ((out (assoc-ref %outputs "out"))
(source (assoc-ref %build-inputs "source"))
- (tar (string-append (assoc-ref %build-inputs "tar") "/bin/tar"))
+ (tar (search-input-file %build-inputs "/bin/tar"))
(xz-path (string-append (assoc-ref %build-inputs "xz") "/bin")))
(setenv "PATH" xz-path)
(mkdir out)
@@ -7758,7 +7754,7 @@ quotation from a collection of quotes.")
(let* ((out (assoc-ref %outputs "out"))
(xonotic (string-append out "/share/xonotic"))
(source (assoc-ref %build-inputs "source"))
- (unzip (string-append (assoc-ref %build-inputs "unzip") "/bin/unzip")))
+ (unzip (search-input-file %build-inputs "/bin/unzip")))
(copy-file source (string-append ,name "-" ,version ".zip"))
(invoke unzip (string-append ,name "-" ,version ".zip"))
(mkdir-p out)
@@ -9547,8 +9543,7 @@ on items and player adaptability for character progression.")
(share (string-append out "/share/drascula"))
(scummvm (assoc-ref %build-inputs "scummvm")))
;; Install data.
- (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip"))
+ (let ((unzip (search-input-file %build-inputs "/bin/unzip"))
(doc (string-append out "/share/doc/" ,name "-" ,version)))
(for-each
(lambda (input)
@@ -9574,8 +9569,7 @@ on items and player adaptability for character progression.")
;; Create standalone executable.
(let* ((bin (string-append out "/bin"))
(executable (string-append bin "/drascula"))
- (bash (string-append (assoc-ref %build-inputs "bash")
- "/bin/bash")))
+ (bash (search-input-file %build-inputs "/bin/bash")))
(mkdir-p bin)
(with-output-to-file executable
(lambda ()
@@ -9665,8 +9659,7 @@ the World and demonstrating that he is even more evil than his brother Vlad.")
(bin (string-append out "/bin"))
(executable (string-append bin "/" ,name))
(scummvm (assoc-ref %build-inputs "scummvm")))
- (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip")))
+ (let ((unzip (search-input-file %build-inputs "/bin/unzip")))
(invoke unzip "-j" (assoc-ref %build-inputs "source")))
(let ((doc (string-append share "/doc/" ,name "-" ,version)))
(for-each (lambda (f) (install-file f doc))
@@ -9772,8 +9765,7 @@ Skorl. Maybe it would be an idea to try and escape...")
(bin (string-append out "/bin"))
(executable (string-append bin "/" ,name))
(scummvm (assoc-ref %build-inputs "scummvm")))
- (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip")))
+ (let ((unzip (search-input-file %build-inputs "/bin/unzip")))
(invoke unzip "-j" (assoc-ref %build-inputs "source")))
(let ((doc (string-append share "/doc/" ,name "-" ,version)))
(install-file "readme.txt" doc))
@@ -9871,8 +9863,7 @@ women and 6-foot-tall pygmies.")
(bin (string-append out "/bin"))
(executable (string-append bin "/" ,name))
(scummvm (assoc-ref %build-inputs "scummvm")))
- (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip")))
+ (let ((unzip (search-input-file %build-inputs "/bin/unzip")))
(invoke unzip "-j" (assoc-ref %build-inputs "source")))
(let ((doc (string-append share "/doc/bass-" ,version)))
(install-file "readme.txt" doc))