summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm40
1 files changed, 22 insertions, 18 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a04814d461..485f356495 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1181,7 +1181,8 @@ exec ~a/bin/freedink -refdir ~a/share/dink\n"
(assoc-ref %build-inputs "bash")
(assoc-ref %build-inputs "engine")
(assoc-ref %build-inputs "data"))
- (chmod port #o777)))))
+ (chmod port #o777)))
+ #t))
#:modules ((guix build utils))))
(inputs `(("engine" ,freedink-engine)
("data" ,freedink-data)
@@ -1440,10 +1441,11 @@ match, cannon keep, and grave-itation pit.")
"gzip")
"/bin")))
(setenv "PATH" path)
- (system* tar "xvf" (assoc-ref %build-inputs "source"))
+ (invoke tar "xvf" (assoc-ref %build-inputs "source"))
(chdir (string-append "minetest_game-" ,version))
(mkdir-p install-dir)
- (copy-recursively "." install-dir)))))
+ (copy-recursively "." install-dir)
+ #t))))
(synopsis "Main game data for the Minetest game engine")
(description
"Game data for the Minetest infinite-world block sandox game.")
@@ -2612,18 +2614,19 @@ Red Eclipse provides fast paced and accessible gameplay.")
(bin (string-append out "/bin"))
(doc (string-append out
"/share/doc/grue-hunter")))
- (begin
- (copy-file tarball "grue-hunter.tar.gz")
- (zero? (system* gzip "-d" "grue-hunter.tar.gz"))
- (zero? (system* tar "xvf" "grue-hunter.tar"))
-
- (mkdir-p bin)
- (copy-file "grue-hunter/gh.pl"
- (string-append bin "/grue-hunter"))
- (patch-shebang (string-append bin "/grue-hunter")
- (list perl))
-
- (install-file "grue-hunter/AGPLv3.txt" doc))))))
+ (copy-file tarball "grue-hunter.tar.gz")
+ (invoke gzip "-d" "grue-hunter.tar.gz")
+ (invoke tar "xvf" "grue-hunter.tar")
+
+ (mkdir-p bin)
+ (copy-file "grue-hunter/gh.pl"
+ (string-append bin "/grue-hunter"))
+ (patch-shebang (string-append bin "/grue-hunter")
+ (list perl))
+
+ (install-file "grue-hunter/AGPLv3.txt" doc)
+
+ #t))))
(inputs `(("perl" ,perl)
("tar" ,tar)
("gzip" ,gzip)
@@ -2930,11 +2933,12 @@ your child be creative.")
(string-append
(assoc-ref %build-inputs "tar") "/bin" ":"
(assoc-ref %build-inputs "gzip") "/bin"))
- (system* "tar" "xvf" (assoc-ref %build-inputs "source"))
+ (invoke "tar" "xvf" (assoc-ref %build-inputs "source"))
(chdir (string-append ,name "-" ,version))
(let ((dir (string-append %output "/share/tuxpaint/stamps")))
(mkdir-p dir)
- (copy-recursively "stamps" dir)))))
+ (copy-recursively "stamps" dir))
+ #t)))
(home-page (package-home-page tuxpaint))
(synopsis "Stamp images for Tux Paint")
(description
@@ -4087,7 +4091,7 @@ fight against their plot and save his fellow rabbits from slavery.")
(xz-path (string-append (assoc-ref %build-inputs "xz") "/bin")))
(setenv "PATH" xz-path)
(mkdir out)
- (zero? (system* tar "xvf" source "-C" out "--strip=3"))))))
+ (invoke tar "xvf" source "-C" out "--strip=3")))))
(synopsis "Data files for 0ad")
(description "0ad-data provides the data files required by the game 0ad.")
(home-page "https://play0ad.com")