summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index eb2563387f..e2c6a7ebc4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2016 Albin Söderqvist <albin@fripost.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Steve Webber <webber.sl@gmail.com>
;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@hyperbola.info>
@@ -2086,8 +2086,8 @@ Every puzzle has a complete solution, although there may be more than one.")
(license license:gpl2+)))
(define-public retux
- (let ((release "1.4.1")
- (revision 1))
+ (let ((release "1.5")
+ (revision 0))
(package
(name "retux")
(version (if (zero? revision)
@@ -2099,10 +2099,10 @@ Every puzzle has a complete solution, although there may be more than one.")
(uri (string-append "https://github.com/retux-game/retux/"
"releases/download/v"
version "/retux-"
- release "-src.tar.gz"))
+ release "-src.zip"))
(sha256
(base32
- "1vrldg2qh2gqfswj7vkpc589ldrrjd903j6cnfdik9zh0jhlq4h2"))))
+ "1yima7s36hn2kh5h08lczc5iid8jbdxk7x1g5ms6knaznzj7rll3"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; no check target
@@ -2125,6 +2125,8 @@ Every puzzle has a complete solution, although there may be more than one.")
(copy-file "retux.py" (string-append bin "/retux"))
(copy-recursively "data" data)
#t))))))
+ (native-inputs
+ `(("unzip" ,unzip)))
(inputs
`(("python-sge-pygame" ,python-sge-pygame)
("python-six" ,python-six)
@@ -3154,7 +3156,7 @@ asynchronously and at a user-defined speed.")
(define-public chess
(package
(name "chess")
- (version "6.2.7")
+ (version "6.2.8")
(source
(origin
(method url-fetch)
@@ -3162,7 +3164,7 @@ asynchronously and at a user-defined speed.")
".tar.gz"))
(sha256
(base32
- "0ilq4bfl0lwyzf11q7n2skydjhalfn3bgxhrp5hjxs5bc5d6fdp5"))))
+ "0irqb0wl30c2i1rs8f6mm1c89l7l9nxxv7533lr408h1m36lc16m"))))
(build-system gnu-build-system)
(arguments
'(#:phases