summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm81
1 files changed, 71 insertions, 10 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8be87f6f55..ec92f508bc 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -364,6 +364,59 @@ played. Freedoom complements the Doom engine with free levels, artwork, sound
effects and music to make a completely free game.")
(license license:bsd-3)))
+(define-public freedroidrpg
+ (package
+ (name "freedroidrpg")
+ (version "0.16.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://ftp.osuosl.org/pub/freedroid/"
+ "freedroidRPG-" (version-major+minor version) "/"
+ "freedroidRPG-" version ".tar.gz"))
+ (sha256
+ (base32 "0n4kn38ncmcy3lrxmq8fjry6c1z50z4q1zcqfig0j4jb0dsz2va2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ (string-append "CFLAGS="
+ "-I" (assoc-ref %build-inputs "sdl-gfx") "/include/SDL "
+ "-I" (assoc-ref %build-inputs "sdl-image") "/include/SDL "
+ "-I" (assoc-ref %build-inputs "sdl-mixer") "/include/SDL")
+ "--enable-opengl")
+ ;; FIXME: the test suite fails with the following error output:
+ ;; 4586 Segmentation fault env SDL_VIDEODRIVER=dummy \
+ ;; SDL_AUDIODRIVER=dummy ./src/freedroidRPG -nb text
+ #:tests? #f))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glu" ,glu)
+ ("libjpeg" ,libjpeg)
+ ("libogg" ,libogg)
+ ("libpng" ,libpng)
+ ("libvorbis" ,libvorbis)
+ ("mesa" ,mesa)
+ ("python" ,python-wrapper)
+ ("sdl" ,sdl)
+ ("sdl-gfx" ,sdl-gfx)
+ ("sdl-image" ,sdl-image)
+ ("sdl-mixer" ,sdl-mixer)
+ ("zlib" ,zlib)))
+ (home-page "http://www.freedroid.org/")
+ (synopsis "Isometric role-playing game against killer robots")
+ (description
+ "Freedroid RPG is an @dfn{RPG} (Role-Playing Game) with isometric graphics.
+The game tells the story of a world destroyed by a conflict between robots and
+their human masters. To restore peace to humankind, the player must complete
+numerous quests while fighting off rebelling robots---either by taking control
+of them, or by simply blasting them to pieces with melee and ranged weapons in
+real-time combat.")
+ (license (list license:expat ; lua/
+ license:gpl3 ; src/gen_savestruct.py
+ license:gpl2+)))) ; the rest
+
(define-public golly
(package
(name "golly")
@@ -2122,28 +2175,36 @@ on the screen and keyboard to display letters.")
(define-public raincat
(package
(name "raincat")
- (version "1.1.1.3")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
- (uri (string-append
- "http://hackage.haskell.org/package/Raincat/Raincat-"
- version
- ".tar.gz"))
+ (uri (string-append "http://hackage.haskell.org/package/Raincat/"
+ "Raincat-" version ".tar.gz"))
(sha256
(base32
- "1aalh68h6799mv4vyg30zpskl5jkn6x2j1jza7p4lrflyifxzar8"))))
+ "10y9zi22m6hf13c9h8zd9vg7mljpwbw0r3djb6r80bna701fdf6c"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/raincat")
+ `("LD_LIBRARY_PATH" ":" =
+ (,(string-append (assoc-ref inputs "freeglut")
+ "/lib"))))
+ #t))))))
(inputs
`(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
- ("ghc-mtl" ,ghc-mtl)
("ghc-random" ,ghc-random)
("ghc-glut" ,ghc-glut)
("freeglut" ,freeglut)
("ghc-opengl" ,ghc-opengl)
- ("ghc-sdl" ,ghc-sdl)
- ("ghc-sdl-image" ,ghc-sdl-image)
- ("ghc-sdl-mixer" ,ghc-sdl-mixer)))
+ ("ghc-sdl2" ,ghc-sdl2)
+ ("ghc-sdl2-image" ,ghc-sdl2-image)
+ ("ghc-sdl2-mixer" ,ghc-sdl2-mixer)))
(home-page "http://www.bysusanlin.com/raincat/")
(synopsis "Puzzle game with a cat in lead role")
(description "Project Raincat is a game developed by Carnegie Mellon