summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm30
1 files changed, 1 insertions, 29 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9c02d88eab..ff3239a22c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -33,6 +33,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages audio)
#:use-module (gnu packages boost)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
@@ -512,35 +513,6 @@ alternative layouts Dvorak and Colemak, as well as for the numpad. Tutorials
are primarily in English, however some in other languages are provided.")
(license license:gpl3+)))
-(define-public openal
- (package
- (name "openal")
- (version "1.15.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://kcat.strangesoft.net/openal-releases/openal-soft-"
- version ".tar.bz2"))
- (sha256
- (base32
- "0mmhdqiyb3c9dzvxspm8h2v8jibhi8pfjxnf6m0wn744y1ia2a8f"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f)) ; no check target
- (inputs
- `(("alsa-lib" ,alsa-lib)
- ("pulseaudio" ,pulseaudio)))
- (synopsis "3D audio API")
- (description
- "OpenAL provides capabilities for playing audio in a virtual 3D
-environment. Distance attenuation, doppler shift, and directional sound
-emitters are among the features handled by the API. More advanced effects,
-including air absorption, occlusion, and environmental reverb, are available
-through the EFX extension. It also facilitates streaming audio, multi-channel
-buffers, and audio capture.")
- (home-page "http://kcat.strangesoft.net/openal.html")
- (license license:lgpl2.0+)))
-
(define-public irrlicht
(package
(name "irrlicht")