summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0d50f55a75..0dcf7eb879 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6118,3 +6118,30 @@ to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
(home-page "https://www.stepmania.com")
(license license:expat)))
+
+(define-public slingshot
+ (package
+ (name "slingshot")
+ (version "0.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ryanakca/slingshot.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19m8b6nsi786bc6gmkp185mwri3r5y249gjmqd5qsc23nnfhgrs1"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (inputs
+ `(("python-pygame" ,python2-pygame)))
+ (home-page "https://github.com/ryanakca/slingshot")
+ (synopsis "Simple 2D shooting strategy game set in space")
+ (description "Slingshot is a two-dimensional strategy game where two
+players attempt to shoot one another through a section of space populated by
+planets. The main feature of the game is that the shots, once fired, are
+affected by the gravity of the planets.")
+ (license license:gpl2+)))