summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e01ad3c8d2..c80335a1ea 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3568,6 +3568,10 @@ are primarily in English, however some in other languages are provided.")
;; The actual source is buried a few directories deep.
(chdir "source/Irrlicht/")
#t))
+ (add-after 'chdir-to-source 'remove-<sys/sysctl.h>
+ (lambda _
+ (substitute* "COSOperator.cpp"
+ (("#include <sys/sysctl.h>") ""))))
(add-after 'chdir-to-source 'fix-build-env
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))