summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f601e96035..b1de90cf24 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9275,9 +9275,10 @@ levels to unlock.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- ;; Skip tests that require internet access.
- (invoke "ctest" "-E" "(http|dns)"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Skip tests that require internet access.
+ (invoke "ctest" "-E" "(http|dns)")))))))
(inputs
`(("boost" ,boost-for-mysql) ; fails with 1.69
("curl" ,curl)