summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9c782303e2..6100ca79d7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1533,7 +1533,6 @@ fully interactive graphical interface and it can load and save games in the
Portable Game Notation.")
(license license:gpl3+)))
-
(define-public xboing
(package
(name "xboing")
@@ -1564,14 +1563,11 @@ Portable Game Notation.")
;; FIXME: HIGH_SCORE_FILE should be set to somewhere writeable
- (zero? (system* "xmkmf" "-a"
- (string-append "-DProjectRoot="
- (assoc-ref outputs "out"))))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (and
- (zero? (system* "make" "install.man"))
- (zero? (system* "make" "install"))))))))
+ (invoke "xmkmf" "-a"
+ (string-append "-DProjectRoot="
+ (assoc-ref outputs "out")))))
+ (add-before 'install 'install-man-pages
+ (lambda _ (invoke "make" "install.man"))))))
(inputs `(("libx11" ,libx11)
("libxext" ,libxext)
("libxpm" ,libxpm)))