summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm58
1 files changed, 47 insertions, 11 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index ea1adf0ecf..ae313a8edf 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015, 2016, 2017 David Thompson <davet@gnu.org>
;;; Copyright © 2016-2021, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017, 2020 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2018, 2019, 2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Julian Graham <joolean@gmail.com>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
@@ -58,6 +58,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system scons)
#:use-module (gnu packages)
@@ -115,6 +116,7 @@
#:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages stb)
+ #:use-module (gnu packages swig)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
@@ -453,6 +455,40 @@ compiling NML files (along with their associated language, sound and graphic
files) into @file{.grf} and/or @file{.nfo} files.")
(license license:gpl2+)))
+(define-public python-pybox2d
+ (package
+ (name "python-pybox2d")
+ (version "2.3.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pybox2d/pybox2d")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dha28yscr1lpyzy9ygqc01a8pyf7n9vavyxikqh469wr2zcacna"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; It is not clear how to run the tests
+ #:tests? #false
+ #:phases
+ '(modify-phases %standard-phases
+ (add-before 'build 'build-ext
+ (lambda _
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ (native-inputs (list swig))
+ (home-page "https://github.com/pybox2d/pybox2d")
+ (synopsis "2D game physics for Python")
+ (description
+ "Pybox2d is a 2D physics library for your games and simple simulations.
+It's based on the Box2D library, written in C++. It supports several shape
+types (circle, polygon, thin line segments), and quite a few joint
+types (revolute, prismatic, wheel, etc.).")
+ (license license:zlib)))
+
(define-public python-sge
(package
(name "python-sge")
@@ -1275,13 +1311,13 @@ interface (API).")
(define-public python-pygame
(package
(name "python-pygame")
- (version "2.1.2")
+ (version "2.5.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "pygame" version))
(sha256
(base32
- "0g6j79naab7583kymf1bgxc5l5c9h5laq887rmvh8vw8iyifrl6n"))))
+ "0jn2n70hmgr33yc6xzdi33cs5w7jnmgi44smyxfarrrrsnsrxf61"))))
(build-system python-build-system)
(arguments
(list
@@ -1344,7 +1380,7 @@ and multimedia programs in the Python language.")
(define-public python-pygame-sdl2
(let ((real-version "2.1.0")
- (renpy-version "8.1.3"))
+ (renpy-version "8.2.0"))
(package
(inherit python-pygame)
(name "python-pygame-sdl2")
@@ -1354,7 +1390,7 @@ and multimedia programs in the Python language.")
(method url-fetch)
(uri (string-append "https://www.renpy.org/dl/" renpy-version
"/pygame_sdl2-" version ".tar.gz"))
- (sha256 (base32 "0qlprs9n3w254ilizqzvr6s01zx72gh7an0bgwxsq4hm22qypdws"))
+ (sha256 (base32 "17mc39c7ha83kzv2wmq61a15mn6p8wh2y33ixhf5sb4bvyr48mhy"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1395,7 +1431,7 @@ developed mainly for Ren'py.")
(define-public python-renpy
(package
(name "python-renpy")
- (version "8.1.3")
+ (version "8.2.0")
(source
(origin
(method url-fetch)
@@ -1403,7 +1439,7 @@ developed mainly for Ren'py.")
"/renpy-" version "-source.tar.bz2"))
(sha256
(base32
- "1g6fz5dxp7yxhgv6q4brzf5hpfqq3l1g3dfv3fsiwwn6mj0b01z2"))
+ "02v54qqjjigfqhdr50kzhkdvplk56bvprq65jl57kcs1qhvlf5s9"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -2038,7 +2074,7 @@ games.")
libxi
libxinerama
libxrandr
- mbedtls-apache
+ mbedtls-lts
mesa
opusfile
pcre2
@@ -2280,7 +2316,7 @@ scripted in a Python-like language.")
libxinerama
libxkbcommon
libxrandr
- mbedtls-apache
+ mbedtls-lts
mesa
openxr
opusfile
@@ -3228,7 +3264,7 @@ progresses the level, or you may regenerate tiles as the world changes.")
(define-public raylib
(package
(name "raylib")
- (version "4.5.0")
+ (version "5.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3238,7 +3274,7 @@ progresses the level, or you may regenerate tiles as the world changes.")
;; TODO: Unbundle src/external
(sha256
(base32
- "00y8fsa4g9fk93s3wihbxl929m84hw3fflr0h409s3i1kfmv7ajj"))))
+ "0327licmylwlh5iyzw35pq7ci2d15rp3jms5i9p0vfg1rlv2sjw0"))))
(build-system cmake-build-system)
(arguments
(list #:tests? #f ;no test