summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm57
1 files changed, 30 insertions, 27 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index b899c2fe6c..74ab51f8b3 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2018 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015, 2016, 2017 David Thompson <davet@gnu.org>
-;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Julian Graham <joolean@gmail.com>
@@ -313,30 +313,24 @@ provide connectivity for client applications written in any language.")
(define-public nml
(package
(name "nml")
- (version "0.4.5")
+ (version "0.5.2")
(source
(origin
(method url-fetch)
- (uri (string-append "http://bundles.openttdcoop.org/nml/releases/"
- version "/nml-" version ".tar.gz"))
+ (uri (pypi-uri "nml" version))
(sha256
(base32
- "1pmvvm3sgnpngfa7884mqhq3fwdjh9sr0ca07ypnidcg0y341w53"))))
+ "1lwf5sc5qqzrkxfx5wkkj3yh2j2nzh5r599ly5psy8yw92km24hy"))))
(build-system python-build-system)
+ ;; TODO: Fix test that fails with
+ ;; "AttributeError: partially initialized module 'nml.nmlop' has no
+ ;; attribute 'ADD' (most likely due to a circular import)"
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'fix-pillow
- (lambda _
- ;; pillow's version is not in PIL.Image.VERSION anymore
- (substitute* "nml/version_info.py"
- (("from PIL import Image") "import PIL")
- (("Image.VERSION") "PIL.__version__"))
- #t)))))
+ '(#:tests? #f))
(propagated-inputs
`(("python-pillow" ,python-pillow)
("python-ply" ,python-ply)))
- (home-page "https://dev.openttdcoop.org/projects/nml")
+ (home-page "https://github.com/OpenTTD/nml")
(synopsis "NML compiler")
(description
"@dfn{NewGRF Meta Language} (NML) is a python-based compiler, capable of
@@ -1495,16 +1489,17 @@ of use.")
(define-public openmw
(package
(name "openmw")
- (version "0.45.0")
+ (version "0.46.0")
(source
(origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/OpenMW/openmw/archive/"
- "openmw-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenMW/openmw")
+ (commit (string-append "openmw-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0r0wgvv1faan8z8lbply8lks4hcnppifjrcz04l5zvq6yiqzjg5n"))))
+ "0rm32zsmxvr6b0jjihfj543skhicbw5kg6shjx312clhlm035w2x"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; No test target
@@ -1743,20 +1738,25 @@ a 2D editor view.")
(define-public guile-chickadee
(package
(name "guile-chickadee")
- (version "0.4.0")
+ (version "0.5.0")
(source (origin
(method url-fetch)
(uri (string-append "https://files.dthompson.us/chickadee/"
"chickadee-" version ".tar.gz"))
(sha256
(base32
- "1fdicsgls5cp0yffcm5vjmav67gv9bxhz1s3jvdvinspxb485x7l"))))
+ "0y3s0p4zyghys48sayfhcbmxmflh8hwawnx5an2jlb3x84yr0dsx"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:make-flags '("GUILE_AUTO_COMPILE=0")))
(propagated-inputs
`(("guile-opengl" ,guile-opengl)
("guile-sdl2" ,guile-sdl2)))
(inputs
- `(("guile" ,guile-2.2)))
+ `(("guile" ,guile-2.2)
+ ("libvorbis" ,libvorbis)
+ ("mpg123" ,mpg123)
+ ("openal" ,openal)))
(native-inputs
`(("pkg-config" ,pkg-config)
("texinfo" ,texinfo)))
@@ -1779,20 +1779,23 @@ that parenthetically inclined game developers need to make 2D (and eventually
(package
(inherit guile-chickadee)
(name "guile3.0-chickadee")
- (version "0.4.0")
+ (version "0.5.0")
(source (origin
(method url-fetch)
(uri (string-append "https://files.dthompson.us/chickadee/"
"chickadee-" version ".tar.gz"))
(sha256
(base32
- "1fdicsgls5cp0yffcm5vjmav67gv9bxhz1s3jvdvinspxb485x7l"))))
+ "0y3s0p4zyghys48sayfhcbmxmflh8hwawnx5an2jlb3x84yr0dsx"))))
(build-system gnu-build-system)
(propagated-inputs
`(("guile-opengl" ,guile3.0-opengl)
("guile-sdl2" ,guile3.0-sdl2)))
(inputs
- `(("guile" ,guile-3.0)))
+ `(("guile" ,guile-3.0)
+ ("libvorbis" ,libvorbis)
+ ("mpg123" ,mpg123)
+ ("openal" ,openal)))
(native-inputs
`(("pkg-config" ,pkg-config)
("texinfo" ,texinfo)))